No Superkey with KDE

Hi -
Running Plasma 5.25.5 with kernel 5.15.72-1. Everything runs fine except there’s no Superkey functionality on this System76 Galago Pro 5. Can you point me to the config steps please?




How about going to “System Settings” >> Hardware > “Input Devices” > “Keyboard” > “Advanced” ?
Could this be what you are looking for ?

Or this:

1 Like

Hi -
Thx for the replies.

SoftExpert… followed the path to “Advanced” and selected “Meta is mapped to Win”, and in another attempt “Meta is mapped to Left Win”… No change. Ideas welcome. I assume that’s the right selection but am not sure. My goal is for the Super key (Meta Key) to pop up the KDE main menu.

NGr… I think KDE Kicker is the panel but there’s no option for Configure Application Launcher.

What is the output of xev for the key you want to use ?

The keyboard settings must be changed to <your keyboard> and no dead keys.

I’ve had this issue before on several distros. I don’t like KDE but tried it many times. I want to say that the issue is the “start” in the bottom left corner of the panel? If you’ve changed it to use another version sometimes the shortcut key is blank. I am going by memory and my memory isn’t that great :slight_smile: . CTRL-Enter or CTRL-Space, CTRL-ALT as the short cut fixes it? Not what you would expect but it fixed it for me in the past. I just can’t remember the combo.

I am fairly certain you could do any key combo you want in the configuration for the menu widget and the meta key will start working again.