No Sound on iMac 5k (iMac 19.1) ''27 2019

imac 19.1 is no clearifying information to deal with for others.

1 Like

See iMac Unibody - ArchWiki
or iMac Aluminum - ArchWiki

1 Like

Its iMac 5k 2019
Model Number: MRR12D/A

Thx bogdancovaciu,

echo 'options snd-hda-intel model=imac27' >> /etc/modprobe.d/sound.conf' && reboot

but with no success at all.

Correct way to do it is:

echo 'options snd-hda-intel model=imac27' | sudo tee -a /etc/modprobe.d/sound.conf

you simply rebooted your system and no file was created …

1 Like

somehow the file has been created (see timestamp), but its still not working even after reboot.

[binary@manjaro /]$ ls -l /etc/modprobe.d/sound.conf 
-rw-r--r-- 1 root root 35 21. Mai 14:48 /etc/modprobe.d/sound.conf
[binary@manjaro /]$ cat !$
cat /etc/modprobe.d/sound.conf
options snd-hda-intel model=imac27
[binary@manjaro /]$

first things first, what driver is installed ? could you give us any information that are useful instead of guessing what ? A minimum is the basic inxi-information from everyone who asks for help !

Thx for your help.

Thats exactly the reason I wrote “Please let me know which else information is needed”. Well as my manjaro is a fresh “out-of-the-box” install, I’ve no idea which driver is installed or where I can get the information from as Im quite new to arch and linux in general.

In my quote of the first post are the most outputs of infos I received when I was googleing for help

CPU: 6-core Intel Core i5-9600K (-MCP-) speed/min/max: 900/800/4600 MHz
Kernel: 5.15.38-1-MANJARO x86_64 Up: 2h 20m Mem: 3826.0/7828.5 MiB (48.9%)
Storage: 2.86 TiB (0.5% used) Procs: 250 Shell: Bash inxi: 3.3.16
  1. Please read this:
    [HowTo] Provide System Information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.
1 Like

Hey Olli,

done :slight_smile:

The output is within my original post now and also here:

inxi --admin --verbosity=7 --filter --no-host --width
  Kernel: 5.15.38-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=34e4f9a9-2c85-450c-bec3-0e721a7fbde6 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.3 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Apple product: iMac19,1 v: 1.0
    serial: <superuser required> Chassis: type: 9 v: Mac-AA95B1DDAB278B95
    serial: <superuser required>
  Mobo: Apple model: Mac-AA95B1DDAB278B95 v: iMac19,1
    serial: <superuser required> UEFI: Apple v: 1731.
    date: 01/20/2022
  Device-1: hid-94:f6:d6:b7:21:dc-battery model: Setup Users Maus serial: N/A
    charge: N/A status: discharging
  RAM: total: 7.64 GiB used: 3.42 GiB (44.8%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i5-9600K bits: 64 type: MCP arch: Coffee Lake
    family: 6 model-id: 0x9E (158) stepping: 0xC (12) microcode: 0xEC
  Topology: cpus: 1x cores: 6 smt: <unsupported> cache: L1: 384 KiB
    desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB L3: 9 MiB
    desc: 1x9 MiB
  Speed (MHz): avg: 800 min/max: 800/4600 scaling: driver: intel_pstate
    governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800
    bogomips: 44412
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush clflushopt
    cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts
    epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr
    ht hwp hwp_act_window hwp_epp ibpb ibrs ida intel_pt invpcid
    invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr
    nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln
    pni popcnt pse pse36 pts rdrand rdseed rdtscp rep_good sdbg sep smap smep
    smx ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow
    tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave
    xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: disabled, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: Apple driver: amdgpu v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    ports: active: eDP-1 empty: DP-1,DP-2,DP-3 bus-ID: 01:00.0
    chip-ID: 1002:67df class-ID: 0300
  Device-2: Apple FaceTime HD Camera (Built-in) type: USB driver: uvcvideo
    bus-ID: 1-13:4 chip-ID: 05ac:8511 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.3 compositor: kwin_x11 driver: X:
    loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa gpu: amdgpu
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 96 s-size: 1016x571mm (40.00x22.48")
    s-diag: 1165mm (45.88")
  Monitor-1: eDP-1 mapped: eDP model: Apple iMac serial: <filter>
    built: 2018 res: 3840x2160 hz: 60 dpi: 163 gamma: 1.2
    size: 597x336mm (23.5x13.23") diag: 685mm (27") ratio: 16:9 modes:
    max: 3840x2160 min: 640x480
  OpenGL: renderer: AMD POLARIS10 (LLVM 13.0.1 DRM 3.42 5.15.38-1-MANJARO)
    v: 4.6 Mesa 22.0.3 direct render: Yes
  Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:a348 class-ID: 0403
  Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 1002:aaf0 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.38-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.51 running: yes
  Device-1: Broadcom BCM4364 802.11ac Wireless Network Adapter vendor: Apple
    driver: N/A modules: brcmfmac pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 03:00.0 chip-ID: 14e4:4464 class-ID: 0280
  Device-2: Broadcom NetXtreme BCM57766 Gigabit Ethernet PCIe driver: tg3
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: N/A bus-ID: 04:00.0
    chip-ID: 14e4:1686 class-ID: 0200
  IF: enp4s0f0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 2.86 TiB used: 13.77 GiB (0.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Apple model: SSD SM0128L
    size: 113 GiB block-size: physical: 4096 B logical: 4096 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: CXS7LA0Q temp: 25.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Apple model: HDD ST2000DM001
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: AQ03 scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Western Digital
    model: WD My Passport 25F3 size: 953.84 GiB block-size: physical: 512 B
    logical: 512 B type: N/A serial: <filter> rev: 1006 scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 953.54 GiB size: 937.5 GiB (98.32%) used: 13.77 GiB (1.5%)
    fs: ext4 dev: /dev/sdc2 maj-min: 8:34 label: N/A
    uuid: 34e4f9a9-2c85-450c-bec3-0e721a7fbde6
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/sdc1 maj-min: 8:33 label: NO_LABEL
    uuid: 4140-2272
  Alert: No swap data was found.
  ID-1: /dev/nvme0n1p1 maj-min: 259:1 size: 300 MiB fs: vfat label: EFI
    uuid: 5F66-17ED
  ID-2: /dev/nvme0n1p2 maj-min: 259:2 size: 112.71 GiB fs: apfs label: N/A
    uuid: cf1cced7-fc2f-4caf-a35d-dac9772e5e29
  ID-3: /dev/sda1 maj-min: 8:1 size: 200 MiB fs: vfat label: EFI
    uuid: 67E3-17ED
  ID-4: /dev/sda2 maj-min: 8:2 size: 1.82 TiB fs: apfs label: N/A
    uuid: cf1cced7-fc2f-4caf-a35d-dac9772e5e29
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-5:2 info: Apple Magic Keyboard with Numeric Keypad
    type: HID,Keyboard driver: apple,usbhid interfaces: 2 rev: 2.0
    speed: 12 Mb/s power: 500mA chip-ID: 05ac:026c class-ID: 0301
    serial: <filter>
  Device-2: 1-12:3 info: Western Digital My Passport SSD (WDBK3E)
    type: Mass Storage driver: usb-storage interfaces: 1 rev: 2.1
    speed: 480 Mb/s power: 500mA chip-ID: 1058:25f3 class-ID: 0806
    serial: <filter>
  Device-3: 1-13:4 info: Apple FaceTime HD Camera (Built-in) type: Video
    driver: uvcvideo interfaces: 3 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 05ac:8511 class-ID: 0e02 serial: <filter>
  Hub-2: 2-0:1 info: Super-speed hub ports: 10 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 4-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 49.0 C pch: 58.0 C mobo: N/A gpu: amdgpu
    temp: 48.0 C
  Fan Speeds (RPM): N/A
  Processes: 247 Uptime: 2h 32m wakeups: 9 Init: systemd v: 250
  tool: systemctl Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1221
  lib: 338 flatpak: 0 Shell: Bash v: 5.1.16 running-in: guake inxi: 3.3.16

searching the internet brings up the simple answer: there is no way to linux to support audio of this apple-crap. thanks to the apple-developers that did the tricks to be total incompatible. you can wait for years until a solution might be able under linux and you can waste a lot of time with useless attempts to get it running. the only really working solution that works today is to buy a usb-audio stick (there are a lot of them) and replace the internal audio with that. otherwise you have to use apple-os.
i wouldn’t waste any more time for this ugly problem, a good audio-stick that is working flawless with linux is less than 20 bucks and solves the problem faster, better and without headache.

There was another discussion about it here

The thing is

both servers are running.
might want to stick to just one …

PulseAudio should not be running/installed at the same time as Pipewire, but alsa should be, should look like this:

Sound Server-1: ALSA v: k5.17.6-1-MANJARO running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.51 running: yes

Alsa k5 number is the Kernel version, so yours is correct for Kernel 5.15.
I’m not even sure how you got Pipewire and PulseAudio running at the same time.

Try running/installing/reinstalling package “manjaro-pipewire” and see if that tells you what files are conflicting/have dependency errors, then remove them, until “manjaro-pipewire” installs with out errors.

or do it the other way and try package “manjaro-pulse” to remove Pipewire.

I had the same issue for a long time, and solved it yesterday by install the Sound Driver for Cirrus Logic CS8409 for iMac27-5k from github.

  1. get the kernel version:
    uname -r
  2. Install package linux-headers, select the same version with kernel (with root user or sudo):
    pacman -S linux-headers
  3. clone the driver code:
    git clone
  4. compile the code:
    cd snd-hda-codec-cs8409
  5. install the driver (with root user or sudo):
    make install
  6. reboot system.

Hope this can help you.

If anyone have the no sound issue on Macbook Pro, maybe this repo Kernel audio driver for Macs with 8409 HDA chip + MAX98706/SSM3515 amps can be a solution.

1 Like

If the kernel updated, the driver need to be recompile and install

1 Like

@philliex Thank you, thank you, thank you. Was going nuts trying to find a solution to the dreaded “iMac won’t make any sound” problem. Was on the verge of buying a silly USB-audio adapter with associated headaches…

Your solution worked perfectly. Will keep this hand for future reference … especially likely when I update my kernel down the road. :+1:

Does the internal microphone work with the module installed?

(I installed this module on Fedora 37 anf it fixed the audio output, but the mic still does not work.)

I’ve been using the solution @philliex posted above ever since noted above. It continues to bail me out of 2019 iMac’s “silence” after upgrading kernels and restoring my native hardware audio. Thank you again!

Having to do this on every kernel upgrade will be a pain with Manjaro’s frequent updates. Is this the kind of change that could be suggested to the kernel devs?

1 Like

Similar problem with snd-hda-codec-cs8409 on iMac 18,3 has already been reported
216996 – No sound on an iMac 18,3 |