No sound on Event Notifications

No sound on Event Notifications.
In Configure Notifications window “play” button :arrow_forward: does not produce any sound, while paplay could play those notification sounds.

$ paplay -v /usr/share/sounds/Oxygen-Sys-App-Error-Critical.ogg
Opening a playback stream with sample specification 'float32le 2ch 48000Hz' and channel map 'front-left,front-right'.
Connection established.
Stream successfully created.
Buffer metrics: maxlength=4194304, tlength=768000, prebuf=760328, minreq=7680
Using sample spec 'float32le 2ch 48000Hz', channel map 'front-left,front-right'.
Connected to device alsa_output.pci-0000_01_00.1.hdmi-stereo (index: 19, suspended: no).
Stream started.
Stream underrun.
Playback stream drained.
Draining connection to server.


$ inxi -SMA
System:    Host: roman-pc Kernel: 5.15.2-2-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.23.3
           Distro: Manjaro Linux
Machine:   Type: Laptop System: Dell product: G3 3779 v: N/A serial: <superuser required>
           Mobo: Dell model: 04R93M v: A00 serial: <superuser required> UEFI: Dell v: 1.2.1 date: 07/18/2018
Audio:     Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel
           Device-2: NVIDIA GP106 High Definition Audio driver: snd_hda_intel
           Sound Server-1: ALSA v: k5.15.2-2-MANJARO running: yes
           Sound Server-2: PulseAudio v: 15.0 running: yes
           Sound Server-3: PipeWire v: 0.3.40 running: yes

$ pactl list sinks short
1       alsa_output.pci-0000_00_1f.3.analog-stereo      module-alsa-card.c      s16le 2ch 44100Hz       IDLE
19      alsa_output.pci-0000_01_00.1.hdmi-stereo        module-alsa-card.c      s16le 2ch 44100Hz       RUNNING

Yous should consider updating system BIOS

System data is showing 2 incompatible sound servers running

  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.40 running: yes

PipeWire cannot support audio unless PulseAudio is removed and replaced, but it can impede PulseAudio functions.
Install metapackage manjaro-pipewire to remove and replace PulseAudio packages

To continue using PulseAudio without PipeWire use this command to stop, disable and mask PipeWire service and socket

systemctl --user disable --now pipewire.socket pipewire.service && systemctl --user mask pipewire.socket

Onboard audio device Intel Cannon Lake PCH cAVS is using legacy driver snd_hda_intel instead of the Sound Open Firmware driver to support internal digital microphone array

Check that package sof-firmware is installed for the Sound Open Firmware driver sof-audio-pci-intel-cnl

If you have resolved those 3 issues and audio is still not working as expected, please post full system information

inxi -Fazy

Have the notification sounds volume as non-zero / too low?
Check System settings → Audio → Notification Sounds item volume.

Low possibility, but just in case, try to clean cache also: [Stable Update] 2021-12-10 - Kernels, Systemd, LibreOffice, Plasma, Browser, Thunderbird - #2 by philm, the KDE Plasma shows visual graphical errors section.

1 Like

You were right, to my shame. Thanks.
Though @nikgnomic’s notations seem pretty reasonable to me to consider.

1 Like

Thanks. In “PulseAudio vs PipeWire” - which is better choice in your opinion basing on experience of using them in Manjaro?

I can only speak from experience of using PulseAudio and JACK. Both have been working well for me for a long time so I have not considered a replacement is necessary

The only knowledgable opinion I have seen so far is a recent video from Unfa
Is PipeWire ready for audio production (in Q4 2021) ? - YouTube
He did not show benchmark data from recent PipeWire tests as expected, but advised he has reverted to using PulseAudio and JACK
But this was mostly focused on comparing JACK and pw-jack

IMO discussion of PulseAudio vs PipeWire is a false dilemma and Linux audio is more of a quandary if you consider that there is more to Linux audio than 2 conflicting sound servers

1 Like

Tried clearly to “BIOS Flash update via USB > F12 > BIOS flash update”, but it failed on flashing with “Firmware update failed. Rebooting the system”. It seems to be a common fail in part of Dell community (considering version 1.18).

I can’t find any comments on Dell forum about latest firmware version but there are a few about problems with earlier versions

BIOS v1.15.1 and later versions all have this comment:

Once the BIOS is upgraded, you cannot downgrade the BIOS to versions earlier than 1.12.0 due to downgrade restrictions

I suspect system cannot cope with 14 versions/3 years of updates and you may need to update to an interim version of BIOS firmware