No signal over HDMI since update



I’ve been having a problem with one of my computers since the update (I got to it yesterday). The computer starts, it gets to the encryption login to unlock the drive, then it starts to boot, but then it loses the hdmi signal, or turns it off, or something.

I can’t get to one of the terms using ctrl-alt F4 (or whichever). I’m not sure how to keep X or sddm or whatever is loading to see what might be going on before the signal is lost. I guess I also forgot to install sshd, so I can’t get in that way.

The system definitely boots. I have a few smb shares setup that start like normal and those are still accessible. I’m pretty sure I can login to my Plasma session to, I just can’t see anything going on.

The box is pretty straight-forward intel based fanless Zotac from a few years ago, so no special GPU. I have Plasma installed and haven’t missed an update, though this recent one was delayed. It was working fine right before the update.

I’ve tried different cables and plugged in a different monitor as well and am seeing the same thing. I wish I could just figure out a way to do some real diagnostics to start off with, but can’t seem to get a terminal.

Any help is greatly appreciated.

Ok - I figured out how to get grub to load my encrypted file system and boot into runlevel 3 and get sshd to start.

Here’s xrandr. I tried the basics of xrandr --output HDMI-1 --auto, but didn’t get anything.

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 309mm x 173mm
   1920x1080     60.01*+  60.01    59.97    59.96    59.93  
   1680x1050     59.95    59.88  
   1400x1050     59.98  
   1600x900      59.99    59.94    59.95    59.82  
   1280x1024     60.02  
   1400x900      59.96    59.88  
   1280x960      60.00  
   1440x810      60.00    59.97  
   1368x768      59.88    59.85  
   1280x800      59.99    59.97    59.81    59.91  
   1280x720      60.00    59.99    59.86    59.74  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   1024x576      59.95    59.96    59.90    59.82  
   960x600       59.93    60.00  
   960x540       59.96    59.99    59.63    59.82  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   864x486       59.92    59.57  
   700x525       59.98  
   800x450       59.95    59.82  
   640x512       60.02  
   700x450       59.96    59.88  
   640x480       60.00    59.94  
   720x405       59.51    58.99  
   684x384       59.88    59.85  
   640x400       59.88    59.98  
   640x360       59.86    59.83    59.84    59.32  
   512x384       60.00  
   512x288       60.00    59.92  
   480x270       59.63    59.82  
   400x300       60.32    56.34  
   432x243       59.92    59.57  
   320x240       60.05  
   360x202       59.51    59.13  
   320x180       59.84    59.32  
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)
HDMI-2 disconnected (normal left inverted right x axis y axis)

I think the hdmi is blown. I’ve tried other monitors, cables, ports, etc. It works at boot with text only and low resolution, but as soon as any higher resolution starts it loses signal.

I replaced it with a minisforum, though the site was down so I got the same HW via amazon. Loaded Manjaro Plasma - and as soon as X started: No signal.

Changing cables/ports - nothing. Then I used a 6 ft cord - and bang, that was it - even though I used the same 10 ft cables with my nvidia shield and gaming pc with no problem.

I tried a DP to HDMI - I could only get 1080p. A 6 ft. hdmi - 4K-60hz. All I can say is it’s been a weird and frustrating couple of days. And if you haven’t tried every-single-cable-in-your-house, you haven’t finished trouble shooting.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.