[Stable Update] 2022-02-14 - Kernels, Haskell, Cutefish 0.7, Deepin, Firefox, Maui 2.1.1, Systemd

Glad the link helped you! What still confuses me is that my ~/.config/fontconfig/ folder is empty… so I’m unsure which file I can/should copy as a source renamed as ~/.config/fontconfig/font.conf.

Why are so many repos outdated https://repo.manjaro.org/ ? It’s been 3 days since the update, very unusual

I forgot you don’t have a user’s fonts.conf file. Maybe just coping and renaming the 60-latin.conf file or creating a new one with the xml template from the ArchWiki site:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "urn:fontconfig:fonts.dtd">

  <!-- settings go here -->


I hope that helps :slight_smile:

one update today …

LANG=C pacman -Si vivaldi
Repository      : community
Name            : vivaldi
Packager        : Mark Wagie <manjaro.org>
Build Date      : Wed Feb 16 17:13:34 2022

so “outdated” if not synch since “17:13”

no, sometime we have 1…3 package the next day, or one package for security between updates

Interesting. Even generated on 2022-02-16 20:23 a lot of mirrors didn’t sync. Most likely due to the update of Vivaldi

Please create a new topic in #support. Announcement threads aren’t the place to troubleshoot general issues.

I guess it’s time to finally learn how to use Kvantum, 'cause with this update the Qt apps lost their theme and feel completely out of place.

EDIT for clarification: I suspect this happened precisely because I didn’t mark Kvantum as explicitly installed, so it got removed. After I noticed the bland Qt apps, I installed it again.

After the update and upon reboot it appeared that kernel 5.15 became corrupted. System would complain of not loading a kernel first.

Was able to resolve by simply booting into another installed kernel and removing/replacing kernel 5.15, but I am curious if there is any insight on what might have happened.

This update has changed my plaintext (monospace) font in Thunderbird, especially the lowercase letters i, j, l, r (and I think t) now look ugly because they appear with serifs while the other letters are without serifs. I checked Preferences → General → Language & Appearance → Advanced and observed that Noto Sans Mono is adjusted for Monospace. In my opinion, Noto Sans Mono doesn’t deserve the name Sans.

My question is: How can I change the font back? Which font did I have before? Unfortunately, choosing another font from the list doesn’t change anything. Why does this update automatically mess up with fonts?

The solution to your problem can be found earlier in this thread. :arrow_heading_up:

1 Like

Thank you very much! It worked for me. In DejaVu Sans Mono, the letters i, j, l are with serifs too (l different), but the r looks normal, what bothered me most about Noto Sans Mono.

Was unable to update at first because of the conflict of manjaro-pipewire and pipewire-alsa. Removed manjaro-pipewire, update went smooth, but I am still unable to install manjaro-pipewire back. I didn’t copy the error message from the first try, but it was quite similar.

$ sudo pacman -S manjaro-pipewire                                                                                                                                                    
resolving dependencies...
looking for conflicting packages...
:: manjaro-pipewire and pipewire-alsa are in conflict (pulseaudio-alsa). Remove pipewire-alsa? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'pipewire-alsa' required by manjaro-pipewire
:: removing pipewire-alsa breaks dependency 'pulseaudio-alsa' required by gnome-settings-daemon

The problem as I see it, is that pipewire-alsa (dependency of manjaro-pipewire) provides pulseaudio-alsa, which is stated to be in conflict with manjaro-pipewire.
I guess, as mainjaro-pipewire is a meta-package it’s not a big deal, all of its dependencies are still installed, but anyway this better be fixed.

sudo pacman -Ru --nodeps pulseaudio pulseaudio-equalizer pulseaudio-jack pulseaudio-lirc pulseaudio-rtp pulseaudio-zeroconf pulseaudio-bluetooth pulseaudio-pa pulseaudio-alsa pulseaudio-ctl manjaro-pulse && sudo pacman -S manjaro-pipewire

…is you need to refresh your mirrors and update to manjaro-pipewire 20220217-2. :wink:

1 Like

Have you tried using pamac instead of pacman ?
Recent comments about issues due to pipewire dependencies all seem to be from use of pacman
Pamac might not be able to manage the dependency problems with a Manjaro metapackage better, but would at least give a 2nd perspective on the issue

Whenever you are using the default configuration, don’t act surprised when it changes.

Are you able to share any guides on how to get off “default configuration”? New/vanilla users don’t know what they don’t know, so if there aren’t any friendly guides they could be reading to get a toe-hold on personalizing/configing the 100’s of packages that make up a distro, then any “update surprises” they find should be expected to generate questions.

New/vanilla users don’t “act surprised”… they “are surprised” when something that was working great suddenly does not.



I don’t know which desktop environment you are using, but it probably isn’t the one I am using (Openbox, which is not a desktop environment precisely but can be coaxed to act a little like one).

But the first thing I would do would be to look in system settings to see if you can save your current setup as a theme, either as one single global theme or as parts of themes in each ‘appearance’ or ‘look and feel’ preference pane.

On my system, I can save a global theme. Even if I have not changed anything from the defaults, it will save those defaults as a custom theme that won’t be overwritten by updates.

Probably good to make note of which font(s) you use, in case a later update says it/they have been removed from the repos and asks if you want to replace with something else. Old fonts are generally pretty safe to keep around, although you might want to put them in ~/.local/share/fonts/ so they are out of the system files.

Other than that, maybe do a search for customizing your desktop environment (KDE/Gnome/XFCE, etc). GUI preference panes are just overwriting config files, usually in your user directory. Myself, I can get lost in preferences/configs for days, but YMMV.

Thank You So Much!!

Couldn’t find what was the issue.

1 Like
  1. mpv plays audio very silently. bomi and firefox sound is fine.
ALSA lib pcm_pulse.c:758:(pulse_prepare) PulseAudio: Unable to create stream: Input/Output error

[ao/alsa] Unable to set hw-parameters: Input/output error
[ao/alsa] Attempting to work around even more ALSA bugs...                                                                    
ALSA lib pcm_pulse.c:758:(pulse_prepare) PulseAudio: Unable to create stream: Input/Output error                              

[ao/alsa] Unable to set hw-parameters: Input/output error
  1. plasma doesn’t hang but stops updating panels. I’ve noticed at first because clock freezed but all icons were freezing.
  2. dolphin and some other programs don’t remember the last size and place but apparently some do such as konsole(although it has different set of worms if it was maximized you can’t easily unmaximize it)

New plasma update fixed dolphin right click for me in wayland session.