No RDP support in KRDC since Update to KDE 6.0.4?

Hi there,
i have a strange problem an just wanted to check if someone else also encountered this.
Since my update to Plasma 6 last week it is not possible to establisch RDP cconnections with KRDC, although the RDP module in the settings is selected.
When i want to establisch a new connection i can only choose vnc.
When i click onto a saved RDP connection i get an error message that the geven address could not be processed.

Anyone a idea what could be the problem? I am using X11 if that makes any difference.

Operating System: Manjaro Linux
KDE Plasma Version: 6.0.4
KDE Frameworks Version: 6.1.0
Qt Version: 6.7.0
Kernel Version: 6.6.30-2-MANJARO (64-bit)
Graphics Platform: X11

Do you have installed freerdp2? – this package is required for rdp connections and is optional dependency for krdc

Thanks for the answer. No it was not installed, dont know if it was needed before and if it was why it wasnt also upgraded.

Nevertheless, i installed it, RDP is selectable but when using KRDC it tells me it couldnt connect to the Server.
If i use xfreerdp from CLI it works.

Thats the Output of KRDC:

KRDC: Starting RDP session
[10:32:04:676] [6285:6285] [WARN][com.freerdp.crypto] - Certificate verification failure 'self-signed certificate (18)' at stack position 0
[10:32:04:676] [6285:6285] [WARN][com.freerdp.crypto] - CN = DESKTOP-UT31UHB
[10:32:11:539] [6285:6285] [ERROR][com.freerdp.core.transport] - BIO_read returned a system error 104: Die Verbindung wurde vom Kommunikationspartner zurückgesetzt
[10:32:11:539] [6285:6285] [ERROR][com.freerdp.core] - transport_read_layer:freerdp_set_last_error_ex ERRCONNECT_CONNECT_TRANSPORT_FAILED [0x0002000D]
[10:32:11:864] [6285:6285] [ERROR][com.freerdp.core.transport] - BIO_read returned a system error 104: Die Verbindung wurde vom Kommunikationspartner zurückgesetzt
[10:32:11:864] [6285:6285] [ERROR][com.freerdp.core] - transport_read_layer:freerdp_set_last_error_ex ERRCONNECT_CONNECT_TRANSPORT_FAILED [0x0002000D]
[10:32:11:864] [6285:6285] [ERROR][com.freerdp.core] - freerdp_post_connect failed

Thats the output of xfreerdp

[10:28:47:221] [6209:6210] [WARN][com.freerdp.crypto] - Certificate verification failure 'self-signed certificate (18)' at stack position 0
[10:28:47:222] [6209:6210] [WARN][com.freerdp.crypto] - CN = DESKTOP-UT31UHB
[10:28:49:528] [6209:6210] [INFO][com.freerdp.gdi] - Local framebuffer format  PIXEL_FORMAT_BGRX32
[10:28:49:528] [6209:6210] [INFO][com.freerdp.gdi] - Remote framebuffer format PIXEL_FORMAT_BGRA32
[10:28:49:545] [6209:6210] [INFO][com.freerdp.channels.rdpsnd.client] - [static] Loaded fake backend for rdpsnd
[10:28:49:545] [6209:6210] [INFO][com.freerdp.channels.drdynvc.client] - Loading Dynamic Virtual Channel rdpgfx ```

Seems to be a bug

I don’t know KRDC but …may you try to change security option about SSL or TLS in general options or individually connection settings…

Unfortunately there are no such option.
I managed to connect to the server now by deleting it from history tab under settings.
Next problem: with H264 acceleration i get a blank screen, RemoteFX works but the quality is simply terrible.

I know it doesn’t help you right now but in Plasma 6.1 Beta Release

Remote Desktop system integration to allow RDP clients to connect to Plasma desktops, plus a new page in System

For me krdc and freerdp has had issues for a long time.

I had to work around krdc issues by using a custom script adapted to use the freerdp2 package. It has been provided as a template → [root tip] [Utility Script] FreeRDP script template

Could it bee an issue that i still use x11 instead of wayland?

I cannot say - depending on the choice you will need to run a different rdp session - that is what the template accounts for.

I had a fair amount of issues with krdc - it seemed like nothing I did would work.

When I created the script - I was once again in control.

1 Like

Honestly: till the update last week i had none problems with KRDC. I will try the script, or a different RDP Client.

That is great - I hope for you it will return - until then - workarounds - that is how we get things done even then.

1 Like

Can you disable all accelerations and retest again.

Can do that, but than the picture quality is as bad as with RemoteFX and performance is quite bad.

I use RDP to access a Windows machine, with all accelerations disabled I simply set resolution to “Current Screen Resolution” and I get a good viewed image enough to do basic tasks in “Full Screen Mode”.

For me, that “Force H.264” never worked for me with Windows10, and “Force RemoteFX” is not good.

At least i am not alone with the problem: [krdc] [Bug 482950] KRDC RDP Blue screen shows nothing