No Partition Detected while installing

[Not a Duplicate]
I am trying to dual boot Manjaro (KDE) with Win 10.
I have created 90 gb around unallocated space from Disk Management in windws.

These are the bios settings rn:
Mode: UEFI
SATA Mode: Optane without RAID
Fast Boot: Disabled
Secure Boot: Disabled

Laptop: Acer Aspire 7 intel version

I checked other threads too where the solution was switch to AHCI. But in my bios I am not able to switch. It’s grayed out.

Also, partitions are not listed in kde partition manager.

I am attaching the pics

Hello @AmreshSinha and welcome :wink:

Optane Cache Acceleration is not supported out-of-the-box… set it to AHCI mode if possible and disable optane, that works pretty good.

If not wanted, then maybe adding the vmd module can help:

  1. Boot the ISO…
  2. Edit the grub menu with E and add this to the parameter after quiet.

That should load the module (driver) early. Maybe it helps.

Btw… did you test this ISO with version 21.1.4 ? It should include vmd now by default.

I can’t change it. It’s grayed out in my bios. idk why :confused:

Thanks I will give this a try.

Ohh Cool! Will give it a try :slight_smile:

It could be possible and some BIOS act like this, that some options are only changeable if a password has been set. Try that maybe…

Supervisor password? Will give it a try :+1:

I tried this tho earlier before reading your recent reply. It still didnt detected.

So, ig changing from optane to AHCI is the only way.

Will try and reply back :+1:

Just be careful, because when I did this with an HP laptop, Windows 10 (pre-installed) become unbootable. Ironically, I did not care, since I wanted to use the entire storage only for Manjaro and not dual-boot.

Each laptop might be different. I can only speak for an HP I did this on.

Yeah so I watched one yt vid on why SATA Mode option is grayed out in my acer laptop.
It showed that while in the BIOS, switch to Main Tab and Press Ctrl + S To enable SATA mode option.

And Then I changed from optane to AHCI.

Now, my partitions are detected.

But I have one doubt, as @winnie said will it affect my preinstalled win 10?

It might. My pre-installed Windows 10 could not boot anymore.

There’s ways around this to get Windows 10 bootable again, by forcing it to use the AHCI drivers, after successfully installing Linux.

Okay I tried booting to winds but it went into infinite loop and finally sending me to automatic repair. :sweat_smile: So, will I need to change SATA mode everytime I want to boot into Winds? :sneezing_face:

Will it have any sort of impacts on performance or anything else?

Performance? No.

It just needs to be able to boot up successfully.

I think it’s silly how laptop manufacturers pretend like Linux doesn’t even exist. Many of these issues are due to the relationship between Microsoft and OEMs. Who cares about us Linux users, right? Does Linux even exist? :face_with_monocle:

Did you get an option to boot into Safe Mode? Sometimes that will automatically force Windows to use the AHCI drivers, and make the change permanent. So the next time you reboot normally, it will be successful, even with AHCI mode.

An alternative is to install Windows 10 from scratch, while the BIOS is set to AHCI mode, in which Windows will use those drivers from the start. (But in your case, Windows 10 was pre-installed at the factory.)

Yeah I turned on safe mode with bcdedit and then turned on AHCI. Then logged into safe mode and removed that entry. Now it’s working fine :smiley: Time to install manjaro :smile: I was a ubuntu user on my old machine. Bought this laptop months ago. I don’t know why laptop companies don’t make their product with preinstalled linux distro :frowning:

They do, they’re just not as affordable compared to their counterparts with the same specs. I wanted to go with a System76 again, but I couldn’t afford it.

DELL and Lenovo offer a few options as well, but honestly if you want the best bang-per-buck, you shop around for a good deal and then research if the hardware is “Linux friendly”.

In the case of many modern laptops with Intel RST, there was an issue post-installation in which the boot process will fail because the vmd module was not loaded early enough. (This has been corrected for Manjaro ISO 21.1.4, but not corrected with upstream Arch Linux as far as I am aware. Other distros also applied their own patches.)

Hopefully this one change will allow more users to install Manjaro on their new laptops without having to edit any config files or do manual interventions after installation. :+1: