No original/internal speaker sound but headphone, bluetooth and others sound ok

Good morning!

I installed Manjaro KDE-Plasma (Kernel 6.1.29-1 on an LG All-In-One (2016/2017). Everything working fine except for sound/audio. The audio bar says it is recognizing sound, but the sound doesn’t come out of the computer speakers. When I use external speakers or headphones the sound works perfectly. I’ve tried PavuControl, Alsa, Pulse, PipeWire and I still can’t solve it.

I’ve read several posts about similar subjects here on the Forum and I’ve carried out the tests and unfortunately it’s still unresolved, so I’m opening this new post.

I ran the Alsa Script on my computer, let me know if that information might be usefull.

If anyone can help me. Thanks

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    [HowTo] Provide System Information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text. (use the option “preformatted text”)


As requested, I forward the audio specifications. Any additional information needed?

  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series
    High Definition Audio vendor: LG driver: snd_hda_intel v: kernel
    bus-ID: 00:1b.0 chip-ID: 8086:2284 class-ID: 0403
  API: ALSA v: k6.1.31-2-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.70 status: off with: wireplumber status: active
    tools: pw-cli,wpctl
  Server-3: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl

If audio from headphone jack is working PulseAudio is probably working and issue with speakers is probably in ALSA

Please post more information about ALSA configuration

sudo --with-aplay --with-amixer --with-dmesg --upload

Do you have anything else checked besides “Built-In Audio” on the configuration tab in pavucontrol (I’m using pavucontrol-qt)? My laptop speakers quit working an update or two ago and I finally got them working again after unchecking the USB-C dock. Never had to do it before. Might be something similar.