No option to enable Arch User Repo support in Pamac

Pamac doesnt list Arch repo in third party section any more what is going on…

and Please someone can help me how to install Arch Packages using Pacaman as well looked but didnt find anything related to it…

Pamac version

Pamac 10.4.0-2  -  libpamac 11.3.0-1


CPU: 6-core AMD Ryzen 5 4600H with Radeon Graphics (-MT MCP-)
speed/min/max: 1426/1400/3000 MHz Kernel: 5.17.9-1-MANJARO x86_64 Up: 46m
Mem: 3412.6/7367.2 MiB (46.3%) Storage: 1.36 TiB (16.9% used) Procs: 379
Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 wm: kwin_x11 vt: 1 dm: SDDM
 Distro: Manjaro Linux base: Arch Linux

Shell: Zsh inxi: 3.3.16

Hi @knight,

Ignore this

Make sure libpamac-aur is installed:

pamac install libpamac-aur

Hope this helps!

Well I don’t have it installed, but still have access to AUR:

$ pamac list --installed | grep "pamac"                                        
libpamac                                 11.3.0-1                      extra      4,0 MB
libpamac-flatpak-plugin                  11.3.0-1                      extra      103,9 kB
pamac-cli                                10.4.0-2                      extra      203,8 kB
pamac-gnome-integration                  10.4.0-2                      extra      22,2 kB
pamac-gtk                                10.4.0-2                      extra      721,

libpamac-aur is in the aur

I see now. Apologies. I misread it. My bad.

I see now that I don’t have it, either:

$ pamac list --installed | grep -i pamac
libpamac                           11.3.0-1                      extra      4.0 MB
pamac-cli                          10.4.0-2                      extra      203.8 kB
pamac-gtk                          10.4.0-2                      extra      721.4 kB
pamac-tray-icon-plasma             0.1.2-4                       extra      84.2 kB

But I very rarely to never use the GUI, so obviously might miss the setting.

Edit:

@knight, please post the output of:

pamac list --installed | grep "pamac"

And,

cat /etc/pamac.conf
1 Like

Do not install libpamac-aur as it is a port from Manjaro to Arch

Your screenshot indicates a system problem of some kind - I don’t know what because my settings (mininal KDE Plasma) looks like

Screenshot

ksnip_20220526-162753

If below suggestion doesn’t work - you have just confirmed a general system issue.

1 Like

make sure EnableAUR on line 20 of /etc/pamac.conf isn’t commented out

Mine’s the same way but aur is enabled.

pamac list --installed | grep -i pamac
libpamac                           11.3.0-1                    extra      4.0 MB
libpamac-flatpak-plugin            11.3.0-1                    extra      103.9 kB
pamac-cli                          10.4.0-2                    extra      203.8 kB
pamac-gtk                          10.4.0-2                    extra      721.4 kB
pamac-tray-icon-plasma             0.1.2-4                     extra      84.2 kB

Is yours also missing the “Advanced” tab, like in @knight’s original screenshot?

No just checked and I have the advanced tab.

4 Likes

:white_check_mark: @linux-aarhus Minimal/custom KDE, everything is normal

:white_check_mark: @winnie Standard KDE (two systems), everything is normal

:warning: @knight Standard KDE, missing “Advanced” tab and missing AUR options

:warning: @straycat Standard KDE, missing only AUR options Confirmed it’s the “Software Mode” option that toggles visible AUR options. (post below) :point_down:

If the above assumptions / summary is correct, and we’re all fully updated, I’m suspecting this could be due to a theming issue?

I’m using the default “dark” breath theme.


EDIT: Or the simpler solution, as referenced by @ishaanbhimwal above.


EDIT 2: But we still need to hear back from @knight to see if the “Advanced” tab returns.

1 Like

That should fix it I just checked the software mode and aur disappeared.

Disabling “Software Mode” brings back everything.

This was way too obvious that it went over our heads until @ishaanbhimwal shared the solution. :grin:

2 Likes

Thank you, Software mode Was the culprit

it was the software mode on pamac

Nope

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.