No longer booting after update on rpi4

I have been running Manjaro KDE on a raspberry pi 4 for a couple months, updating about once a week. I updated yesterday and after rebooting, the system is not coming all the way up. I’ll get a cursor for about a second and then it drops back to the boot text, with the last message either

finished tlp system startup/shutdown
or
started network manager script dispatcher service

ctl-alt-f2 doesn’t do anything, but ctl-alt-del does reboot it, so the system isn’t completely frozen. In fact, if I do a ctl-alt-f2 and then blindly type in root, password, and then reboot, it reboots, so its as if the screen has frozen? Thinking it might be a graphics driver issue, I commented out #vc4-fkms-v3d in config.txt, and now I can at least see the switch to tty2 and what I’m typing, but I’m new to arch, and at a loss as to what to do next.

I have the same issue and haven’t solved yet, you could read here:

Are you using an SD card or external SSD for boot?

Using a micoSD card. I tried booting raspbian from another card and it came up fine, so its not a hardware failure. I did a full-upgrade on raspbian thinking it might be a firmware issue, but that didn’t change anything on the manjaro side.

Are both of you all running plasma?

If so do a:

journalctl | grep sddm

Here is something else with plasma on the pbp with the update.

https://forum.manjaro.org/t/pinebook-pro-boots-to-black-screen-with-cursor-after-crashing-during-arm-testing-update/38632/2

Yes I’m running plasma. Here is my “journalctl | grep sddm” output from the latest boot, with the last screen message of “started network manager script dispatcher service”:

Nov 20 13:42:55 RasPi4B sddm[382]: Signal received: SIGTERM
Nov 20 13:42:55 RasPi4B sddm[382]: Display server stopping...
Nov 20 13:42:55 RasPi4B sddm[382]: Display server stopped.
Nov 20 13:42:55 RasPi4B sddm[382]: Running display stop script "/usr/share/sddm/scripts/Xstop"
Nov 20 13:42:55 RasPi4B systemd[1]: sddm.service: Succeeded.
Nov 20 13:42:57 RasPi4B sddm[383]: Initializing...
Nov 20 13:42:57 RasPi4B sddm[383]: Starting...
Nov 20 13:42:57 RasPi4B sddm[383]: Logind interface found
Nov 20 13:42:57 RasPi4B sddm[383]: Adding new display on vt 1 ...
Nov 20 13:42:57 RasPi4B sddm[383]: Loading theme configuration from ""
Nov 20 13:42:57 RasPi4B sddm[383]: Display server starting...
Nov 20 13:42:57 RasPi4B sddm[383]: Adding cookie to "/var/run/sddm/{f01d848a-7db3-402c-8892-834c1ceb8302}"
Nov 20 13:42:57 RasPi4B sddm[383]: Running: /usr/bin/X -nolisten tcp -auth /var/run/sddm/{f01d848a-7db3-402c-8892-834c1ceb8302} -background none -noreset -displayfd 18 -seat seat0 vt1
Nov 20 13:42:58 RasPi4B sddm[383]: Setting default cursor
Nov 20 13:42:58 RasPi4B sddm[383]: Running display setup script "/usr/share/sddm/scripts/Xsetup"
Nov 20 13:42:58 RasPi4B sddm[383]: Display server started.
Nov 20 13:42:58 RasPi4B sddm[383]: Reading from "/usr/share/xsessions/plasma.desktop"
Nov 20 13:42:58 RasPi4B sddm[383]: Reading from "/usr/share/xsessions/plasma.desktop"
Nov 20 13:42:58 RasPi4B sddm[383]: Session "/usr/share/xsessions/plasma.desktop" selected, command: "/usr/bin/startplasma-x11"
Nov 20 13:42:58 RasPi4B sddm-helper[496]: [PAM] Starting...
Nov 20 13:42:58 RasPi4B sddm-helper[496]: [PAM] Authenticating...
Nov 20 13:42:58 RasPi4B sddm-helper[496]: pam_kwallet5(sddm-autologin:auth): (null): pam_sm_authenticate
Nov 20 13:42:58 RasPi4B sddm-helper[496]: [PAM] Preparing to converse...
Nov 20 13:42:58 RasPi4B sddm-helper[496]: pam_kwallet5(sddm-autologin:auth): pam_kwallet5: Couldn't get password (it is empty)
Nov 20 13:42:58 RasPi4B sddm-helper[496]: [PAM] Conversation with 1 messages
Nov 20 13:42:59 RasPi4B sddm-helper[496]: [PAM] returning.
Nov 20 13:42:59 RasPi4B dbus-daemon[363]: [system] Activating via systemd: service name='org.freedesktop.home1' unit='dbus-org.freedesktop.home1.service' requested by ':1.11' (uid=0 pid=496 comm="/usr/lib/sddm/sddm-helper --socket /tmp/sddm-authf")
Nov 20 13:42:59 RasPi4B sddm-helper[496]: pam_systemd_home(sddm-autologin:account): systemd-homed is not available: Unit dbus-org.freedesktop.home1.service not found.
Nov 20 13:42:59 RasPi4B sddm[383]: Authenticated successfully
Nov 20 13:42:59 RasPi4B sddm-helper[496]: pam_kwallet5(sddm-autologin:setcred): pam_kwallet5: pam_sm_setcred
Nov 20 13:42:59 RasPi4B sddm-helper[496]: pam_unix(sddm-autologin:session): session opened for user gbai(uid=1000) by (uid=0)
Nov 20 13:42:59 RasPi4B sddm-helper[496]: [PAM] Preparing to converse...
Nov 20 13:42:59 RasPi4B sddm-helper[496]: [PAM] Conversation with 1 messages
Nov 20 13:42:59 RasPi4B sddm[383]: Authentication information: "Welcome to Manjaro-ARM\n~~Website: https://manjaro.org\n~~Forum: https://forum.manjaro.org/c/arm\n~~Matrix: #manjaro-arm-public:matrix.org"
Nov 20 13:42:59 RasPi4B sddm-helper[496]: pam_kwallet5(sddm-autologin:session): pam_kwallet5: pam_sm_open_session
Nov 20 13:42:59 RasPi4B sddm-helper[572]: pam_kwallet5: final socket path: /run/user/1000/kwallet5.socket
Nov 20 13:42:59 RasPi4B sddm-helper[496]: Starting: "/usr/share/sddm/scripts/wayland-session /usr/bin/startplasma-x11"
Nov 20 13:42:59 RasPi4B sddm-helper[575]: Jumping to VT 2
Nov 20 13:42:59 RasPi4B sddm-helper[575]: VT mode didn't need to be fixed
Nov 20 13:42:59 RasPi4B sddm[383]: Session started
Nov 20 13:43:00 RasPi4B sddm-helper[496]: [PAM] Closing session
Nov 20 13:43:00 RasPi4B sddm-helper[496]: pam_unix(sddm-autologin:session): session closed for user gbai
Nov 20 13:43:00 RasPi4B sddm-helper[496]: pam_kwallet5(sddm-autologin:session): pam_kwallet5: pam_sm_close_session
Nov 20 13:43:00 RasPi4B sddm-helper[496]: pam_kwallet5(sddm-autologin:setcred): pam_kwallet5: pam_sm_setcred
Nov 20 13:43:00 RasPi4B sddm-helper[496]: [PAM] Ended.
Nov 20 13:43:00 RasPi4B sddm[383]: Auth: sddm-helper exited with 1

What’s the output of systemctl status sddm?

Here’s the output of systemctl status sddm:

● sddm.service - Simple Desktop Display Manager
     Loaded: loaded (/usr/lib/systemd/system/sddm.service; enabled; vendor preset: disabled)
     Active: active (running) since Fri 2020-11-20 15:01:26 GMT; 5min ago
       Docs: man:sddm(1)
             man:sddm.conf(5)
   Main PID: 380 (sddm)
      Tasks: 3 (limit: 4251)
     CGroup: /system.slice/sddm.service
             ├─380 /usr/bin/sddm
             └─387 /usr/lib/Xorg -nolisten tcp -auth /var/run/sddm/{9f57b5da-637b-4492-be2d-12e6afcd951>

Nov 20 15:01:27 RasPi4B sddm[380]: Authenticated successfully
Nov 20 15:01:27 RasPi4B sddm-helper[484]: pam_kwallet5(sddm-autologin:setcred): pam_kwallet5: pam_sm_se>
Nov 20 15:01:27 RasPi4B sddm-helper[484]: pam_unix(sddm-autologin:session): session opened for user gba>
Nov 20 15:01:27 RasPi4B sddm-helper[484]: [PAM] Preparing to converse...
Nov 20 15:01:27 RasPi4B sddm-helper[484]: [PAM] Conversation with 1 messages
Nov 20 15:01:27 RasPi4B sddm[380]: Authentication information: "Welcome to Manjaro-ARM\n~~Website: http>
Nov 20 15:01:28 RasPi4B sddm-helper[484]: pam_kwallet5(sddm-autologin:session): pam_kwallet5: pam_sm_op>
Nov 20 15:01:28 RasPi4B sddm-helper[484]: Starting: "/usr/share/sddm/scripts/wayland-session /usr/bin/s>
Nov 20 15:01:28 RasPi4B sddm[380]: Session started
Nov 20 15:01:29 RasPi4B sddm[380]: Auth: sddm-helper exited with 1
lines 1-21/21 (END)

Do you have autologin enabled?

I did set it to autologin, but in KDE settings. Do I need to configure autologin in command-line interface?

Please check this post and see if your files still contain tally*.so stuff:

https://bugs.archlinux.org/task/67641

Should have been fixed with SDDM 0.19.0-2 though.

If the issue is not solved in the current ongoing diagnosis. This looks like the same issue in this thread with the pbp with malformed packages with the latest testing update.

https://forum.manjaro.org/t/no-longer-booting-after-update-on-rpi4/38638

So I listed the content of /usr/lib/security, and there’s no pam_tally2.so or any pam_tally*.so, but there are a few other stuff:

pam_access.so     pam_filter       pam_localuser.so  pam_rhosts.so        pam_timestamp.so
pam_cap.so        pam_filter.so    pam_loginuid.so   pam_rootok.so        pam_tty_audit.so
pam_cifscreds.so  pam_ftp.so       pam_mail.so       pam_securetty.so     pam_umask.so
pam_debug.so      pam_group.so     pam_mkhomedir.so  pam_setquota.so      pam_unix.so
pam_deny.so       pam_issue.so     pam_motd.so       pam_shells.so        pam_usertype.so
pam_echo.so       pam_keyinit.so   pam_namespace.so  pam_stress.so        pam_warn.so
pam_env.so        pam_kwallet5.so  pam_nologin.so    pam_succeed_if.so    pam_wheel.so
pam_exec.so       pam_lastlog.so   pam_permit.so     pam_systemd_home.so  pam_xauth.so
pam_faildelay.so  pam_limits.so    pam_pwhistory.so  pam_systemd.so
pam_faillock.so   pam_listfile.so  pam_pwquality.so  pam_time.so

Yeah. But I want to see if any files in /etc/pam.d/ still contains entries for tally.

I see, I did

grep -E "tally" /etc/pam.d/*

but no match

I also have autologin enabled. I had been having issues with kwallet, and I recently deleted ~/.local/share/kdewalletd/kdewallet.kwl to reset it. Thinking this is messing up autologin too, I commented out the autologin section of /etc/sddm.conf.d/kde_settings.conf and I was able to login!

I noticed that the section “Session=” in kde_settings.conf had been blank, and after logging in manually and reenabling autologin with KDE settings that section now reads “Session=plasma”. FurN1, maybe try just adding that, (assuming you didn’t also reset kwallet)?

1 Like

Decent information! I tried commenting out User=<my username> and added Session=plasma in /etc/sddm.conf.d/kde_settings.conf, and now I can log in desktop by enter password in the login screen.

Then I tried commenting out Session=plasma, and I can login to desktop as well. Looks like Session=plasma is not necessary?

Edit:

So after login-in desktop, I re-enabled autologin with KDE settings as you mentioned. Now the /etc/sddm.conf.d/kde_settings.conf changed, from this at the very beginning:

[Autologin]
User=<my username>

to this now:

[Autologin]
Relogin=false
Session=plasma
User=<my username>

[General]
HaltCommand=/usr/bin/systemctl poweroff
RebootCommand=/usr/bin/systemctl reboot

[Theme]
Current=breath2

[Users]
MaximumUid=60000
MinimumUid=1000

And now if I reboot Raspberry Pi, it does autologin and I can see the desktop without any problem. Maybe this re-generating the kde_settings.conf file did the magic? Maybe this is a change in KDE Plasma from its 5.19 version to 5.20.

1 Like