No internet connection after update Proton_VPN related?

Today I did a software update on my Manjaro machine with Proton_VPN installed. After the update Proton couldn’t connect to the internet.

I sometimes had the same problem before and fixed it by removing all the Proton software and rebooted the laptop and had normal internet working again. Then installed the software again and no problems anymore.

Now I did the same by removing all the Proton software and rebooted the laptop… but I still have no internet connection. I can reach my router so it’s not a bad Wifi connection or so and my other laptop it’s internet is working properly.

So it seems Proton software did do some changes on my PC like wanting priority internet connection but have no clue how to set it to default.

Does anyone has a solution for my problem?

Thank you.

If you are going to use Proton vpn, have you tried rebuilding the aur packages?

I have no clue how to do that. Will look it up.

But I removed the Proton software and normally my laptop should get back the connection except this time.

Its basically building them again. We could spend hours trying to figure it out why its not working now. But if your going to install proton vpn again it will likely be a huge waste of time.

Also installing software can’t be done since I don’t have any connection at all.

I would be glad if my laptop would get back the internet connection even without Proton at all (I already uninstalled it). But seems Proton changed something in the system.

I guess it overwrote the /etc/resolv.conf file.

Pfeww… got it solved. Seems like Proton did do some kind of killswitch and could disable it with this.

Thanks for your support anyway!


3. Disable Kill Switch if you have uninstalled the app

The Kill Switch can be easily disabled from within the official Linux app, but this will not be possible if you uninstalled the app without first disabling the Kill Switch. This may result in your system being unable to access the internet. To remove the Kill Switch after the app has been uninstalled:

a) Identify Proton VPN connection names by running the command:

nmcli connection show --active

This will display a list of all your system’s active connections.

b) Look for any connections with the pvpn- prefix. This usually includes pvpn-killswitch and pvpn-ipv6leak-protection, and may include pvpn-routed-killswitch. Delete all these connections using the following command:

nmcli connection delete [connection name]

For example:

nmcli connection delete pvpn-killswitch

c) Re-run the following command to verify that Proton VPN connections have been deleted:

nmcli connection show --active

If any Proton VPN connections remain, delete them as described above.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.