No Icon Themes loading after update on XFCE

I just updated the system, but things didn’t go well like every time. It broke again, lightdm wasn’t starting, so I spent 2 hours fixing it up, then after I got into the system all the icons are messed, they are like default icons, so I went in appearance and tried to change to my icon theme, but all of the icon themes were looking same (with little difference) as default one, I downloaded few more icon themes to try but none of them are working, it’s showing it’s enabled but nothing is happening the ugly default icons remain the same and most of the icons are missing. I’ve again looking for more than 2 hours but can’t find anything. My guess is, still some issue with lightdm, it’s not able to render the icons or something. But I’m complete noob in Linux stuff all I know is how to google stuff when something goes wrong. But not able to find anything this time.

And I also did this, after looking at some forum
sudo gtk-update-icon-cache ~/.icons/WhiteSur
but this broke the icon settings, now I can’t open ‘settings < appearance’ or choose any icon, it just lags and crashes.

Please guide me on how to fix this, thanks for your time, and I don’t really know what kind of system info I should attach with the questions, so sorry for that

❯ inxi --admin --verbosity=7 --filter --no-host --width                                                                             ─╯
  Kernel: 5.10.56-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/vmlinuz-5.10-x86_64 
  root=UUID=4c33371e-a8f8-4d60-af19-33d087bc242a rw quiet 
  resume=UUID=c354d7fe-c683-4a11-822b-281aff9f0021 udev.log_priority=3 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel, plank 
  wm: xfwm 4.16.1 vt: 7 dm: LightDM 1.30.0 Distro: Manjaro Linux 
  base: Arch Linux 
  Type: Portable System: Dell product: Inspiron 3542 v: N/A serial: <filter> 
  Chassis: type: 8 serial: <filter> 
  Mobo: Dell model: 0KHNVP v: A14 serial: <filter> BIOS: Dell v: A14 
  date: 05/23/2018 
  ID-1: BAT0 charge: 8.9 Wh (40.3%) condition: 22.1/41.4 Wh (53.4%) 
  volts: 16.1 min: 14.8 model: SMP-SDI2.8 DELL FW1MN31 type: Li-ion 
  serial: <filter> status: Charging 
  RAM: total: 3.74 GiB used: 2.41 GiB (64.4%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Dual Core model: Intel Core i3-4005U bits: 64 type: MT MCP 
  arch: Haswell family: 6 model-id: 45 (69) stepping: 1 microcode: 26 cache: 
  L2: 3 MiB bogomips: 13574 
  Speed: 798 MHz min/max: 800/1700 MHz Core speeds (MHz): 1: 798 2: 798 3: 798 
  4: 798 
  Flags: abm acpi aes aperfmperf apic arat arch_perfmon avx avx2 bmi1 bmi2 bts 
  clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm 
  dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase 
  fxsr ht ibpb ibrs ida invpcid invpcid_single lahf_lm lm mca mce md_clear mmx 
  monitor movbe msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm 
  pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdtscp rep_good 
  sdbg sep smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 
  tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid xsave 
  xsaveopt xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Dell driver: i915 
  v: kernel bus-ID: 00:02.0 chip-ID: 8086:0a16 class-ID: 0300 
  Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo 
  bus-ID: 1-1.5:3 chip-ID: 0bda:5756 class-ID: 0e02 serial: <filter> 
  Display: x11 server: X.Org 1.20.13 compositor: xfwm4 v: 4.16.1 driver: 
  loaded: intel unloaded: modesetting alternate: fbdev,vesa display-ID: :0.0 
  screens: 1 
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
  s-diag: 414mm (16.3") 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2) 
  v: 4.5 Mesa 21.1.6 compat-v: 3.0 direct render: Yes 
  Device-1: Intel Haswell-ULT HD Audio vendor: Dell driver: snd_hda_intel 
  v: kernel bus-ID: 00:03.0 chip-ID: 8086:0a0c class-ID: 0403 
  Device-2: Intel 8 Series HD Audio vendor: Dell driver: snd_hda_intel 
  v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9c20 class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.56-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.33 running: no 
  Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter 
  vendor: Dell driver: ath9k v: kernel port: f040 bus-ID: 06:00.0 
  chip-ID: 168c:0036 class-ID: 0280 
  IF: wlp6s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell 
  driver: r8169 v: kernel port: e000 bus-ID: 07:00.0 chip-ID: 10ec:8136 
  class-ID: 0200 
  IF: enp7s0 state: down mac: <filter> 
  WAN IP: <filter> 
  Device-1: Qualcomm Atheros AR9462 Bluetooth type: USB driver: btusb v: 0.8 
  bus-ID: 1-1.6:20 chip-ID: 0cf3:0036 class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 9 state: up address: see --recommends 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 465.76 GiB used: 111.02 GiB (23.8%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital 
  model: WD5000LPVX-75V0TT0 size: 465.76 GiB block-size: physical: 4096 B 
  logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> 
  rev: 1A01 scheme: MBR 
  Optical-1: /dev/sr0 vendor: TSSTcorp model: DVD+-RW SU-208FB rev: D200 
  dev-links: cdrom 
  Features: speed: 24 multisession: yes audio: yes dvd: yes 
  rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
  ID-1: / raw-size: 100 GiB size: 97.93 GiB (97.93%) used: 23.85 GiB (24.4%) 
  fs: ext4 dev: /dev/sda3 maj-min: 8:3 label: N/A 
  uuid: 4c33371e-a8f8-4d60-af19-33d087bc242a 
  ID-2: /boot raw-size: 512 MiB size: 487.9 MiB (95.30%) 
  used: 100.3 MiB (20.5%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A 
  uuid: 96f064ac-ac8e-482b-82b2-c78b729cf416 
  ID-3: /home raw-size: 359.26 GiB size: 352.62 GiB (98.15%) 
  used: 86.77 GiB (24.6%) fs: ext4 dev: /dev/sda4 maj-min: 8:4 label: N/A 
  uuid: 17676bf6-5c1b-4a77-b3ca-a9fa642f7368 
  Kernel: swappiness: 10 (default 60) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 6 GiB used: 312.6 MiB (5.1%) priority: -2 
  dev: /dev/sda2 maj-min: 8:2 label: N/A 
  uuid: c354d7fe-c683-4a11-822b-281aff9f0021 
  Message: No unmounted partitions found. 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0 
  speed: 480 Mb/s chip-ID: 8087:8000 class-ID: 0900 
  Device-1: 1-1.5:3 info: Realtek Integrated_Webcam_HD type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA 
  chip-ID: 0bda:5756 class-ID: 0e02 serial: <filter> 
  Device-2: 1-1.6:20 info: Qualcomm Atheros AR9462 Bluetooth type: Bluetooth 
  driver: btusb interfaces: 2 rev: 1.1 speed: 12 Mb/s power: 100mA 
  chip-ID: 0cf3:0036 class-ID: e001 
  Device-3: 1-1.8:5 info: Realtek RTS5129 Card Reader Controller 
  type: <vendor specific> driver: rtsx_usb,rtsx_usb_ms,rtsx_usb_sdmmc 
  interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 0bda:0129 
  class-ID: ff00 serial: <filter> 
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 8 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-4: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 70.0 C mobo: 65.0 C 
  Fan Speeds (RPM): cpu: 3958 
  Processes: 261 Uptime: 2d 8h 20m wakeups: 14 Init: systemd v: 248 
  tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1371 
  lib: 425 Shell: Zsh v: 5.8 running-in: xfce4-terminal inxi: 3.3.06 

:+1: Welcome to Manjaro! :+1:

  1. Does this also happen if you create a new user profile and log in there?(E.G. random-pickle2) If yes, go to step #2 below. If no, please reply: I might have a workaround for you…
  2. Please read this:
    How to provide good information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  3. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.


The problem persists even with a new user.
I’m proving the the required Information…

Then you have an XFCE specific issue I can’t help you any further with, so the only thing I can do for you is edit your title to attract and XFCE expert.


Look here
It’s a link to another forum post.
That was even just today and it looks like it could help you restore the default look
that somehow vanished during your efforts to fix your issue.

1 Like

Sadly no effect after following this solution :frowning:
I don’t understand why this is happening, is there any cache for icons that got saved as default icon theme? I saw in logs when I did pacman -Syu, something like building or saving icon cache.

Really feeling helpless, tried many things but none worked

Thanks man, you did what you could :+1:

1 Like

How did you install that icon theme?
From some other source? There are several that I could find.
Maybe you just need to rebuild it?

and that right there could have been a big slipup - why would you run that command as root?
Unless you actually have icons installed there in that directory:
remove it
or at least make sure the ownership is not messed up
and then run the command again without sudo

rule #1 Do NOT run random commands found on the internet unless you know what you are doing.

I installed from some other source, i.e. downloaded from a site, it worked fine for months, all went wrong after the update.

sudo gtk-update-icon-cache ~/.icons/WhiteSur

I read in a forum, it was for rebuilding the icon cache,
So I ran it, but asked for root permission that’s why I ran with Sudo,

But this command did no changes to my system that I know, the issue was existing from before this command, I ran it few days later but nothing much happened, just little lag on startup of settings < appearance

And I don’t think ownership is messed

How can I rebuild it?

I know that, I was told it will update/rebuild the icon cache, and the issue will be solved, but it didn’t worked

How do you know?
… because you previously said:

which to me means that it clearly did something …

I was hoping that you would tell us from where exactly - and what you did to install it. :wink:
It seems to have been installed inside your $HOME directory only, not system wide.

What does
ls -hl $HOME/.icons/WhiteSur
Is the file named “icon-theme.cache”
which should be there,
owned by you or by root?

This is the Icon theme I installed

And yes, icon-theme.cache exists in the directory
And it was working fine being in my $HOME for a long time.

I just went to that site, clicked on the “Files (8)” link, chose “01-WhiteSur.tar.xz”, downloaded it, unpacked it into $HOME/.icons (which I had to create first) - and it all works.
How did you install it?

There is also a link to github, where it came from.
If you used that, it would have been installed either system wide to
or into

Since it works for me I can only speculate why it wouldn’t work for you.
You might need to choose a different “Style” along with the icons?
I’m fresh out of ideas.

The theme is fine, and it doesn’t matter if it’s system-wide or user only, in this case, there’s something else wrong,

See all themes look the same
and I already have a style

I’m not trying to argue, but they don’t look all the same.
Most of those that you showed here are variants of the Papirus theme, of course they look similar. :wink:

… in that list, your theme should be listed further down if it is correctly installed
Is it listed?

I personally use the Numix style with the elementary Xfce dark icon set.
You seem to be using some theme reminiscent of MacOS - maybe that is somehow causing your trouble? Don’t know.
There is also another place where a style can be chosen - in addition to “Appearance” - under “Window Manager”, but that refers to how dialogs and buttons look.

… experiment - I can’t advise further

All the manually installed themes are listed and all are looking same even if they are not variant of Papirus :[

No themes worked I’ve tried,
I also tried, lxappearance to apply them,

Anyways glad you tried to help. Have a good day.

Very strange.
The only way that could be is when all the different names of themes exist as symlinks only - all pointing to one and the same theme.
To accomplish this by accident seems very unlikely.

But even in your picture - they don’t look the same.

Have you checked what is inside /usr/share/icons and in the directories below?
Same thing for $HOME/.icons and below that?
Are there actual files - and different ones - in there?

The file manager will show you the icons

ls -al /usr/share/icons
ls -al $HOME/.icons

in a terminal

ls -al /usr/share/icons/*

will print a list of everything that is in each directory
same for what is installed in your $HOME

ls -al $HOME/.icons/*

maybe the MacOS window theme (with the red,yellow, green buttons in the title bar)
is demanding specific icons?
Could it be? I don’t know.
What if you change that and see whether your icons then can actually be changed, too? :wink: