No HDMI output signal on AMD/NVIDIA hybrid laptop

Hello togehter,
I got a new Asus TUF laptop, which comes with a Ryzen 7 3750h CPU and a GTX1650 GPU. I’m unable to get an external monitor to work. (e. g. a working monitor or a TV)

Xrndr recognize the external hdmi device:

~ >>> xrandr                                                                   
Screen 0: minimum 320 x 200, current 5760 x 2160, maximum 16384 x 16384
eDP connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 382mm x 215mm
   1920x1080    120.00*+  48.00  
   1680x1050    120.00  
   1280x1024    120.00  
   1440x900     120.00  
   1280x800     120.00  
   1280x720     120.00  
   1024x768     120.00  
   800x600      120.00  
   640x480      120.00  
HDMI-1-0 connected
   3840x2160     30.00 +  59.94    50.00    29.97    25.00    23.98    23.98  
   4096x2160     29.97    25.00    24.00    23.98  
   1920x1080     60.00    59.94    50.00    29.97    25.00    23.98  
   1280x1024     60.02  
   1280x960      60.00  
   1280x720      60.00    59.94    50.00  
   1024x768      60.00  
   800x600       60.32  
   720x576       50.00  
   720x480       59.94  
   640x480       59.94    59.93  

My installed drivers:

> 0000:01:00.0 (0300:10de:1f91) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-amd-nvidia-prime            2020.11.30               false            PCI
          video-nvidia            2020.11.30               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> 0000:05:00.0 (0300:1002:15d8) Display controller ATI Technologies Inc:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-amd-nvidia-prime            2020.11.30               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

~ >>

In the meantime i tried to fix is with de workaround from this thread:

But sadly it not work for me.
Do you have any idea what I can do to fix this?

Thank you!

As per NVIDIA documentation:

  • The NVIDIA driver currently cannot be used as an output sink when the output source driver is xf86-video-amdgpu.

This is probably why you cannot get the external monitor to work. I’m not sure how the issue got resolved in the other, thread, since it technically shouldn’t be possible; maybe the README is out of date? Anyways, there are two things you can do:


Install optimus-manager-git from AUR, and switch to the “nvidia” mode. I’m pretty sure this should reliably work no matter intel+nvidia or amd+nvidia configuration. Please refer to this guide on how to install optimus-manager. Please ignore the

So if you have AMD-Nvidia, stop reading futher as the guide below is only for Intel-Nvidia and you don’t need any of this.

part. And in the first step, run pamac build optimus-manager-git instead of what’s written in the guide, you can safely ignore the second step as well. If you want a tray applet to control which GPU is active, install optimus-manager-qt: pamac build optimus-manager-qt-git.


Change the Xorg driver of your AMD GPU to “modesetting”. I’m not 100% sure, but it’s worth a try in my opinion.

Hey thank you for your reply,

hmm I don´t know if the repo from the other thread is outdated… the last change was for 10 months…?

Okay maybe I try your idea with the optimus-manager.
Do I have to switch my graphic driver from video-nvidia to video-hybrid-amd-nvidia-prime before I try your suggestion?

If the current installed mhwd configuration is video-nvidia, then I first suggest removing that and installing video-hybrid-amd-nvidia-prime.

HI, Specter 456,
If sound is concerned …
only one idea … could be not question of driver but change swichting HDMI way-out instead speackers way …
'Left click at Sound volume of Taskbar - Change HDMI/display instead Digital/Output
Maybe ??

from a Newbye

So I choose the way from pobrn,

  1. uninstall video-nvidia
  2. install video-hybrid-amd-nvidia-prime
  3. install optimus-manager
  4. install optimus-manager-qt
  5. disable xorg graphic configurations (look at the link to the Guide)
  6. install gdm prime (look at the link to the Guide)
  7. enable gdm systemctl… (look at the link to the Guide)
  8. set Wayland to false (look at the link to the Guide)
  9. control if the systemctl service is running (look at the link to the Guide)
    => systemctl status optimus-manager.service
  10. enable optimus-manager-qt as autostart app

=> So at startup there is the amd gpu choosen.
=> If I want to use a extern monitor or if I need the power of the nvidia gpu I switch via the optimus-manager-qt to the nvidia gpu (after the change to nvidia there is the hybrid icon active. But I checked with << nvidia-smi if the nvidia gpu is active, and thats the case.)

>>> nvidia-smi                                                               
Tue Jan  5 09:36:16 2021       
| NVIDIA-SMI 455.45.01    Driver Version: 455.45.01    CUDA Version: 11.1     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|   0  GeForce GTX 1650    Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   44C    P8     1W /  N/A |    221MiB /  3911MiB |      5%      Default |
|                               |                      |                  N/A |
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|    0   N/A  N/A      8902      G   /usr/lib/Xorg                     101MiB |
|    0   N/A  N/A      8978      G   /usr/bin/gnome-shell               24MiB |
|    0   N/A  N/A     11353      G   ...AAAAAAAA== --shared-files       92MiB |

1000 thanks to pobrn!

Thank you for your help!
But the answer from @pobrn solved my problem!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.