No GUI desktop starting up

Hello,

After the latest updates I have been fighting through all sorts of graphics issues. I thought I had resolved them but now I am back to no plasma desktop login prompt. Just a terminal screen. Any ideas on how I can re-enable the GUI?

Please do the following:

  • login with your username and password.

  • run the command

    startx
    

    on the terminal and the plasma desktop will appear.

  • In System settings subsection Login Screen

    • select the login screen
    • Apply the changes.
  • Again in System Settings, locate System administration, then Systemd

    • look for the button Default in the bottom left corner of the window
    • click on it.
  • Still in System Settings, go to Background Services and Applications in the Startup and Shutdown section verify menu daemon is running.

  • Finally: reboot.

I think that the above steps are not necessary whether you could successfully initiate the plasma desktop, but I hope it could help.

2 Likes

@j8a

startx gives me this:

Server terminated with error (1). Closing file.

xinit: giving up
xinit: unable to connect to X server: Connection refused

1 Like

Please try the following post stating that the right command is the following:

startplasma-x11

I suggest you to read the whole post, because it could solve your problem.

:crossed_fingers:

1 Like

That did not help much. Still complaining about X server. I would like to refresh my installation but I am afraid it’s going to require me to wipe my existing install with all my apps and home directory. :frowning:

1 Like

Hi, I’m vanhertz, I lose the interface all the time, it happens to me often because it tries new video drivers, both proprietary and open source, we’ll see if it works for you …
I will also leave a page which helped me for a long time., this continues to work so please thank our friend Jose, who announced the solution some time ago

step 1: after 15 minutes or when you think it is already started, if you cannot visualize you can start a session in the tty, pressing control + alt + f2(any f up to f6 f1 are the gui session or maby f7 just press f2 for easy).

Once tt2 appears, you will see that it asks for a user, enter the name of the user you want to start … you can also start as root user, typing root when the user in question asks, write the password (this is not visualize but if it is written, make sure not to make a mistake) of the user in question, for example if you want to start as root it would be something like in the following image:

picture


Step 2: once inside, what to do is remove the graphics drivers, in this case we will make sure to remove all of them and then install only 1.
first you have to list the drivers and targets with the command:

mhwd -li

It will be something similar to this:

example and target

We will only focus on the graphic section, so we will eliminate all the drivers of the graphic controller with the command:

mhwd -r pci driver-name

the name corresponds to the first column as in the following example:

example2

so…example mhwd -r pci video-linux…just repeat until all is erased (just in grafic controller)

Now to finish, we will install the free drivers with the following command, but before … remember the red circle marked in “examples and targets”, because that number you must use in the next command … in my case it is “0300” … so the command is:

mhwd -a pci free 0300

if your “number” is another just replace, now once installed you should see the graphical session when changing from tty … press:

Control + Alt + f1

and enjoy the freedom that Manjaro gives you.
If you have already done everything and you do not see the GUI restart the pc and it should be fixed, if not, check the page that I leave next, it is the one I said at the beginning of this answer … good luck.

2 Likes

Ah…also, you can trying to change core…it’s posible to do it whit comand :slight_smile:
Just install it (download) and…when you get in the grub…(Manjaro manager :v) go to second option and select your core

Thank you sooo much. you saved my day !