No GUI after the latest update

Was running Manjaro Gnome.

For the past couple of days, it was showing a large update available.

I finally did it today and now there is no GUI. I tried booting into 5.14, 5.13, 5.10 and 5.4 kernels. Still, the same story.

startx from a TTY produces an error. The relevant parts are:

[    78.906] (WW) NVIDIA(0): The NVIDIA GeForce GTX 650 Ti GPU installed in this system is
[    78.906] (WW) NVIDIA(0):     supported through the NVIDIA 470.xx Legacy drivers. Please
[    78.906] (WW) NVIDIA(0):     visit for more
[    78.906] (WW) NVIDIA(0):     information.  The 495.44 NVIDIA driver will ignore this

So, I tried installing nvidia470xx-utils. It results in a conflict with the following error:

:: removing nvidia-utils breaks dependency 'nvidia-utils=495.44' required by linux510-nvidia
:: removing nvidia-utils breaks dependency 'nvidia-utils=495.44' required by linux513-nvidia
:: removing nvidia-utils breaks dependency 'nvidia-utils=495.44' required by linux514-nvidia
:: removing nvidia-utils breaks dependency 'nvidia-utils=495.44' required by linux54-nvidia

How do I get out of this problem?

Can you boot into any earlier timeshift snapshot if accessible from GRUB?

@Shirshendu Thanks. But I do not have any timeshift snapshots. I was using restic to backup.

Boot from a pendrive, mount Manjaro root partition and browse the latest entries of pacman log or right from “broken” Manjaro tty with tac /var/log/pacman.log | less. Maybe you will spot some errors or warnings. Based on that undertake further steps like chrooting, etc.

Posted from phone, sorry for mistakes and/or typos.

PS: in order to have your computer operable, just install a backup OS like Ubuntu 20.04 so you could use it in case of emergency (similar to what you’re experiencing right now). Btw it is perfectly possible to chroot using other installed Linux so you won’t have to use some slow pendrive.

@openminded Thanks. I am able to boot without any problem. It is only the GUI that is broken.

Checked tac /var/log/pacman.log | less

Nothing suspicious there.

Could it be something to do with video drivers? I have an NVIDIA card.

Do you get errors when to start X from TTY?


@maycne.sonahoz Thanks. That uncovered a lot of information. I have updated the question with it. A quick summary of the problem is here. My graphics card needs nvidia470xx. With the update, nvidia495xx is installed. And now I am unable to install nvidia470xx because it breaks down some dependencies. How to get out of this?

the stable branch is still using 470xx not 495xx, you could try switching to that.

I assume you’re on the testing branch if you’re on 495xx now.

But yeah, support for some cards was dropped with 495xx unfortunately, that piece of shit company…

Use pacman to delete nvidia 495 driver packages including kernel modules like linux510-nvidia and so on and remove EOL linux513:
sudo pacman -R linux54-nvidia linux514-nvidia linux513-nvidia linux510-nvidia linux513 linux513-headers
Then install driver v.470:
sudo pacman -S linux54-nvidia-470xx linux510-nvidia-470xx linux514-nvidia-470xx nvidia-470xx-utils lib32-nvidia-470xx-utils



@openminded Thanks. That worked as a charm. I am writing this comment from my usual machine.

Just one more question. Every time I upgrade, nvidia470 would be updated to nvidia495, etc.? And every time I will have to go through the same steps?

No it’s unlikely. Now you have “nvidia-470xx” packages installed, which conflict with the newest 495 series. The reason why you encountered this problem was that you didn’t follow recent Manjaro announcements where it had been stated that Manjaro is going to introduce a separate v 470 driver series, buy the default one would be v 495. I guess you’re on Unstable or Testing branch? You’d better start reading Announcements topics before applying updates :wink:

@openminded Thanks. Will it be a better idea for a newbie like me to move to ‘stable’? I am currently using ‘testing’ branch. Being a step farther from the cutting edge is better than having a broken system.

Also, what command tells me which branch I am using? I found it out by looking up my command prompt history :slight_smile:

Yes, obviously. Using the testing branch does bring updates earlier, but it is also less stable, as the name suggests.

@maycne.sonahoz Thanks. And how do I know on which branch I am? I know it is too basic a question. But I could not find any answer to this. The wiki talks about switching branches.

Switching Branches - Manjaro

Pacman-mirrors - Manjaro

pacman-mirrors --help

\/ \/ \/ \/ \/ \/ \/ \/ \/ \/ \/ \/ \/ \/ \/ \/ \/ \/

pacman-mirrors -G

@cscs Thanks. Will remember now.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.