No functioning mirror in Australia

Not to sound rude but I don’t think you read the post or title, this doesn’t help at all and I know how they work, the issue here is the Australian mirror went out out of commission apparently

The mirrors are not controlled by Manjaro. So if they go down or become inaccesible for some reason, we can’t do anything about it, until someone mentions it and the Team disables those mirrors in the mirrorlist service.

Some of the questions being asked about selecting a mirror led me to feel some documentation would be good to have linked within the thread.

I’m sorry you found it unhelpful others may feel otherwise :man_shrugging:

1 Like

yeah it’s catch 22, I need to test it before I can ask to be added to the official list haha

Yeah I know that now and understand haha, maybe some quality or reliability control should be done to make sure servers can be official so they can be more relied on and can’t disappear for no reason or have separate communities servers for countries :slightly_smiling_face:

haha yeah that’s understandable, I will have to test it and let you know how it goes

I added it to the json file and testing, how do I see if it’s in use?

The issue only really appear if you limit your mirrorlist to much. The chances of the only 2 mirrors in the same country going down at the same time is minimal. It was probably just bad luck.

But if the servers don’t come online soon, they should be removed from the official mirrorlist.

Wouldn’t you add it to /etc/pacman.d/mirrorlist

Sadly they both got decommissioned so we should look at decommissioning them.	Australia	http	N/A	Unknown	Unknown	Unknown	Australia	http	1117:40	Out of date	Out of date	Out of date

you can use pacman-mirrors to temporarily overwrite your mirror list.
sudo pacman-mirrors --api -u

If you do that one you have to rebuild your mirror list after you finish testing however.
But if you just add it in the custom mirrors list then it should get preferenced with out having to overwrite the rest of your mirror list.

Ahh ok well I just added it to my /etc/pacman.d/mirrorlist like so

## Country : Australia Custom
Server =$repo/$arch

Needs to be an -U. Not lower case. Or she will say.

pacman-mirrors: error: unrecognized arguments: -u


I have reached out to AARNet to see if there is a possibility of adding Manjaro to their mirror service.

yeah, I tried that and got a “will not do” response :frowning:
hence I setup my own, thread here

Just waiting on getting added to the offical list.

my new mirror is now live in Australia and on the official list, so this should now be solved :slight_smile:

1 Like

Good to see a manjaro linux mirror in australia. There are many manjaro users in Australia.

1 Like

I received a response from AARNet. The mirror has now been setup.

Just need to have it added to the official list

thats awesome!

you just need to raise an issue on this repo to get it added!

Thats the plan!

AARNet have just asked me to test it for them. I’m just setting that up now.

1 Like

Anyone else want to test it.

sudo pacman-mirrors --api -U

I haven’t hit it with something big… Like a big dirty update.