No functional WiFi after 2021-01-19 stable update

I don’t have a functional WiFi connection after the latest stable update. KDE shows it as connected with an exclamation mark. I can ping my router, but I can’t access the web. Downgrading NetworkManager restores the functionality. System specs can be found below.

  Kernel: 5.4.89-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=a5710dc2-1637-47f9-a1be-a92a8d28f0aa ro scsi_mod.use_blk_mq=1 
  resume=UUID=a5710dc2-1637-47f9-a1be-a92a8d28f0aa resume_offset=15566848 
  quiet nmi_watchdog=0 
  Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Laptop System: Hewlett-Packard product: HP EliteBook Folio 9470m 
  v: A1029D1102 serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: Hewlett-Packard model: 18DF v: KBC Version 62.19 serial: <filter> 
  UEFI: Hewlett-Packard v: 68IBD Ver. F.73 date: 04/12/2019 
  ID-1: BAT0 charge: 9.7 Wh condition: 14.2/14.2 Wh (100%) volts: 15.1/14.8 
  model: Hewlett-Packard Primary type: Li-ion serial: <filter> 
  status: Discharging 
  Info: Dual Core model: Intel Core i5-3427U bits: 64 type: MT MCP 
  arch: Ivy Bridge family: 6 model-id: 3A (58) stepping: 9 microcode: 21 
  L2 cache: 3 MiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 18366 
  Speed: 798 MHz min/max: 800/1200 MHz Core speeds (MHz): 1: 798 2: 798 3: 798 
  4: 798 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Vulnerable: No microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Hewlett-Packard 
  driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0166 
  Device-2: Chicony HP HD Webcam [Fixed] type: USB driver: uvcvideo 
  bus ID: 1-1.3:3 chip ID: 04f2:b346 serial: <filter> 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: 
  loaded: intel display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
  s-diag: 414mm (16.3") 
  Monitor-1: LVDS1 res: 1366x768 hz: 60 dpi: 112 size: 310x170mm (12.2x6.7") 
  diag: 354mm (13.9") 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) 
  v: 4.2 Mesa 20.3.3 compat-v: 3.0 direct render: Yes 
  Device-1: Intel 7 Series/C216 Family High Definition Audio 
  vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:1e20 
  Sound Server: ALSA v: k5.4.89-1-MANJARO 
  Device-1: Intel 82579LM Gigabit Network vendor: Hewlett-Packard 
  driver: e1000e v: 3.2.6-k port: 2080 bus ID: 00:19.0 chip ID: 8086:1502 
  IF: enp0s25 state: down mac: <filter> 
  Device-2: Intel Centrino Advanced-N 6235 driver: iwlwifi v: kernel 
  port: ef80 bus ID: 03:00.0 chip ID: 8086:088e 
  IF: wlo1 state: up mac: <filter> 
  IF-ID-1: wwp0s26u1u5i6 state: down mac: <filter> 
  Local Storage: total: 342.81 GiB used: 196.73 GiB (57.4%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Silicon Power 
  model: SPCC Solid State Disk size: 223.57 GiB block size: physical: 512 B 
  logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 6A 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Vaseky model: V800 128G 
  size: 119.24 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 7A 
  ID-1: / raw size: 64 GiB size: 62.5 GiB (97.65%) used: 52.34 GiB (83.8%) 
  fs: ext4 dev: /dev/sda1 maj-min: 8:1 
  ID-2: /boot/efi raw size: 512.6 MiB size: 511.6 MiB (99.80%) 
  used: 14.8 MiB (2.9%) fs: vfat dev: /dev/sda4 maj-min: 8:4 
  Kernel: swappiness: 5 (default 60) cache pressure: 100 (default) 
  ID-1: swap-1 type: file size: 16 GiB used: 0 KiB (0.0%) priority: -2 
  file: /swapfile 
  System Temperatures: cpu: 52.0 C mobo: 0.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 188 Uptime: 16m wakeups: 1 Memory: 15.51 GiB 
  used: 2.17 GiB (14.0%) Init: systemd v: 247 Compilers: gcc: 10.2.0 
  clang: 11.0.1 Packages: pacman: 1693 lib: 496 flatpak: 0 Shell: Bash 
  v: 5.1.0 running in: yakuake inxi: 3.2.02

Thanks for your support.

Try this:

  • Install systemd-resolvconf (replaces openresolv)
  • Enable the systemd-resolved service:
    systemctl enable --now systemd-resolved
  • Upgrade networkmanager & libnm to the latest versions again

It’s not that you don’t have WiFi. You don’t have functioning DNS.

You might as well check this config /etc/resolv.conf whether it has some DNS addresses specified at all. Sometimes it drops down to or in my case. Try to remove all local IP addresses in this config and put nameserver on top or any other DNS address.

I don’t have openresolv installed and systemd-resolved is disabled. Nonetheless, I have working connection (with downgraded NM). Is your suggestion still valid?

May be so. I’m not sure. I’ve edited the title to make it less ambiguous.

That’s the first thing I did. It was empty. It has my router’s address at this moment.

Can try
ping -4
ping -4
If the latter fails, it’s likely DNS.

Possibly not as it was mostly for issues folks had been having with VPN’s. You could try systemd-resolved without systemd-resolvconf, but either way see systemd-resolved - ArchWiki.

It appears to be a DNS problem. But why must I use a local DNS? I don’t want to.

I tred your suggestion. It worked, but it’s slower. If I ping the reply takes longer to be print, eventhough the ping times don’t differ widely.

This is just strange.

EDIT: I’ll search for similar problems online and retrieve some relevant logs. I’ll also refresh my memory at network troubleshooting. I’ll come back later. Thanks.

See here and here. In the end we have to monitor it more.

1 Like

Thank you. I’ll take a look at it.

Ok, after fiddling with this, I’ve settled with the latest version of NM with systemd-resolved enabled. I’ll mark Yochanan’s post as the solution.

Thank you all for the support.

It seems this isn’t quite fixed yet. If I connect to a network in which I need to accept the terms of use, NM never prompts me. Is there some additional service I need to activate or some packages that I need to install? Again, downgrading NM and disabling systemd-resolved restores functionality. Something is definitely wrong.

Ok, something is definitely wrong. My desktop is also affected. I already noticed my network speed and reliability was sluggish, but I though it was due to the heavy tele-work that is going on. Today, when I connected remotely from my laptop, locally (in my home), the connection was unbearable. That’s when I tried to disable systemd-resolved and downgrade NM. Guess what - it got fixed, both the web surfing and remote connection. Tomorrow I’ll check an older desktop I have (a Pentium D with LXQT).

Ok, I have tested the Pentium D desktop and it works perfectly with the latest NM and without both systemd-resolved and openresolv :thinking:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

This was fixed by the 2021-02-09 Stable Update.