[Stable Update] 2021-01-19 - Kernels, XFCE, Plasma, PulseAudio, Pipewire, Mesa, Firefox, Thunderbird, KDE Apps

Even with the last update of Pulseaudio the problem of Pulseaudio still persists, forcing me to use Pavucontrol to select the sound output every time I turn on the PC

Yes, I too experienced the same. Changing the compositor to OpenGL 2.0 solved the problem for me. (Scale method: Accurate, Tearing Prevention “vsync”: Automatic)

1 Like

After updating I noticed that while my Laptop is connected to the network, it can’t connect to the internet. while my phone is still able to use it. I don’t know what to do, so I wish someone here would guide me on how to solve it

EDIT: navigating the forum with phone wasn’t easy. After properly reading through the thread I find @mbb’s solution to downgrade the networkmanager package. it worked.

Why is Kernel 5.10 still shown with no Infos in Manjaro Settings Manager?
Is this Kernel still experimental or recommended or something between?

Btw. no issues after the last update… goodjob, i love Manjaro (I use Linux since 4 Month now after 27 Years Windows and you guys can count on a regular Donation :slight_smile:


As long as it’s not officially named LTS, it’s a normal kernel for now.
It will whange when next kernel 5.11 will go out.

1 Like

You can update NM and then enable systemd-resolved service.

sudo systemctl enable systemd-resolved

The reboot. See here.

1 Like

Update went smoothly on KDE with 5.4 kernel.
My graphics hardware are :

inxi -G
Graphics:  Device-1: Intel UHD Graphics 630 driver: i915 v: kernel
Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] driver: N/A

I used to use these drivers :

mhwd -li
> Installed PCI configs:
              NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-430xx-bumblebee            2019.10.25               false            PCI
       video-linux            2018.05.04                true            PCI

After this update I have :

mhwd -li
> Installed PCI configs:
              NAME               VERSION          FREEDRIVER           TYPE
       video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

Graphics hardware are a mystery to me, can someone explain me like I am 5 what are the changes for me ?
What should I expect ? Performance loss ? Battery time decrease ? Glitches ?
What should I monitor to see if everything goes fine in the next days ?

Thanks !

I get an error when I try to update because of the removal of sip.

[johnblood@manjaro ~]$ yay
[sudo] password for johnblood: 
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
:: Replace python-pyqtwebengine with extra/python-pyqt5-webengine? [Y/n] 
:: Replace python-sip with extra/python-sip4? [Y/n] 
:: Replace sip with extra/sip4? [Y/n] 
warning: sndio: local (20180120-1) is newer than community (1.7.0-3)
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing sip breaks dependency 'sip' required by python-pyqt4
error installing repo packages

Would it be okay to skip the sip changes?


No, don’t skip them.

I did a reverse dependency search and python-pyqt4 is not used by anything, so I removed it. Now the update is running okay.

Continuing issue with whole-disk passthrough in libvirt, as I’ve documented in the Virtualization section (sorry, I’m not yet allowed to post links, but a search for devmapper will turn it up).


Instead of sudo pacman -Syu I ran the upgrade via the update notifier in the taskbar. It handled it perfectly. Linux command terminal is soo 90ies :crazy_face: .

I tried to run the updated, but it failed. This was the error I got :

    fout:fout bij het uitvoeren van de transactie (conflicterende bestanden)
    python-urllib3: /usr/lib/python3.9/site-packages/urllib3/util/__pycache__/proxy.cpython-39.pyc bestaat in bestandssysteem
    python-urllib3: /usr/lib/python3.9/site-packages/urllib3/util/__pycache__/ssltransport.cpython-39.pyc bestaat in bestandssysteem
    python-urllib3: /usr/lib/python3.9/site-packages/urllib3/util/proxy.py bestaat in bestandssysteem
    python-urllib3: /usr/lib/python3.9/site-packages/urllib3/util/ssltransport.py bestaat in bestandssysteem
    Er zijn fouten opgetreden, geen enkel pakket geüpgraded.

This is some info about my system :

  Host: desktop Kernel: 5.4.85-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 10.2.0 Desktop: Xfce 4.14.3 tk: Gtk 3.24.23 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux
  Device-1: NVIDIA GM206 [GeForce GTX 960] vendor: Hewlett-Packard 
  driver: nvidia v: 455.45.01 bus ID: 01:00.0 chip ID: 10de:1401 
  Display: server: X.Org 1.20.10 driver: nvidia resolution: 1920x1080~60Hz 
  s-dpi: 96 
  OpenGL: renderer: GeForce GTX 960/PCIe/SSE2 v: 4.6.0 NVIDIA 455.45.01 
  direct render: Yes

Not sure what you mean by no infos? 5.10 is version 5.10.7-3. It is the latest STABLE release. If you are referring to it being marked LTS that is not going to arbitrarily happen. What defines it as a LTS kernel are the developers at kernel.org. They are the ones who maintain the kernels and THEY are the ones who will mark it as LTS when it is appropriate to do so. This will occur most likely when 5.11 gets released as a regular STABLE kernel and 5.10 then becomes the latest LTS kernel, at that time 5.12 will become the new experimental kernel. The manjaro team doesn’t have control over when the kernel developers mark a kernel as LTS. Even though we all know that 5.10 will become the next LTS kernel at this time it is NOT a LTS kernel and that is why it is not marked as such yet. Head over to kernel.org if you ever have any questions about the current state of a kernel as they are the source of that information.

1 Like

You could try:
sudo pacman -Syu --overwrite="/usr/lib/python3.9/site-packages/urllib3/util/*"

Make a backup first, in case you’re going to follow this smattering advice… :crossed_fingers:

I get this error on boot:
[FAILED] Failed to start Wait for Network to be Configured
See ‘systemctl status systemd-networkd-wait-online.service’ for details.

Now I have ‘[Ok] Finished TLP system startup/shutdown.’ and a blinking underscore on my screen.
I can login on tty2.

I installed sip 6 instead of sip4.
Wrong idea?

Thank you for your answer! Sadly, that doesn’t seem to work for me.

It works. thank you so much.

1 Like

I usually like some adventure, but something tells me not to go for this one. Any other ideas please?

Hi Jan,

Have you tried one of the solutions in the top post? Some help on getting the gui up and running again: