No boot after kernel update attempt, how to install kernel from live boot?

I tried to upgrade from kernel 5.15 to 6.1 after hearing it could solve an audio issue I’ve been experiencing: No audio on some bootups - #8 by rrd , but after removing 5.15, running the command for installing 6.1 and restarting, my system fails to boot. Presumably the install failed and now there’s no kernel.

So now I’d like to install 5.15 again - what are the exact steps for installing a kernel on an existing system via live boot? I found some guides but they are too fragmentary and vague.

boot into manjaro live usb, connect to internet, and chroot:
manjaro-chroot -a
install kernels:
pacman -S linux515 linux60
if there are no errors, exit chroot:

Thank you, will attempt this shortly.

Or you can use:

mhwd-kernel --install linux515

I recommend version 5.15 as it’s the latest LTS one.

So I ran these commands, and got the followig output:

grub-probe: error: cannot find a GRUB drive for /dev/sdc1. Check your
grub-probe: error: cannot find a GRUB drive for /dev/sdc1. Check your
==> Mounting (ManjaroLinux) [/dev/sdb2]
 --> mount: [/mnt]
 --> mount: [/mnt/boot/efi]
 --> mount: [/mnt/run/media/svalbardsleeperdistrict/7A37EAEA4783A250]
fuse: failed to access mountpoint /mnt/run/media/svalbardsleeperdistrict/7A37EAEA4783A250: No such file or directory

sdc is the thumb drive I’m running the live boot from, and 7A37EAEA4783A250 should be either the shared NTFS drive I use to access from both Windows and Manjaro, or the Windows installation drive (I have three drives, the third - sdb - is the one for Manjaro installation).

I ran the kernel install anyway (on two separate tries using both methods in posts above), and while it completed successfully, there were a number of error messages during the installation - these errors were also present when I tried to install kernel v6:

WARNING: consolefont: no font found in configuration
WARNING: Possibly missing firmware for module: bfa
WARNING: Possibly missing firmware for module: qla1280
WARNING: Possibly missing firmware for module: qla2xxx
WARNING: Possibly missing firmware for module: qed
WARNING: Possibly missing firmware for module: xhci_pci

If I check if the kernel has been installed successfully with pacman -Ss linux5* | grep "installed", I can see that 5.15.81-1 is indeed installed.

But after a reboot, the boot is stuck at the same spot (with no error messages, just the text entry cursor blinking). It also looks like that unlike previous attempts, now I don’t have grub anymore. I tried rebuilding it from live session after doing manjaro-chroot -a but no effect.

On a side note: it is good practice to more than one kernel installed, exactly in cases like those when the newer kernel does not work as intended. Installing a newer kernel does not require you to remove the old one (unless the latter is EOL).

1 Like

those warnings are not important… everyone has them…
was everyhting working before you tried installing the linux 6?
from chroot rerun update first:
pacman-mirrors --fasttrack 5 && pacman -Syyu
if there are no errors, post output from:
mhwd-kernel -li
and logs:
journalctl -b-1 -p5 --no-pager

Before the kernel6 install attempt, the only issue I was experiencing was the missing sound (linked in the OP).

There were no errors from mirror update. The output from mhwd-kernel -li is:

Currently running: 5.15.60-1-MANJARO (linux515)
The following kernels are installed in your system:
    * linux515
    * linux60
    * linux61

And the journalctl output is here: journalctl output -

you have these:

Dec 09 16:44:16 ssddl systemd-modules-load[241]: Failed to find module 'nvidia'
Dec 09 16:44:16 ssddl systemd-modules-load[241]: Failed to find module 'nvidia-drm'
Dec 09 16:44:16 ssddl systemd-modules-load[241]: Failed to find module 'nvidia-uvm'

post output from:
mhwd -l -li
inxi -G
ls /etc/modprobe.d
find /etc/X11/ -name "*.conf"

mhwd -l -li output: mhwd -l -li -

inxi -G output:

  12Device-1 NVIDIA GP104 [GeForce GTX 1070] 12driver nouveau 12v kernel
  12Display 12server X.Org 12v 21.1.4 12driver 12X 12loaded nvidia 12gpu nouveau 12resolution 121 1920x1080~60Hz
    122 1680x1050~60Hz
  12API OpenGL 12Message Unable to show GL data. Required tool glxinfo missing.

ls /etc/modprobe.d output: mhwd-gpu.conf

find /etc/X11/ -name "*.conf" output:


looks ok…
post also output from:
pacman -Qs optimus
pacman -Qm

pacman -Qs optimus has no output, while pacman -Qm returned this:

debtap 3.5.1-1
gcolor2 0.4-9
guilded 1.0.9161723.master-1
manjaro-firmware 20160419-1
metis 5.1.0.p10-2

you can remove this:
pacman -Rs manjaro-firmware
its a dead package…

now add this parameter:
open this file:
nano /etc/default/grub
and inside this line: GRUB_CMDLINE_LINUX_DEFAULT inside the quotes add this parameter:
dont remove anything, just add it to existing parameters;
and change this line to look like this:
save the file with ctrl+x, update grub:

uninstall nvidia:
mhwd -r pci video-nvidia
install it again:
mhwd -i pci video-nvidia
exit chroot, reboot and see if you can boot…
also try with different kernels

Many thanks - that fixed it. The only issue is now the Windows entry is gone from grub - should I repair it from Windows installation software? I’ve done that successfully once in past.

run this: (not from chroot, but from your installation)
sudo update-grub
reboot and windows should be there

1 Like

That was perfect, many thanks for the help throughout - I had not backed up the most recent config files for my i3wm and Polybar, and had the issue with no boot required a reinstall, a lot of configurations in those would have to be remade. I appreciate your time very much.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.