No audio on some bootups

On about every third/fourth bootup over the past few weeks, my system has had no sound. I searched for threads on this, but the solutions there don’t seem to be relevant to my issue.

I initially thought this issue had been created by my experimentation with login managers, as it was pointed out to me in a related thread that my sound servers weren’t running: Dbus error, sound gone after replacing lightdm with ly - #3 by mithrial The issue isn’t fixed by me running the command indicated in that post though, and I’ve also since reverted login manager to lightdm.

inxi -Fazy output:

  Kernel: 5.15.78-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=c5d0936d-2e66-4d0a-8d24-3e703a917a0a rw quiet apparmor=1
    security=apparmor resume=UUID=dec7a2a8-2900-406c-8eec-5c31a480d1a7
  Desktop: i3 v: 4.21.1 info: polybar vt: 7 dm: LightDM v: 1.32.0
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Gigabyte product: Z170X-Gaming 5 v: N/A
    serial: <superuser required>
  Mobo: Gigabyte model: Z170X-Gaming 5 v: x.x serial: <superuser required>
    UEFI: American Megatrends v: F21 date: 03/06/2017
  Info: model: Intel Core i5-7600K bits: 64 type: MCP arch: Kaby Lake
    gen: core 7 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 9 microcode: 0xF0
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 800 min/max: 800/4200 scaling: driver: intel_pstate
    governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 bogomips: 30409
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT disabled
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
  Device-1: NVIDIA GP104 [GeForce GTX 1070] vendor: Gigabyte driver: nvidia
    v: 520.56.06 alternate: nouveau,nvidia_drm non-free: 520.xx+
    status: current (as of 2022-10) arch: Pascal code: GP10x process: TSMC 16nm
    built: 2016-21 pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.0
    chip-ID: 10de:1b81 class-ID: 0300
  Device-2: Logitech C920 PRO HD Webcam type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-6:3 chip-ID: 046d:08e5
    class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 compositor: Picom v: git-7e568
    driver: N/A display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3600x1080 s-dpi: 101 s-size: 905x272mm (35.63x10.71")
    s-diag: 945mm (37.2")
  Monitor-1: DVI-D-0 pos: primary,left res: 1920x1080 hz: 60 dpi: 102
    size: 477x268mm (18.78x10.55") diag: 547mm (21.54") modes: N/A
  Monitor-2: HDMI-0 pos: right res: 1680x1050 hz: 60 dpi: 93
    size: 459x296mm (18.07x11.65") diag: 546mm (21.5") modes: N/A
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel bus-ID: 1-6:3 chip-ID: 046d:08e5
    bus-ID: 00:1f.3 chip-ID: 8086:a170 class-ID: 0102 class-ID: 0403
    serial: <filter>
  Device-2: NVIDIA GP104 High Definition Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:10f0 class-ID: 0403
  Device-3: Logitech C920 PRO HD Webcam type: USB
    driver: snd-usb-audio,uvcvideo
  Device-4: SteelSeries ApS Arctis 7 type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-2:2 chip-ID: 1038:12ad
    class-ID: 0300
  Sound API: ALSA v: k5.15.78-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.59 running: yes
  Device-1: Intel Ethernet I219-V vendor: Gigabyte driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
  IF: enp0s31f6 state: down mac: <filter>
  Device-2: Qualcomm Atheros Killer E2400 Gigabit Ethernet vendor: Gigabyte
    driver: alx v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000
    bus-ID: 0c:00.0 chip-ID: 1969:e0a1 class-ID: 0200
  IF: enp12s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  Local Storage: total: 1.14 TiB used: 30.98 GiB (2.7%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: TeamGroup model: TM8FP6512G
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: SN08868 temp: 35.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 EVO 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 2B6Q scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Kingston model: SA400S37240G
    size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: B1H5 scheme: GPT
  ID-1: / raw-size: 188.84 GiB size: 184.81 GiB (97.87%)
    used: 30.95 GiB (16.7%) fs: ext4 dev: /dev/sdb2 maj-min: 8:18
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 27.6 MiB (9.2%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 34.44 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sdb3 maj-min: 8:19
  System Temperatures: cpu: 35.0 C mobo: N/A gpu: nvidia temp: 33 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
  Processes: 225 Uptime: 1m wakeups: 2 Memory: 31.31 GiB used: 3.21 GiB (10.2%)
  Init: systemd v: 251 default: graphical tool: systemctl Compilers:
  gcc: 12.2.0 clang: 14.0.6 Packages: 1335 pm: pacman pkgs: 1328 libs: 337
  tools: pamac,yay pm: flatpak pkgs: 7 Shell: Bash v: 5.1.16
  running-in: alacritty inxi: 3.3.23

pacmd dump:

### Configuration dump generated at Sun Dec  4 14:17:56 2022

load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore
load-module module-augment-properties
load-module module-switch-on-port-available
load-module module-udev-detect
load-module module-alsa-card device_id="3" name="pci-0000_01_00.1" card_name="alsa_card.pci-0000_01_00.1" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-alsa-card device_id="2" name="usb-046d_HD_Pro_Webcam_C920_E6B65C6F-02" card_name="alsa_card.usb-046d_HD_Pro_Webcam_C920_E6B65C6F-02" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-alsa-card device_id="0" name="usb-SteelSeries_SteelSeries_Arctis_7-00" card_name="alsa_card.usb-SteelSeries_SteelSeries_Arctis_7-00" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-alsa-card device_id="1" name="pci-0000_00_1f.3" card_name="alsa_card.pci-0000_00_1f.3" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-bluetooth-policy
load-module module-bluetooth-discover
load-module module-bluez5-discover
load-module module-dbus-protocol
load-module module-gsettings
load-module module-default-device-restore
load-module module-always-sink
load-module module-intended-roles
load-module module-suspend-on-idle
load-module module-console-kit
load-module module-systemd-login
load-module module-position-event-sounds
load-module module-role-cork
load-module module-filter-heuristics
load-module module-filter-apply
load-module module-cli-protocol-unix

set-sink-volume alsa_output.pci-0000_01_00.1.hdmi-stereo-extra1 0x10000
set-sink-mute alsa_output.pci-0000_01_00.1.hdmi-stereo-extra1 no
suspend-sink alsa_output.pci-0000_01_00.1.hdmi-stereo-extra1 yes
set-sink-volume alsa_output.usb-SteelSeries_SteelSeries_Arctis_7-00.mono-chat 0x10000
set-sink-mute alsa_output.usb-SteelSeries_SteelSeries_Arctis_7-00.mono-chat no
suspend-sink alsa_output.usb-SteelSeries_SteelSeries_Arctis_7-00.mono-chat yes
set-sink-volume alsa_output.usb-SteelSeries_SteelSeries_Arctis_7-00.stereo-game 0xfffc
set-sink-mute alsa_output.usb-SteelSeries_SteelSeries_Arctis_7-00.stereo-game no
suspend-sink alsa_output.usb-SteelSeries_SteelSeries_Arctis_7-00.stereo-game yes
set-sink-volume alsa_output.pci-0000_00_1f.3.analog-stereo 0x10000
set-sink-mute alsa_output.pci-0000_00_1f.3.analog-stereo no
suspend-sink alsa_output.pci-0000_00_1f.3.analog-stereo yes

set-source-volume alsa_output.pci-0000_01_00.1.hdmi-stereo-extra1.monitor 0x10000
set-source-mute alsa_output.pci-0000_01_00.1.hdmi-stereo-extra1.monitor no
suspend-source alsa_output.pci-0000_01_00.1.hdmi-stereo-extra1.monitor yes
set-source-volume alsa_input.usb-046d_HD_Pro_Webcam_C920_E6B65C6F-02.analog-stereo 0xbc51
set-source-mute alsa_input.usb-046d_HD_Pro_Webcam_C920_E6B65C6F-02.analog-stereo no
suspend-source alsa_input.usb-046d_HD_Pro_Webcam_C920_E6B65C6F-02.analog-stereo yes
set-source-volume alsa_output.usb-SteelSeries_SteelSeries_Arctis_7-00.mono-chat.monitor 0x10000
set-source-mute alsa_output.usb-SteelSeries_SteelSeries_Arctis_7-00.mono-chat.monitor no
suspend-source alsa_output.usb-SteelSeries_SteelSeries_Arctis_7-00.mono-chat.monitor yes
set-source-volume alsa_output.usb-SteelSeries_SteelSeries_Arctis_7-00.stereo-game.monitor 0x10000
set-source-mute alsa_output.usb-SteelSeries_SteelSeries_Arctis_7-00.stereo-game.monitor no
suspend-source alsa_output.usb-SteelSeries_SteelSeries_Arctis_7-00.stereo-game.monitor yes
set-source-volume alsa_input.usb-SteelSeries_SteelSeries_Arctis_7-00.mono-chat 0xcb59
set-source-mute alsa_input.usb-SteelSeries_SteelSeries_Arctis_7-00.mono-chat no
suspend-source alsa_input.usb-SteelSeries_SteelSeries_Arctis_7-00.mono-chat yes
set-source-volume alsa_output.pci-0000_00_1f.3.analog-stereo.monitor 0x10000
set-source-mute alsa_output.pci-0000_00_1f.3.analog-stereo.monitor no
suspend-source alsa_output.pci-0000_00_1f.3.analog-stereo.monitor yes

set-card-profile alsa_card.pci-0000_01_00.1 output:hdmi-stereo-extra1
set-card-profile alsa_card.usb-046d_HD_Pro_Webcam_C920_E6B65C6F-02 input:analog-stereo
set-card-profile alsa_card.usb-SteelSeries_SteelSeries_Arctis_7-00 output:mono-chat+output:stereo-game+input:mono-chat
set-card-profile alsa_card.pci-0000_00_1f.3 output:analog-stereo

set-default-sink alsa_output.pci-0000_00_1f.3.analog-stereo
set-default-source alsa_input.usb-046d_HD_Pro_Webcam_C920_E6B65C6F-02.analog-stereo

### EOF

I can also look up log files if anyone can tell me which one to look into - I don’t really have experience with that.

I did a pacman update right now, and now the sound is there after reboot. But I have a suspicion this is unrelated. If there is anything in the above output that someone can point out, maybe I can address this in a long term.

Without reading your linked related thread:

Do you by any possibility have an USB-Speaker that is giving you the actual audio?
If that is the case, i do too and have same issue.
The fix is rather simple, just turn-off the speaker device using it’s own buttons and turn it back on.

No idea why it won’t initialize properly though :woman_shrugging:

Thank you for the reply. No, unfortunately that would not fix this as my sound system is not a USB one : ( I appreciate it though!

Yeah another restart and the sound is gone again.

I have the same issue. Sometimes I have sound, sometimes not. Today I was watching a youtube video, the sound was fine and after it was finished and I started a new one, the sound did not worked anymore.

Interesting, my impression is that this happens across different Manjaro installations - most references I’ve found are for more “mainstream” versions, while I’m running the more “niche” i3wm version. Even though I’m not sure if the causes are different in all these cases, the reports are definitely numerous.

On my most recent 3-4 bootups the sound devices seem to be working, but the sounds are muted, so I have to open Pulseaudio config window and unmute them. This is another new behaviour.

I updated to the v6 kernel and it seems to fixed it


There are lot of similar reports about audio problems with kernel update including some ALSA related bug for Intel Skylake. KabyLake and later generations of Intel systems

A lot of users have confirmed that the best, simple solution for this is to install kernel v6.0

Use either Manjaro Settings Manager GUI tool. Or copy/paste this to terminal

sudo mhwd-kernel -i linux60
1 Like

Upgrading kernel seems to have fixed this for me as well.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.