No audio on new install. But am getting audio in Ubuntu

I switched from Kubuntu to Manjaro but am surprised to discover that audio isn’t working in Manjaro. It says that it can’t find any output or input devices.

Sof-firmware is installed by default (as I said its a new install) and its running kernel 6.5.5-1

I’ve seen this problem a lot on this forum and have gone through quite a few threads but haven’t been able to replicate their success (for example a few people have problems because they’re dual booting windows, I only have Manjaro on this laptop)

Here’s the output for sudo dmesg | egrep ‘(snd|sound|sof)’

[    0.058067] software IO TLB: area num 8.
[    0.534498] PCI-DMA: Using software bounce buffering for IO (SWIOTLB)
[    0.534505] software IO TLB: mapped [mem 0x000000008570b000-0x000000008970b000] (64MB)
[    7.831524] snd_hda_intel 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040100
[    7.831536] snd_hda_intel 0000:00:1f.3: Digital mics found on Skylake+ platform, using SST driver
[    8.498025] snd_soc_skl 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040100
[    8.498035] snd_soc_skl 0000:00:1f.3: Digital mics found on Skylake+ platform, using SST driver
[    8.515757] snd_soc_skl 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    8.637252] snd_soc_skl 0000:00:1f.3: Direct firmware load for 9d71-ACRSYS-ACRPRDCT-2-tplg.bin failed with error -2
[    8.637259] snd_soc_skl 0000:00:1f.3: tplg fw 9d71-ACRSYS-ACRPRDCT-2-tplg.bin load failed with -2, trying alternative tplg name skl_hda_dsp_generic-tplg.bin
[    8.637314] snd_soc_skl 0000:00:1f.3: Direct firmware load for skl_hda_dsp_generic-tplg.bin failed with error -2
[    8.637318] snd_soc_skl 0000:00:1f.3: tplg skl_hda_dsp_generic-tplg.bin failed with -2, falling back to dfw_sst.bin
[    8.637365] snd_soc_skl 0000:00:1f.3: Direct firmware load for dfw_sst.bin failed with error -2
[    8.637368] snd_soc_skl 0000:00:1f.3: Fallback tplg fw dfw_sst.bin load failed with -2
[    8.637370] snd_soc_skl 0000:00:1f.3: Failed to init topology!
[    8.637372] snd_soc_skl 0000:00:1f.3: ASoC: error at snd_soc_component_probe on 0000:00:1f.3: -2

Here is the output for inxi -Fazy

  Kernel: 6.5.5-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.5-x86_64
    root=UUID=a7c201c6-76c0-4753-89eb-0276cdc823c3 rw quiet
    root=/dev/mapper/luks-fd1713f4-5ab5-4591-9cd5-5c03fe21d3e0 splash
  Desktop: KDE Plasma v: 5.27.8 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Acer product: Swift SF314-54 v: V1.18
    serial: <superuser required>
  Mobo: KBL model: Strongbow_KL v: V1.18 serial: <superuser required>
    UEFI: Insyde v: 1.18 date: 10/08/2021
  ID-1: BAT0 charge: 21.1 Wh (59.4%) condition: 35.5/50.8 Wh (69.9%)
    volts: 15.1 min: 15.3 model: SMP-SDI3320 AC14B7K type: Li-ion
    serial: <filter> status: discharging
  Info: model: Intel Core i5-8250U bits: 64 type: MT MCP arch: Coffee Lake
    gen: core 8 level: v3 note: check built: 2017 process: Intel 14nm family: 6
    model-id: 0x8E (142) stepping: 0xA (10) microcode: 0xF4
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 418 high: 548 min/max: 400/3400 scaling:
    driver: intel_pstate governor: powersave cores: 1: 400 2: 400 3: 400 4: 400
    5: 400 6: 400 7: 548 8: 400 bogomips: 28808
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling mitigation: Microcode
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: conditional,
    RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel UHD Graphics 620 vendor: Acer Incorporated ALI driver: i915
    v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
    active: eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:5917
    class-ID: 0300
  Device-2: Chicony HD WebCam driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-7:3 chip-ID: 04f2:b5c5
    class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa dri: iris gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93") monitors: <missing: xrandr>
  Monitor-1: eDP-1 model: ChiMei InnoLux 0x14d4 built: 2016 res: 1920x1080
    dpi: 158 gamma: 1.2 size: 309x173mm (12.17x6.81") diag: 354mm (13.9")
    ratio: 16:9 modes: 1920x1080
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 1 drv: swrast surfaceless: drv: iris x11: drv: iris
    inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.1.9-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics 620 (KBL GT2)
    device-ID: 8086:5917 memory: 7.47 GiB unified: yes
  API: Vulkan v: 1.3.264 layers: N/A device: 0 type: integrated-gpu
    name: Intel UHD Graphics 620 (KBL GT2) driver: mesa intel
    v: 23.1.9-manjaro1.1 device-ID: 8086:5917 surfaces: xcb,xlib
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI
    driver: snd_soc_skl v: kernel alternate: snd_hda_intel,snd_soc_avs
    bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0401
  API: ALSA v: k6.5.5-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.81 status: off with: pipewire-media-session
    status: active tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl
  Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 8086:095a class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB
    rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-5:2 chip-ID: 8087:0a2a
    class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
    v: 3.0 port: 3060 bus-ID: 00:17.0 chip-ID: 8086:282a rev: N/A class-ID: 0104
  Local Storage: total: 238.47 GiB used: 9.76 GiB (4.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: SK Hynix model: HFS256G39TND-N210A
    size: 238.47 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 1P10 scheme: GPT
  ID-1: / raw-size: 238.17 GiB size: 233.37 GiB (97.99%) used: 9.76 GiB (4.2%)
    fs: ext4 dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-fd1713f4-5ab5-4591-9cd5-5c03fe21d3e0
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 448 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
  System Temperatures: cpu: 46.0 C pch: 40.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Processes: 222 Uptime: 5m wakeups: 11362 Memory: total: 8 GiB
  available: 7.64 GiB used: 2.28 GiB (29.8%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: pm: pacman pkgs: 1146 libs: 338 tools: pamac pm: flatpak pkgs: 0
  Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.30

When you search the web for 9d71-ACRSYS-ACRPRDCT-2-tplg.bin then you find the solution. Switch to legacy snd_hda_intel, since the firmware is not there.

Seems there is also an entry in the ArchWiki for your Laptop or a similar one: Acer Swift 5 - ArchWiki

1 Like

Switch to legacy snd_hda_intel, since the firmware is not there.

So searching for that term, led me to an endeavor OS forum. There, a command was suggested which solved my speaker issue.

sudo sh -c ‘echo “options snd-intel-dspcfg dsp_driver=1” >> /etc/modprobe.d/inteldsp.conf’

Unfortunately that didn’t resolve the microphone issue. I came across an arch forum and the discussion there went over my head.

Do you have any clues what I can do to get the microphone working (as it did under Ubuntu)

Ah thanks for that. I just replied to the other person that I used the command (which is similar to yours) to get speakers working

sudo sh -c ‘echo “options snd-intel-dspcfg dsp_driver=1” >> /etc/modprobe.d/inteldsp.conf’

But unfortunately that doesn’t resolve the microphone issue. Do you have suggestions about that? IT was working under Ubuntu so it should be possible to get it up and running

I found this bugzilla thing, and it marks the issue as being resolved. But I’m looking through the comments (especailly towards the end) and am having difficulty making sense of it.

am I even looking at the right place?

On the arch wiki it says to enable internal mciophone, to add this boot parameter

snd_rn_pci_acp3x.dmic_acpi_check to enable internal microphones

So I went to /etc/default/grub

edited the line: GRUB_CMDLINE_LINUX=“snd_rn_pci_acp3x.dmic_acpi_check”

Unfortunatley that didn’t enable microphone? Did I do something wrong or does that command not work for?

You need to set the correct model, so:

options snd-hda-intel model=generic

See: HD-Audio Codec-Specific Models — The Linux Kernel documentation
which has a predefined patchset or patch it manually with hdajackretask. Vendors like to make modification to their hardware :wink:

1 Like

Just to clarify, combining what you wrote with some other forum, I added that line to /etc/modprobe.d/hdamodel.conf

so: sudo tee /etc/modprobe.d/hdamodel.conf <<< ‘options snd-hda-intel model=generic’

Unfortunately microphone still isn’t working :frowning:

Edit: Adding that file also killed the sound. So I had to delete the file so that there was only inteldsp.conf in the folder.

So sound is working again…still nothing on microphone.

You and I know that this line is an example right? I added link with more models. Unfortunately, I can’t tell you which model fits your laptop.

If you don’t know where this tool hdajackretask is, then search for it:

pamac search --files /usr/bin/hdajackretask

and install the packages.

I personally would go for manual patching :man_shrugging:

So sorry, like I said this is all way over my head

In the link you provided, I can’t see my specific laptop. However there is an acer device and it suggests using aspire-headset-mic. Which prompted me to try swift-headset-mic (with no success)

Regarding hdajackretask, I know its program but nothing is launching from the temrinal, nor can I even find the package to install

Search retruns: No package owns /usr/bin/hdajackretask

Edit: Or is there a way to compare Kubuntu’s setting and just insert that here? I can reinstall Kubuntu and look through its settings, if I knew where to look

I understand, but I cannot do it for you :man_shrugging:

    ~  pamac search --files /usr/bin/hdajackretask                                                            ✔ 
/usr/bin/hdajackretask is owned by alsa-tools

I guess not. Most likely it is patched on kernel level at compilation. Ubuntu uses highly customized kernels, while Manjaro uses upstream kernels directly plus a handful patches.

Can you make sense of this message by a guy who works on the kernel?

This seems to be the fix I need, but I don’t know how to get it working

Note that the fixup of SF314-54/55 (ALC256_FIXUP_ACER_HEADSET_MIC)

Taken from here Linux-Kernel Archive: [PATCH 5.10 061/135] ALSA: hda/realtek: Fix headset mic for Acer SWIFT SF314-56 (ALC256)

If you don’t mention or link back to previous things, responses from other users are very likely to repeat things you have already tried

This issue may have been resolved for Ubuntu users in a bug report to Launchpad and maintainers may have overlooked referring patch upstream to ALSA developers (again)

snd_rn_pci_acp3x.dmic_acpi_check is for AMD Audio Co-Processor dmic support - not likely to work for an Intel Skylake system

install alsa-tools to get hdajackretask tool

pamac install alsa-tools

is there a way to compare Kubuntu’s setting

If available, this will give a full diagnostic of ALSA --upload

If script is not available, use this to download and run it

wget -O && bash

Sure… linux 6.5 has this quirk:

Actually it is included since linux 5.14-rc5:

Ok, alsa-tools installed and I can open up hdajackretask

I select teh Realtek ALC256 codec

I’m not sure what to do now. If I click on “show unconnected pins” it shows two pins grayed out as microphone and internal microphone. Pin ID 0x19 and 0x1a

I clicked on “Override” and then hit “Install boot override.”

Unfortunately after restarting, that didn’t fix the microphone issue

HOw should I be using hdajackretask

Kernel patch for headset mic has been discussed before and does not support internal dmic
and there is no model name option to load ALC256_FIXUP_ACER_HEADSET_MIC

So I got hdajackretask up and running. I’m confused as to what to do now.

I can select the codec Realtek ALC256. Then if I go to “show unconnected pins” I see a bunch fo grayed out stuff.

There were two options grayed out under microphone and internal microphone. Pin ID 0x19 and 0x1a.

I hit override for both of them and then hit “Install boot override.” Unfortunately restarting didn’t resolve the issue.

How should I be doing the manul repatching?

I suggest you try using 1 troubleshooting strategy at a time instead of multiple hacks

I would not consider using hdajackretask to modify an audio codec without first getting detailed information from working and non-working systems to know what needs reconfiguring

That makes sense, I realize that I had an earlier boot option still enabled (I doubt it was doing something but I just forgot to delete it after I found out ti didn’ work).

What would you suggest I do?

Agree… it should patch it automatically:

@helpcomputer Forget about hdajackretask. Patch should be there.

Please share:

pactl list sources short

I would assume, that A) there was a change on the newest kernel or B) the mic is simply muted. Assuming that snd_hda_intel is used and not snd_soc_skl (which doesn’t work).

Check alsamixer if there is mic.