No audio on new install. But am getting audio in Ubuntu

run alsa-info script on Kubuntu and Manjaro and used meld (or similar) to compare the working and non-working data

So two quick things

  1. SOrry, how do I install it? I can’t find the package and running that command from the terminal doesn’t do anything

  2. I should do this on a clean install of Manjaro right? I’m sure I’ve made many changes that I’m not even aware of. My gut says to do a clean isntall and only run the command
    sudo tee /etc/modprobe.d/inteldsp.conf <<< ‘options snd-intel-dspcfg dsp_driver=1’

And then run alsa-info

Is that correct, or should I just go ahead and run it anyway


Here is the output for pactl list sources short

0 alsa_output.pci-0000_00_1f.3.analog-stereo.monitor module-alsa-card.c s16le 2ch 44100Hz SUSPENDED
1 alsa_input.pci-0000_00_1f.3.analog-stereo module-alsa-card.c s16le 2ch 44100Hz SUSPENDED

Alsamixer for Microphone:

I’m not sure how to do this exactly. But running alsamixer and then hitting f4 (for capture devices), it shows something at 100 (volume I’ve set mcirophone at)

And there Mr. @helpcomputer is the input (the internal mic, must be a jack)… fully working, but just suspended.

yes - remove any modprobe options

on Manjaro run alsa-info with sudo so it includes data from dmesg

sudo --upload

and post link to the data uploaded to alsa-project

data will include information about ALSA mixer settings. screenshots of alsamixer settings are not necessary or useful

Sigh, I’m sorry for being such a pain, but my mind is frazzled and nothing seems to be working.

I installed Kubuntu, then installed alsa-tools

However I can’t get to run as it says “command not found”

Ubuntu’s page says I need to have alsa-utils (which I do have installed), but then why is the script not available?

I ran the script you suggested but it gives the following error: bash: No such file or directory

Edit: success, so ignore this post. But got alsa-info to run

Can we unsuspend it? Is it something that hdatestrejack can do? I don’t see a pin number there.

Just as an FYI, while I try to figure out how to run, alsamixer under kubuntu looks radically different. In Manjaro I can only see the leftmost bar

I’ll edit this post once I reinstall Manjaro to show what alsamixer looks like in Manjaro


Here is what alsamixer shows in Manjaro


Here is the link for Kubuntu’s alsa-info, I believe it is correct. I’m going to go and reinstall Manjaro now and reedit this post in an hour or so with its alsa-info

Here is alsa-info on a fresh install of Manjaro

And here is alsa-info on Manjaro after forcing it to use snd_intel driver

Well what about switching the sound card?


Pulseaudio is the sound server, so a pseudo sound card.

So I tried that and the screen looks very similar to Kubuntu now. Unfortunately I don’t know what microphone it has selected but its not the laptops built in ones :frowning:

So you don’t have a Mic on Ubuntu as well? When I look at the laptop pictures on the net then there is headset symbol and the specification says that there is digital mic integrated.

So Capture 0 and Capture 1 are integrated and jack. The audio jack needs probably such type (since headset symbol):


This has 3 stripes:

  • Stereo output (2 channels)
  • Mono input (1 channel)

4 stripes means Stereo input.

Set everything to max and check in pavucontrol whether the level moves.

Sorry for being a dunce…and probably answering your question incorrectly. But thats the image I see in alsa in Kubuntu (the image I linked above)

In that scenario, the internal microphone works, I haven’t tried plugging in a physical external mic (I don’t have one available).

I was wondering if you had a chance to look through the alsa uploads.

I just learned of Meld and its a cool program. There are a ton of differences, but the simplest and obvious one I can see is that they’re using different drivers. Would it be a simple fix as switching drivers?

Ubuntu uses snd_soc_skl_hda_dspm, but Manjaro snd_soc_skl ? Anyhow… sof works on Ubuntu.

We need to know which firmware Ubuntu loads instead. -2 means here: not there. So not found in /lib/firmware/. That is the whole problem with sof.

I can reinstall Kubuntu. How do I get firmware information to the level of detail that will answer your question?

Like you did already in the quoted part?! There is displayed which firmware has been loaded. Look at lines with “Direct firmware load for” and there you see the file. Search it then in /lib/firmware on Ubuntu/Manjaro.

alsa-info data shows ALSA mixer controls in text format: Mixer controls for card PCH
so screenshots are not needed
To check audio capture controls for onboard audio in alsamixer

alsamixer --card=PCH --view=capture

(or use --view=all to check playback and capture controls)

No data from dmesg included in any of the data sets to show what microphone inputs are detected

Kubuntu Information for capture devices and mixer controls is only showing 1 dmic, but it should be detecting 2 on this system

The low-level configuration shown in !!HDA-Intel Codec information is mostly the same when comparing Kubuntu and partially-working Manjaro. So there is nothing that I can see that can be adjusted at hardware level using hdajackretask

the main difference in the Kubuntu data is that there are more drivers listed in All Loaded Modules for a Skylake audio system



there are some SOF drivers absent too, but Skylake systems require Intel SST driver support that sofproject has declined to support on Linux.

Some devices have support from soundwire drivers provided by alsa-project
soundwire drivers are usually provided by either alsa-ucm-conf, the main kernel package
(linux-65 for this system) or the kernel-headers package - so check if linux65-headers is installed

The soundwire drivers missing from Manjaro data should be provided by linux65


Ah, I see. Prepare to rip your hair out, I had no idea what that command did. I just saw a few threads where people asked for that information, so I thought to provide it before hand.

I’ll reinstall Kubuntu tomorrow morning and see whta the output for that command is.

Do I still use the egrep term as listed above? For example, if I run that command now, AFTER running the command below, I no longer see a line that says "Direct firmware load

I’ll give it a shot and see what Kubuntu says