New user : 2 graphics card, Bumblebee or not?

Hello everyone,

First, I’m a new user with Manjaro distrubution and before I used to Ubuntu. Now, I discover manjaro an I like it.

So, secondly I have a pc with 2 graphics card (Nvidia and Intel) and on Windows 7, I can switch the card. I’ve seen that Bumblebee systems.

How to use a Bumblebee mode with my computer : Asus UL80vt
(Nvidia G210M and Intel Mobile 4 Series)?
Or if so complicated, how can I switch or choose my video driver?

I afraid of black screen after one changement.

If, there are an another topic, could you link me here ?

Thank you every one :slight_smile:!

Screenshot_2020-12-09_09-41-25|655x500, 100%

give it a try with Nivida 340xx, let me know, how it going with that

Ok, Thanks.

But, how I do if my screen don’t work after that ?

Unfortunately, I think the 340xx series driver is being deprecated.

You can read these threads here:

Also, if you look in the branch compare and search for nvidia-340, you can see that it’s already removed from unstable and testing branches. So I assume it will be removed from the stable branch very soon.

So I would recommend bumblebee driver instead of the proprietary driver.

Hello @rahinsoo,

I have old ASUS laptop with iGPU and dGPU. I use only dGPU - nVidia 325M with 340xx driver for linux and I have no problems so far. I used this tutorial from old manjaro forum and never looked back.

If you try the tutorial first read step five see if you have one of the login managers described there so that you don’t run in some errors.

Another thing like emke posted if you are planning to use newer kernel than 5.4 LTS its better to use nouveau driver.

Currently I’m on kernel 5.40.80-2 with display: x11 server: X.Org 1.20.10, linux54-nvidia-340xx 340.108-80 driver. And so far so good :slight_smile:

Hey, i have the same problem. ASUS laptop Geforce GT540M (Fermi).
CleanInstalled Manjaro with open drivers, installed 390xx Nvidia via the MSM, Switched to Kernel 5.40, followed the tutorial for KDE, but now after reboot theres only a Black Screen with the Cursor visable. Is there any other way to get the dGpu going, i tried Bumblebee drivers with optimus-manager and qt but again there would only be black screen.


Did you uninstall the open drivers ??? This is important! :slight_smile:
First install the nvidia-390xx-utils, linux54-nvidia-390xx, mhwd-nvidia-390xx(MHWD module-ids for nvidia) and for good measure lib32-nvidia-390xx-utils. I have all of these but the 340xx version.

Did you read the Step 5 where it says


e.g. KDE edition

Create a new file,


and make it executable.

Do you have SDDM as login manager ?? Maybe you missed this step or something, double check every step. If the login manager is not configured properly, you could have black screen simply because the manager is not using the dGPU and doesn’t know how to display the login screen.

For other results and explanations try googling how to use dedicated graphics card instead of integrated manjaro linux it will show couple results from this forum and other stuff.

Nvidia 340 support is dropped in next Manjaro release. Older driver will be 390 then.

Fresh Install, deinstalled open drivers, sudo pacman -s all 390xx drivers followed the Tutorial, setup executable for my SDDM, reboot and after the Login screen i see for 2 seconds my desktop after that it turns black, still can open programs with hotkeys.
Alt Space to open searchbar, opened Resolution and i can see that in Display Configuration are 2 devices listed, LaptopScreen (Primary) and VGA-0.
Dont know if thats important.

sorry for spamming, but i checked the Hardware Configuration and it still showed (after the reboot)none of the drivers installed, so clicked on install video-nvidia-390xx wich seems to have worked.
inxi -G returns

Device-1: Intel… driver: i915 v: kernel
Device-2: NVIDIA GF108M [GeForce GT 540M] driver: nvidia v: 390.132

Display: x11 server: X org 1.20.10 driver modesetting,nvidia
resolution: 960x540~60hz
OpenGL: renderer: GeForce GT 540M/PCIe/SSE2 v: 4.6.0 NVIDIA 390.132

how would i change my resolution back to 1600x900?
xrandr shows 960x540 as the highest.

Solved :

Section “Monitor”
Identifier “LVDS-1-1”
Modeline “1600x900_60.00” 109.00 1280 1368 1496 1712 1024 1027 1034 1063 -hsync +vsync
Option “PreferredMode” “1600x900_60.00”

Section “Screen”
Identifier “Screen0”
Monitor “LVDS-1-1”
DefaultDepth 24
SubSection “Display”
Modes “1600x900_60.00”

Section “Device”
Identifier “Device0”
Driver “nvidia”

and restarting Plasma Style

Hello @GokuSan

Thank you for your Feedback.
I use Kernel 5.8.18-1, and I think that my nVidia is more old.
How to know the driver used, if it is intel or Nvidia?

Are you test the bumblebee driver ?

Hello @rahinsoo,

If you open terminal and write inxi -Gxx you will get information about your graphics in general.
So if it says something like

 Display: x11 server: X.Org 1.20.10 
 driver: modesetting,nvidia 
 resolution: 1600x900~60Hz 
 OpenGL: renderer: GeForce GT 325M/PCIe/SSE2 v: 3.3.0 NVIDIA 340.108 
 direct render: Yes 

Than you are using your nVidia.
Of course your nVidia will be something along the lines renderer: GeForce GT 210M/....

Or you can do this to check glxinfo | grep -i vendor
And the output should be

server glx vendor string: NVIDIA Corporation
client glx vendor string: NVIDIA Corporation
OpenGL vendor string: NVIDIA Corporation

No. I like to use nVidia.

I write this on my terminal and I have :

  Device-1: Intel Mobile 4 Series Integrated Graphics vendor: ASUSTeK 
  driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:2a42 
  Device-2: NVIDIA GT218M [GeForce G210M] vendor: ASUSTeK driver: nouveau 
  v: kernel bus ID: 01:00.0 chip ID: 10de:0a74 
  Device-3: Chicony Asus Integrated 0.3M UVC Webcam type: USB 
  driver: uvcvideo bus ID: 1-5:3 chip ID: 04f2:b036 
  Display: x11 server: X.Org 1.20.10 driver: intel,nouveau 
  unloaded: modesetting alternate: fbdev,nv,vesa resolution: 1366x768~60Hz 
  s-dpi: 96 
  OpenGL: renderer: Mesa DRI Mobile Intel GM45 Express (CTG) 
  v: 2.1 Mesa 20.2.3 direct render: Yes 


server glx vendor string: SGI
client glx vendor string: Mesa Project and SGI
    Vendor: Intel Open Source Technology Center (0x8086)
OpenGL vendor string: Intel Open Source Technology Center

Do you think that the driver 340 to nVidia is ok or not for me ?
Because I see the name “nouveau” for the driver :open_mouth:


340 drivers will be removed soon from Manjaro, see this thread Dropping all legacy and older Nvidia drivers ?!? if it is your only option… good luck. Check Nvidia official support for older hardware Support timeframes for Unix legacy GPU releases | NVIDIA too… at some point nothing devs can really do if Nvidia themselves do not support the hardware anymore.

Can you post the output of mhwd --list from a terminal?

Ok, I go to see that.

For mhwd -- list :

                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-340xx-bumblebee            2020.10.04               false            PCI
    video-nvidia-340xx            2020.10.04               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> 0000:00:02.0 (0300:8086:2a42) Display controller Intel Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-340xx-bumblebee            2020.10.04               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

Seems like your hardware will be unsupported really soon. You could install Nvidia drivers (Bumblebee or not) but in a coming update probably early next year on end of the month if I guess, they will get removed. I don’t have the ETA but it seems very soon, it is already dropped in Testing branch since a month.

Hello @rahinsoo

Yes, it’s the correct driver for your GPU, but you will have to downgrade the kernel to 5.4 LTS. Its is the last version that supports 340.xx nVidia driver, I believe.

So its up to you, weather you wanna switch to 340.xx or stay with nouveau.

As far as

I don’t think it should be a problem, because if you stay on k 5.40 LTS its oki.
According to Arch wiki Last supported Xorg version is 1.20.
So I think it will be until 5.40 EOL.

Yeah you can also compile your own Kernel and add your own patches, but do you think the user here will be able to maintain a custom Manjaro installation on his own, when he’s not even sure how to install video drivers from the official easy GUI?
Yes It is possible, by downgradin xorg (which then will create other issues regarding packages depending on xorg), having older LTS kernel, to install foreign DKMS packages from AUR or other methods, sure, but officially, Manjaro drop support for Nvidia 340.


I wouldn’t go that far.

No, I don’t think so, but if you want to drive a McLaren, you at least have to know how to drive and have the will to improve :smiley:
And there is the community to help you with that.

Xorg 1.20.10 is still working nice with 340.xx(official repo) , so far there is no problem on my end. I will cross that bridge when I come to it :slight_smile: So unless something really bad happens, like some security hole in the driver, am stying on it.