New Raspberry Pi Kernels & Related Packages

I pushed a couple of days ago when the forum was down to the unstable branch:

linux-rpi4 5.4.58-1
linux-rpi4-headers 5.4.58-2
rpi-eeprom 2020.07.31-1

Today I was notified by the RPi people that my issue was resolved I opened regarding non working usb ports with the pi4 8G boards with the 5.8-rc kernel. When I first opened the issue the kernel was still in the rc status but now it has been upgraded to 5.8.1. Because of this the linux-rpi4-mainline 5.7.9-1 kernel/headers packages has now been upgraded in the unstable branch (when the mirrors sync):

linux-rpi4-mainline 5.8.1-1
linux-rpi4-mainline-headers-5.8.1-1

In all of the new kernel packages here I have added “usbhid.mousepoll=8” to /boot/cmdline.txt to help with the mouse refresh rate which will help with some mouses that do not play well trying to use it’s default with the linux default config. The number 8 can be increased (or decreased) to your liking with the mouse movement.

3 Likes

Now I’m trying latest kernel and headers on my RPI4 4GB. All work perfect!

Thanks for the hard work!

1 Like

Today the RPi folks bumped their kernel versions up to match kernel.org’s version updates over last weekend so I pushed the new kernel packages to the unstable branch. (when the mirrors sync)

linux-rpi4 5.4.59-1
linux-rpi4-headers 5.4.59-1
linux-rpi4-mainline 5.8.2-1
linux-rpi4-mainline-headers 5.8.2-1

There has been some intermittent instancies where it takes multiple boot tries to get a sdcard to boot with the latest software reported here:

Raspberry Pi 4 does not boot after apt full-upgrade

So the RPi folks have pushed a fix and I have built and pushed the needed packages to the unstable branch (when the mirrors sync):

raspberrypi-bootloader 20200819-1
raspberrypi-bootloader-x 20200819-1

EDIT:

I also push an upgrade for this package today to the unstable branch:

raspberrypi-userland-aarch64-git r806.f73fca0-1

1 Like

I pushed 2 new upgraded pi kernels and their headers to the unstable branch (when the mirrors sync).

linux-rpi4 5.4.61-1
linux-rpi4-headers 5.4.61-1
linux-rpi4-mainline 5.8.5-1
linux-rpi4-mainline-headers 5.8.5-1

With the linux-rpi4 kernel the RPi people added AppArmor support. If you want it enabled at boot you will have to add lsm=“apparmor” to the line in the /boot/cmdline.txt file.

configs: Include AppArmor support
 
AppArmor security has been a long-requested feature. 
This commit adds the config settings necessary to allow 
it to be enabled at boot time using the kernel command 
line (cmdline.txt) - just include: 
 
lsm="apparmor" 
 
The commit also includes a few settings to give better 
control over processes or containers. 

Signed-off-by: Jean-Christophe Berthon <jcberthon@users.noreply.github.com>
Signed-off-by: Phil Elwell <phil@raspberrypi.com>

Additional:

I also just pushed the 2 upgraded raspberrypi-bootloader packages to the unstable branch.

raspberrypi-bootloader 20200902-1
raspberrypi-bootloader-x 20200902-1

This is great work. :slight_smile:

So glad you are keeping this up to date, as our Raspberry Pi images are still the most downloaded images, by far.

Even though the Pinebook Pro onesare slowly getting there. :wink:

1 Like

The RPi people add the 5.9.y tree to their github. I had a compile issue last night and opened an issue on their github and they had it fixed by the time I woke up. They also told me that they are aware of a few other issues and I will post an updated package when they are fixed. The issues they are aware of I believe does not affect most of us. Maybe we can find some other issues to make this kernel stable when it gets out of the -rc stage:

Be aware that 5.9 has a lot of conflicts with downstream (as partial commits are appearing upstream).
It’s in a state where you should be able to boot with working display, network and usb.
But kms, codecs, camera, isp, vcsm are still being worked on and may not be functional currently.

UPDATED 09-10-2020:

From looking at the commits this week it looks like they were working on their concerns that had above. They also upgraded to to kernel version to 5.9.0-rc4 to be inline with the current kernel.org version.

See post #11 for latest link

I guess you’re talking about 5.8.7 and not 5.9.7.
I wonder how to test the 5.9-rc3 and go back to 5.8.5 if it’s not ok. Could you please specify the procedure ?

Fat fingers here. It was supposed to be 5.9.y for their branch name (I corrected my post).

I tested the 5.9.0-rc3 here and it booted ok and every test I do here on a new kernel had no issues. I do not have a camera and by default we do not use kms because it is still listed as unstable.

If you want to switch back to 5.8.5-1install linux-rpi4-mainline in the unstable branch. Another option is install the linux-rpi4-mainline kernel/header packages from your pacman cache if you have not cleared them out. (/var/cache/pacman/pkg/)

Just pushed the 2 raspberrypi-bootloader packages with some bug fixes they commited to unstable when the mirrors sync.

raspberrypi-bootloader 20200903-1
raspberrypi-bootloader-x 20200903-1

UPDATED 09-07-2020

Just pushed the latest rpi-eeprom 2020.09.03-1 package to the unstable branch when the mirrors sync.

rpi-eeprom Releases

[ray@pi4 ~]$ sudo rpi-eeprom-update
BCM2711 detected
VL805 firmware in bootloader EEPROM
BOOTLOADER: up-to-date
CURRENT: Thu Sep  3 12:11:43 PM UTC 2020 (1599135103)
 LATEST: Thu Sep  3 12:11:43 PM UTC 2020 (1599135103)
 FW DIR: /lib/firmware/raspberrypi/bootloader/beta
VL805: up-to-date
CURRENT: 000138a1
 LATEST: 000138a1

UPDATED 09-10-2020:

I updated the link in post #7 for the new linux-rpi4-rc kernel 5.9.0-rc4 which includes bug fixes and a kernel version bump.

Here is the latest linux-git 5.9.0-rc4-2 kernel packages. It looks like they have might fixed their concerns as mentioned above. They also found and fixed a bad patch for the wifi that upstream had accepted that would cause the wifi to stop working. There is also a kernel bump to match upstream and they added apparmor.

md5sum:
4ac80d91e26a9fa3eb5b568c49314 linux-rpi4-rc-590-rc4-2.tar

linux-rpi4-rc 5.9.0-rc4-2 kernel/headers

ADDITIONAL:

The RPi folks upgraded the other 2 kernels to match the current upstream versions today. They both now have apparmor also. Also the 2 raspberrypi-bootloader packages has been upgraded. I have built and pushed all these packages to the unstable branch when the mirrors sync.

linux-rpi4 5.4.64-1
linux-rpi4-headers 5.4.64-1
linux-rpi4-mainline 5.8.8-1
linux-rpi4-mainline-headers 5.8.8-1
raspberrypi-bootloader 20200911-1
raspberrypi-bootloader-x 20200911-1
1 Like

Thanks for the new kernels.
Do you plan to add the apparmor feature to the OS ?

I do not make those decisions and really do not know what it would involve.

By the way I have messed around and come up with a config for the upstream kernel (not rpi kernel) if you are up to really venture out and test it. I am waiting for Strit to test it and give some feed back at the moment. It is the latest 5.9.0-rc5 upstream commited yesterday.

Here is this week’s new versions of the RPi tree kernels and bootloader packages I pushed to the unstable branch when the mirrors sync:

linux-rpi4 5.4.65-1
linux-rpi4-headers 5.4.65-1
linux-rpi4-mainline 5.8.9-1
linux-rpi4-mainline-headers 5.8.9-1
raspberrypi-bootloader 20200916-1
raspberrypi-bootloader-x 20200916-1

And here is a link to the latest RPi tree linux-rpi4-rc 5.9-rc5-1 kernel packages:

https://drive.google.com/file/d/1Aw4s7A9DMychBNxI-RG6mE1YKwtCATAL/view?usp=sharing

Here is this week’s new versions of the RPi tree kernels and bootloader packages I pushed to the unstable branch when the mirrors sync:

linux-rpi4 5.4.68-1
linux-rpi4-headers 5.4.68-1
linux-rpi4-mainline 5.8.12-1
linux-rpi4-mainline-headers 5.8.12-1
raspberrypi-bootloader 20200928-1
raspberrypi-bootloader-x 20200928-1

And here is a link to the latest RPi tree linux-rpi4-rc 5.9-rc7-1 kernel packages:

md5sum:
0518a94db71735cd26d580f78f8eb3bf linux-rpi4-rc_5-9-rc7.tar

https://drive.google.com/file/d/1p3JzFVP1a3nBYHm9-AHKkCaYUc4xQK4Y/view?usp=sharing

All of the above kernels now have rspamd enabled if you are running a mail server.

The linux-rpi4-mainline 5.8.12-1 and linux-rpi4-rc 5.9-rc7-1 kernels now have modules enabled for running anbox. It crashes on a lot of programs I installed but from talking to @Strit today he said that it is still in it’s infancy but is being pushed by the pinephone community with it’s developtment so hopefully soon things will start improving at a faster rate in the development:

Switch to unstable, updated, everything O.K. Thanx

1 Like

This weeks new upgraded kernels and bootloader packages has been pushed to the unstable branch.

linux-rpi4 5.4.69-1
linux-rpi4-headers 5.4.69-1
linux-rpi4-mainline 5.8.13-1
linux-rpi4-mainline-headers 5.8.13-1
raspberrypi-bootloader 20201001-1
raspberrypi-bootloader-x 20201001-1

Well this will be short lived. They upgraded all branches today again to be current with upstream. I will update the kernel names here when I get all kernel packages built and pushed.

UPDATED:

This is the new linux-rpi4-rc-5.9.rc8-2 re-compiled to use the SCHEDUTIL govenor that has been maximized for aarch64 starting in kernel 5.9

md5sum:
375d448be759fde161de365f9a765499 linux-rpi4-rc-5.9.rc8-2.tar

linux-rpi4-rc-5.9.rc8-2

1 Like

The 5.8.14 is out, the same day… Unfortunately for you.:wink:

Actually the 5.8.13 came out 5 days ago but I missed it, so I did it yesterday. But yea a lot of compiling kernels. Actually yesterday I compiled 7 kernels. I maintain a 32bit repo for all pi’s for a satellite form with added and patched modules for dvb/atsc/dvbt that are not in the mainline kernel also. So now 10 kernel compiles in 2 days. But it is what it is… lol

Here are the new kernel and bootloader packages that I pushed to the unstable branch that the RPi folks upgraded to today:

linux-rpi4 5.4.70-1
linux-rpi4-headers 5.4.70-1
linux-rpi4-mainline 5.8.14-1
linux-rpi4-mainline-headers 5.8.14-1
raspberrypi-bootloader 20201007-1
raspberrypi-bootloader-x 20201007-1

What is new is they enabled but it is not active to linux-rpi4 5.4.70 “Memory CGroup swap controller” for docker. It is supposed to stop this:

$ docker info
WARNING: No swap limit support

To make it active add this to /boot/cmdline.txt"

swapaccount=1

ADDED:

I forgot to mention I enabled anbox support in the linux-rpi4 5.4.70-1 above. I had not done it because the arch wiki said for kernels <= 5.7. I saw today in it’s .config where it looked like it could be enabled so I tried it and it seems to work at least as good as the other kernels, It is too flakey for me in it’s current stage of development.

I also forgot to post a link to the latest linux-rpi4-rc kernel:

1 Like