New laptop doesnt boot with newer kernels than 5.15 (Manjaro KDE)

Dear community,

I have very recent hardware and Manjaro runs good with the kernel 5.15. But if i’m not mistaken the cpu drivers for my computer (the new 12th gen intel) should be better with newer kernels (as recommended by someone on this forum). So i installed the new kernels through the practical menu, but I get two black screens, enabling a lot of things (in order), but at the end it gets stuck. The same happens with the fall back option in the GRUB menu. I can wait a long time and in the end it just turns itself off. Only 5.15 seems to work.

Normally it seems to be ‘checking some blocks’ but then i just get the manjaro login screen.

Its the new dell inspiron 16 plus (7620), with the RTX3060.

Could somebody please help me with this?


Some information to consider can be seen here Dell Inspiron 16 Plus (7620) - ArchWiki
Will also answer to your other topic about power consumption question …

But that link was already shared, so for more workarounds outside that information, you will have to speculate and test things by yourself.

Not quite sure that that means to be honest. All menus are practical… Either way, hopefully you either refer to the MHWD ui or via terminal.
sudo mhwd-kernel -i linux60

Since the stable branch is a bit behind with the kernel version, firmware and nvidia modules, maybe you might want to move to unstable and see if those patches mentioned in the wiki are helping.

If the Linux515 is making your hardware work, then stick to it till there is more information about that specific model you have.

I’m sorry, that adjective was kind of pointless. I refer to the menu in ‘settings’ where you can easily install new kernals. (but as i said, it won´t boot).

Ill stick with the version that i have. Doing a kernal patch (for the speakers as explained in that link is way above my level (i am an average user) and i’m still trying to work out the part about switching from RAID to ASCI (if that can be done safely, for the power consumption), but all the instruction vids that i can find refer to windows.

If there is nothing to be done about it not booting with a newer kernel, than ill just accept it. For my daily needs of course 5.15 good enough, i just thought that if better was available then why not give it a try.


If you installed Manjaro and you have no Windows, that means you already switched to AHCI from BIOS Settings, otherwise you could have not been able to do the install.

For the Nvidia part, reason why is booting to black screen or not booting with newer kernels you could try to add ibt=off to the grub kernel boot parameter. See this Lenovo Legion 5i 2021 boots to black screen after installing NVIDIA

Edit /etc/default/grub and add after quiet the ibt=off and save the file, then run from terminal:
sudo update-grub
Reboot the system in newer kernel. If it fails, boot back to the 5.15 one and try to get some logs.

1 Like

Thank you so much for your help! I tried the ibt=off trick and it worked like a charm. After that i switched to AHCI (it was actually on RAID) and now the new kernel works and my battery life on standby seems to have normalized (like one percent per 2 hrs). (i also got help on my other post.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.