New Dell tower with tons of juice has constantly lagging screens

The Problem

I have recently gotten a new development computer through work and have installed Manjaro on it, but from since day 1 the screen output has been super laggy. Honestly, I’m not even sure if it is the display, or the operations themselves, I can’t really tell and to be honest don’t know how to tell. The lag increases and decreases with CPU usage, even minimal it seems, like just switching between programs. When I’m in my IDE, it’s just lagging the whole time.

I have the computer plugged two Samsung 27" monitors. The thing is, I had this same monitor set up with a wayyyyy weaker laptop that I was using until it died which also had Manjaro on it, so I know the computer should be able to handle this lol.

Basically, I’m not sure how to proceed. I have checked dmesg and journalctl but I will admit that I am very ignorant on how to use these tools effectively; I always just scroll until I find suspicious things when I’ve had problems before, but nothing seems really off when I scrolled since getting this computer.

I would like to stress that this lagging does begin when I start having increased CPU work, or so it seems. I’m just suspect that it’s a CPU problem given that I have 20 cores and haven’t been doing much more than normal/heavy IDE stuff.

What I’ve Tried

Not much, I honestly out of my area of expertise here. I checked that the nvidia drivers were indeed installed, and tried switching from open to proprietary. I’ve tried to downgrade my kernel, but it seems that Manjaro has removed this ability from the settings menu, for idk what reason.

inxi -b Output

  Host: beast-within Kernel: 6.6.32-1-MANJARO arch: x86_64 bits: 64
  Desktop: KDE Plasma v: 6.0.5 Distro: Manjaro Linux
  Type: Desktop System: Dell product: XPS 8960 v: N/A
    serial: <superuser required>
  Mobo: Dell model: 09M47G v: A00 serial: <superuser required> UEFI: Dell
    v: 2.3.0 date: 12/11/2023
  Info: 20-core (8-mt/12-st) Intel Core i7-14700K [MST AMCP] speed (MHz):
    avg: 926 min/max: 800/5500:5600:4300
  Device-1: Intel Raptor Lake-S GT1 [UHD Graphics 770] driver: i915 v: kernel
  Device-2: NVIDIA AD106 [GeForce RTX 4060 Ti] driver: nvidia v: 550.90.07
  Device-3: Logitech C922 Pro Stream Webcam driver: snd-usb-audio,uvcvideo
    type: USB
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0 driver: X:
    loaded: nvidia gpu: i915,nvidia s-res: 3840x1330
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.90.07
    renderer: NVIDIA GeForce RTX 4060 Ti/PCIe/SSE2
  Device-1: Intel Alder Lake-S PCH CNVi WiFi driver: iwlwifi
  Device-2: Realtek Killer E3000 2.5GbE driver: r8169
  Local Storage: total: 2.75 TiB used: 263.14 GiB (9.3%)
  Memory: total: 64 GiB available: 62.46 GiB used: 15.59 GiB (25.0%)
  Processes: 491 Uptime: 4h 16m Shell: fish inxi: 3.3.35

mwhd Output

s127 fsh ❯ mhwd
> 0000:01:00.0 (0300:10de:2803) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2024.05.03               false            PCI
           video-linux            2024.05.06                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> 0000:00:02.0 (0380:8086:a780) Display controller Intel Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2024.05.06                true            PCI

nvidia-smi Output

| NVIDIA-SMI 550.90.07              Driver Version: 550.90.07      CUDA Version: 12.4     |
| GPU  Name                 Persistence-M | Bus-Id          Disp.A | Volatile Uncorr. ECC |
| Fan  Temp   Perf          Pwr:Usage/Cap |           Memory-Usage | GPU-Util  Compute M. |
|                                         |                        |               MIG M. |
|   0  NVIDIA GeForce RTX 4060 Ti     Off |   00000000:01:00.0  On |                  N/A |
|  0%   46C    P5             10W /  160W |     843MiB /   8188MiB |     35%      Default |
|                                         |                        |                  N/A |

sudo mhwd-kernel --install linux69 will install the latest. somewhat older would be linux61

For graphical menu there is manjaro-settings.

Strange… not for my Manjaro KDE PC and Laptop, Manjaro settings Manager is right there.

This is a Laptop what you are using, right?
1.Switching between X11 and Wayland maybe change something.
2.I have no experience with dual GPU’s, maybe it helps to disable your Intel iGPU, if you don’t care about the additional power draw.
3.There are additional commands to improve Wayland Performance under KDE, always check “Known Issues and Solution” if you encounter a problem:

1 Like

With a desktop system capable of dual GPU you choose in the firmware which one to use.

I don’t know Dell workstation - but a Lenovo counterpart e.g. my old P330 (i9-9900) will automagically disable the iGPU in favor of the external GPU.

Since you are using Nvidia using Plasma may not be the right thing as Plasma (just as Gnome) is focusing on Wayland and Nvidia/Wayland is not a fantastic combo.

I recommend trying out the reference made by @Kobold above.

There is a few treads on Nvidia - please inform yourself - not all may be applicate for you.

If you could pursuade your workplace to switch the GPU for an Radeon 7900XTX that would make your day.

The only complete desktop system not yet embracing Wayland is Xfce - thus it may provide a much better experience than Plasma.

Rule of thumb

  • Nvidia GPU work great with Windows
  • AMD Radeon GPU work fantastic with Linux and Windows

Writing this from a Manjaro Plasma workstation (Lenovo P620 with Radon 7900XTX)

Thank you very much, switching to Wayland solved all my issues!

Actually I spoke too soon. The lagging is gone now but now it’s almost like my input is getting buffered as I type it? It’s super bizarre behaviour and I don’t understand it at all.

Did you used the above commands after switching to Wayland?

Only shows us available things. Not what you have installed.

mhwd -li

But you have a an iGPU+dGPU. Does this mean the nvidia is on all the time?
Did you do something to achieve this?

(what configuration steps have you performed?)