Network Manager not working

Hi I’m new to manjaro.

This is probably a very noob problem too but, I just finished installing Manjaro and nothing is appearing on my network manager. I tried manually adding a wifi network, but I probably botched it horribly since I wasn’t sure what to fill in and what to leave blank other than the SSID and password. Fortunately I dual booted windows and the wifi seems to be working fine here. (Forgot to mention I run KDE Plasma).

inxi -Nazy
rfkill list
1 Like

are you dual booting
if yes try to go into manjaro and reboot to manjaro
i am also suffering from the same issue
once you shut down from windows and go to manjaro
i didnt get wifi working
but when i reboot again from manjaro to manjaro
wifi will work

another possible issue might be
incompatable drivers
try to go into hardware configuration application
or use “mhwd” command to identify the devices
check if your wifi device is listed and driver is installed

additional solution
if nothing works
get a linux compatable network adapter on store
it will be cheap
you might be good to go then

i am also suffering from the same issue
once you shut down from windows and go to manjaro
i didnt get wifi working
but when i reboot again from manjaro to manjaro
wifi will work

do you suggest any fix
thank you

How do you know its the same issue?
You should probably start your own thread unless you know you are using the same adapter, etc.

And both of you should maybe take a look at this:

2 Likes

Hi! Thanks for the information, this is my first time here so I’ll keep it in mind. I ran the two commands you suggested as well and this is what I got;

Network:
  Device-1: Intel Wi-Fi 6 AX200 driver: N/A

0: hci0: Bluetooth
              Soft blocked: no
              Hard blocked: no

Sorry if it comes out poorly, I had to manually type it out but I hope this helps. (Sorry for the late response)

So this tells us you dont have a driver.
Hm. Lets see about that device…
OK, according to intel its supported. But its pretty new.
First make sure you have linux-firmware installed, and also try to get the latest kernel you can.
Also … try manually loading the driver:

sudo modprobe iwlwifi

If its still not recognized … there is this in the AUR, which will get you an even newer iwlwifi:
https://aur.archlinux.org/packages/linux-firmware-iwlwifi-git/

Of course, aside from all of that … follow sherlocks advice above … and try rebooting from manjaro>manjaro … see if it makes a difference.

Hi

I am facing the same problem. Here is the output of mhwd

> 0000:04:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
         network-r8168            2016.04.20                true            PCI


> 0000:00:02.0 (0300:8086:0f31) Display controller Intel Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

and how to install this one on the system?

https://aur.archlinux.org/packages/linux-firmware-iwlwifi-git/

https://wiki.manjaro.org/index.php?title=Arch_User_Repository

1 Like

Thanks for the help, attempts were unsuccessful though. I’m going to buy a wifi adapter in hopefully less than a week, is there anything I should know before buying one?

Ive generally been happy with intel and atheros.
Avoid realtek.
Anything you think looks nice - search it up and see how others experience the device, or if it has a page on linux compatibility, etc.

Speaking of … I have started digging on your device … and it looks like users report it working with earlier kernels (some 5.4 release and earlier) … so instead of going forward … maybe try going back and checking 5.4.

But then I found this…

Which seems to indicate my initial suspicion of its ‘supported’ but not yet not really …

…the plot thickens…

Please return also this for maybe some clues

sudo dmesg | grep iwl
[          2.742363] iwlwifi  0000:02:00.0: enabling device (0000 -> 0002)
[          3.149938] iwlwifi:  probe of 0000:02:00.0 failed with error -110

Had to manually type it out so sorry for sloppiness.

Also I’m pretty sure he has the same laptop I do, probably the same issue though. Not too sure how I can go about installing an earlier kernel though.

Hm. That error is also consistent with problems while dual-booting windoze and having ‘fast startup’ enabled.

Are you dual-booting? Have you tried to make sure you fully shutdown from windoze ?

1 Like

If this is the correct address I may have found something…

Run this:

sudo printf 'install iwlwifi echo 1 > /sys/bus/pci/devices/0000\:02\:00.0/reset ; \ \n        /sbin/modprobe --ignore-install iwlwifi' > /etc/modprobe.d/iwlwifi.conf
Explanation:

We want to have file /etc/modprobe.d/iwlwifi.conf with contents:

install iwlwifi echo 1 > /sys/bus/pci/devices/0000\:02\:00.0/reset ; \
        /sbin/modprobe --ignore-install iwlwifi

I do dual boot, whats a good way of making sure windows fully shuts down/disabling fast startup?

Also I run that in a single command right?

Yes the one-liner as written is a single command you can copy/paste.

For windoze … I cant remember off the top of my head (DDG it) … but I believe it can be done with a CMD command, applied settings (again like turning off ‘fast start’ which is actually just windoze not ever shutting down all they way :roll_eyes:), and even some trick about holding Shift while selecting restart or something similar.

I had same problem with r8168 not connecting. Tried many of the suggestions on the forum - different kernels, blacklisting, etc. and none of them worked. Live usb always worked and connected so I checked if there were any settings on the live usb that were different than mine.

I right clicked the Network Manager icon and selected Edit Connections. I noticed that Link negotiation was set to Ignore on the live usb and Automatic on my install. Changed the entry to Ignore and now I connect instantly and the connection never drops. Tested on 5.4, 5.6 and 5.7 kernels and all connect now. Hope this helps.

Didn’t seem to work, thanks though. Is it possible to download an earlier linux kernel from my windows os, put it on a usb, and open it in manjaro?

It is … just download the pkg tar from a mirror from here:
https://repo.manjaro.org/

(but there are some issues like maybe needing extra modules to go with it, etc … it would be preferable to use an ethernet chord or tether…)