Network drivers MHWDCONFIG is invalid and empty


After all, the Laptop doesnt have Ethernet port( but maybe trought usb…?)

run lspci and lsusb

How do gonna show you the Output though…?

To get temporary connection - tether your android phone using the USB connection cable for your phone.

I install (/or update) linux hearders that you told in your page, what should i do after it, build them as you told or as the first page you gave me told (to pamac build rtl8821cu-dkms-git)?

I ran the second choice ( to build pamac build rtl…) first, it works

I ran pamac build rtl8821cu-dkms-git. Now it hangs, and 2 previous lines it said was:

==> dkms install --no-depmod rtl8821cu/5.4.11458c2226a -k 5.15.53-1-MANJARO
Deprecated feature: REMAKE_INITRD

The screen doesnt update and hangs on same screen in 30 minutes now, doesn’t show mouse move, and cant click anything. Should I do anything…?

yes cancel it … if this driver wont install there are others:
pamac build rtl8821cu-morrownr-dkms-git
after installing reboot and test

How long lasts a dkms install?

what do you mean lasts? you mean how long it takes to install? that depends but not long since its few mega big

It hangs now too…mouse invisible and…

then you have some other issues, this shouldnt happened … so cancel it …
and i read that you installed it on usb before you install it on hard drive, but you will have to install headers and the dkms drivers also there…

I dont know if that’s the point on every dkms install, and it is first time i use something like this…

Do I turn off and on the pc then…?

is it completely frozen? try ctrl+alt+del

Doesn’t do much either…

so its frozen, so you have to force it, after you booted provide logs:
journalctl -b-1 -p4 --no-pager

With proprietary or open source drivers?