Nemo not working and no shortcuts on desktop after update

2 days ago I updated a laptop (Lenovo thinkpad x220t) that I did not use for some time and forgot about it. Last time it was updated was on the 15/09/2021 so nearly 5 month ago! I know it’s recommended to update Manjaro a lot more frequently, so I was a bit nervous when I run the update.
During the update, there was only one error referring to the ‘Keyring’ so I thought I may have to re-enter password and credentials.
After restart, there where no shortcuts on the desktop, but the bottom panel was present, so I clicked on ‘Show desktop’ = no effect
I opened the desktop preference in system settings ‘open/close’ the desktop icons = no effect
I then tried to open ‘nemo’ from the panel = no effect
I tried from the ‘menu’ same result = no effect
I then then tried all the application and they all seem to work.
I created a test document in ‘libreoffice’ and save it to ‘Documents’ with no problem, so 'nemo seems to be working?
I then start ‘Document Viewer (Xreader)’ from the ‘menu’ File - Open… brings up what looks like ‘nemo’ and under documents I can see all the files, EXCEPT the one I just saved from within ‘Libreoffice’? I restarted and tried this a few more times, can not see/access the documents from within ‘Xreader’ (also tried ‘Evince’ with same results). Strangely, if I run ‘Libreoffice’ File - Open I can see all the documents - the new ones I created and the old ones??
I already re-installed ‘nemo’ = made no difference
Any suggestions - thanks

run this and try again and reboot:

sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu  

also check if you are not running some eol kernel

1 Like

I run the command - at the end it said:
‘Starting full system upgrade’
‘There is nothing to do’
No change in my system behavior after a restart!
I run the same kernel as I did prior to updating = 5.10.89-1

Thanks for your help

Do you have any nemo plugins installed? There was an issue with either the Dropbox or mega plugin breaking nemo a few months ago but it should be fixed

The pdf plugin was recently the cause…

But we would know better if OP @chameau provided output of attempting to run nemo

Also … whats installed:

pacman -Qs nemo

That’s it -Qs nemo showed
Tools to work with PDF files from Nemo

local/nemo-python 5.0.0-13
Python3 binding for Nemo components

I followed the link to the other post and run the command
pamac build python-pypdf2
restart and now all seem to work fine

I run -Qs nemo again and the results were identical to the first time? so I don’t know if that was a bug or happened because there were 5 months since last update? and I don’t know about the ‘Keyring’ error I got during the update, but everything seem to work now - Thanks

You need to rebuild all of your AUR nemo plugin things, as well as any python dependent stuff you missed.

pamac build $(pacman -Qoq /usr/lib/python3.9)

And, if it is missed somehow:

pamac build nemo-pdf-tools

I’m not that technically savvy - I usually just use pacman to update Manjaro not the terminal, also you mention ‘AUR’ apps - I have ‘Enable AUR support’ turned off in pacman
so just before I proceed with your instructions, in usr/lib/ I do not have ‘python3.9’ but I have 'python2.7 and python3.10 - should I change your command to python3.10?
I searched for ‘nemo-pdf-tools’
I found: 'nemo-pdf-tools- in /tmp/pamac/dbs/local
the only instance of 'nemo-pdf-tools-1.2.9.oextras20.04.03-9-any.pkg.tar.zst is in /var/cache/pacman/pkg

No … that means its unecessary.
(It probably also means you want to investigate and/or remove that 2.7 directory)

You mean pamac.
But I guess that sorta clears this up then - you have it installed, but it only exists in the AUR.
You can follow my pamac build instruction above to featch and rebuild it from the AUR … or if you are unwilling to do that … you should probably remove it from your system. Though I guess you can ride it out until your system complains.