Nemo file manager not working after update

I recently updated my Manjaro system and user applications. After the update, I am not able to open my Nemo File Manager.
This is what is says when I tried to ran nemo through my terminal:

(nemo:12751): Gtk-WARNING **: 11:08:08.962: Theme parsing error: gtk.css:4070:23: Junk at end of value for color

** (nemo:12751): WARNING **: 11:08:09.010: Current gtk theme is not known to have nemo support (Dracula-alt-style) - checking...

(nemo:12751): Gtk-WARNING **: 11:08:09.014: Theme parsing error: gtk.css:4070:23: Junk at end of value for color

** (nemo:12751): WARNING **: 11:08:09.071: The theme appears to have no nemo support.  Adding some...
No module named 'PyPDF2'

I have no idea what could have gone wrong before the update everything was working fine even with the Dracula-alt-style that it is complaining about.
Thanks :slight_smile:

Are you fully up to date?
sudo pacman-mirrors -g && sudo pacman -Syyu

How did you install the theme? Is it up to date as well?

Yes the system is fully up to date, but I installed the theme manually by putting it in the .themes folder in the home directory

Then you may want to download it again (‘updating’).

If that doesnt fix it … you can complain to the theme dev … but otherwise you would need to use a different theme.

(of course this is all assuming nemo works with other themes … and is thus not a nemo problem)

I tried different themes as well, even the preinstalled matcha theme, the problem still persists.

** (nemo:18652): WARNING **: 12:15:01.724: Current gtk theme is not known to have nemo support (Matcha-dark-sea) - checking...
No module named 'PyPDF2'

It is not working with any theme

Do you have some pdf plugin installed?

pacman -Qqs nemo
1 Like

Yes, I do have some


Shall I remove this pdf-tools plugin?

edit :point_down:

pamac build python-pypdf2
1 Like

Thanks a lot :pray:, both of you @ishaan2479 and @cscs for helping me throughout this.

1 Like


I would probably prefer the AUR package python-pypdf2
And if it is required by your other AUR package (nemo-pdf-tools) then it should include python-pypdf2 as a dependency …

…and it looks like it does:

And I was going to ask if you had rebuilt your aur packages (you should if you havent) … but then I realized that aur package hasnt changed since august … so I am still confused as to why you dont have python-pypdf2 … unless maybe you do and they all need rebuilds? …

I did have python-pypdf2 installed even before I did pip install pyPDF2 and Nemo never complained about it before the last update I had.

This means you need to rebuild your third-party packages against current libs.
Likely many if you dont know anything about this … but at hand here is the python ones…
So probably something like this:

pamac build $(pacman -Qoq /usr/lib/python3.9)

And/Or manually rebuild ones you know you need … in this case python-pypdf2

pamac build python-pypdf2

Then you could remove your pip package (pip uninstall PyPDF2) … and see if everything works … I would guess it does.


I did run the command below, but it downgraded the python-pypdf2 package :thinking: and everything works fine.

Dont know where you got 0-3 …
As I noted above … the pdf-tools AUR package hasnt changed since August (nor its dependencies)
In this case the package hasnt changed in years and is obviously 0-2.

Though, serendipitous, the latest comments are related to this thread:

Yeah, I’m baffled too, no idea how did that happen.

I do. nemo-pdf-tools and python-pypdf2 were recently dropped from the Manjaro repos.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.