Need help with DRI_PRIME=1 for ATLauncher

Hi! So, I’ve been facing this problem since a long time… First everything ran smoothly, back when I used to run PopOS 18.04 i guess, then after PopOS updates, i couldnt launch anything using my GPU, using DRI_PRIME=1, as it would just make my pc stuck. So I shifted to Manjaro XFCE, and the same thing happens here… I get stuck when I use DRI_PRIME=1. When Im on Windows 11, nothing like this happens. I can run my games easily with GPU, so I know that my GPU isnt the problem. I hope someone helps me out


We need to start with something like system information.

inxi -Fazy

This will have links to guides on how to find info, how to format it while sharing, etc …

  Kernel: 6.5.5-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.5-x86_64
    root=UUID=0e38e0ae-63ae-4670-ad92-e49e67094801 rw quiet splash apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 vt: 7 dm: LightDM v: 1.32.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: HP product: HP Notebook v: Type1ProductConfigId
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: HP model: 81F0 v: 63.53 serial: <superuser required> UEFI: Insyde
    v: F.50 date: 11/20/2020
  ID-1: BAT1 charge: 32.1 Wh (100.0%) condition: 32.1/32.1 Wh (100.0%)
    volts: 16.7 min: 14.6 model: COMPAL PABAS0241231 type: Li-ion
    serial: <filter> status: full
  Info: model: Intel Core i3-5005U bits: 64 type: MT MCP arch: Broadwell
    gen: core 5 level: v3 note: check built: 2015-18 process: Intel 14nm
    family: 6 model-id: 0x3D (61) stepping: 4 microcode: 0x2F
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1896 min/max: 500/1900 scaling: driver: intel_cpufreq
    governor: schedutil cores: 1: 1896 2: 1896 3: 1896 4: 1896 bogomips: 15969
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel HD Graphics 5500 vendor: Hewlett-Packard driver: i915
    v: kernel arch: Gen-8 process: Intel 14nm built: 2014-15 ports: active: eDP-1
    empty: DP-1,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:1616 class-ID: 0300
  Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 M430 Radeon
    520 Mobile] vendor: Hewlett-Packard driver: radeon v: kernel
    alternate: amdgpu arch: GCN-1 code: Southern Islands process: TSMC 28nm
    built: 2011-20 pcie: gen: 2 speed: 5 GT/s lanes: 4 link-max: gen: 3
    speed: 8 GT/s lanes: 8 bus-ID: 0d:00.0 chip-ID: 1002:6660 class-ID: 0380
    temp: 46.0 C
  Device-3: Chicony HP TrueVision HD driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:5 chip-ID: 04f2:b56c
    class-ID: 0e02 serial: <filter>
  Display: x11 server: v: compositor: xfwm v: 4.18.0 driver:
    X: loaded: modesetting unloaded: radeon alternate: fbdev,vesa
    dri: iris,radeonsi gpu: i915 display-ID: :0.0
    note: <missing: xdpyinfo/xrandr>
  Monitor-1: eDP-1 model: AU Optronics 0x70ec built: 2015 res: 1366x768
    dpi: 101 gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5")
    ratio: 16:9 modes: 1366x768
  API: EGL v: 1.5 hw: drv: intel iris drv: amd radeonsi platforms: device: 0
    drv: iris device: 1 drv: radeonsi device: 2 drv: swrast surfaceless:
    drv: iris x11: drv: iris inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.1.9-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 5500 (BDW GT2)
    device-ID: 8086:1616 memory: 7.49 GiB unified: yes
  Device-1: Intel Broadwell-U Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c
    class-ID: 0403
  Device-2: Intel Wildcat Point-LP High Definition Audio
    vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:9ca0 class-ID: 0403
  API: ALSA v: k6.5.5-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.81 status: off tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl,pavucontrol
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 5000
    bus-ID: 07:00.0 chip-ID: 10ec:8136 class-ID: 0200
  IF: enp7s0 state: down mac: <filter>
  Device-2: Broadcom BCM43142 802.11b/g/n vendor: Hewlett-Packard driver: wl
    v: kernel modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 13:00.0
    chip-ID: 14e4:4365 class-ID: 0280
  IF: wlp19s0 state: up mac: <filter>
  Device-1: Broadcom BCM43142A0 Bluetooth 4.0 driver: btusb v: 0.8 type: USB
    rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-4:4 chip-ID: 0a5c:216d
    class-ID: fe01 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 476.94 GiB used: 15.7 GiB (3.3%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 model: SATA SSD 512GB size: 476.94 GiB
    block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD
    serial: <filter> fw-rev: 115 scheme: GPT
  ID-1: / raw-size: 388.67 GiB size: 381.5 GiB (98.16%) used: 15.67 GiB (4.1%)
    fs: ext4 dev: /dev/sda5 maj-min: 8:5
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 29.1 MiB (30.3%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  Alert: No swap data was found.
  System Temperatures: cpu: 63.0 C pch: 50.5 C mobo: N/A gpu: radeon
    temp: 46.0 C
  Fan Speeds (rpm): N/A
  Processes: 197 Uptime: 37m wakeups: 1 Memory: total: 8 GiB
  available: 7.67 GiB used: 2.65 GiB (34.5%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: pm: pacman pkgs: 1029 libs: 310 tools: pamac pm: flatpak pkgs: 0
  Shell: Bash v: 5.1.16 running-in: xfce4-terminal inxi: 3.3.30

Oh yeah, in your case please also show:

mhwd -l -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
            video-vesa            2017.03.12                true            PCI
   network-broadcom-wl            2018.10.07               false            PCI
     video-modesetting            2020.01.13                true            PCI

Warning: No installed USB configs!
> 0000:13:00.0 (0200:14e4:4365) Network controller Broadcom:
                  NAME               VERSION          FREEDRIVER           TYPE
   network-broadcom-wl            2018.10.07               false            PCI

> 0000:0d:00.0 (0380:1002:6660) Display controller ATI Technologies Inc:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

> 0000:00:02.0 (0300:8086:1616) Display controller Intel Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

Mk. a few things.

I cant make out the model here. But I would check for BIOS updates if I were you.

This should not be installed.

sudo mhwd -r pci video-vesa

(note and general instruction: dont install random things if you dont know what & why)

This is one of those cards thats on the cusp.
You can use the newer/better amdgpu if you follow
(or just install amdgpu-experimental)

I might check other kernels as well. Specifically older, as you have an older amd card. 6.1 is LTS.

video-vesa as not installed back then. i just installed it now to check
and i removed it now

also I have a hp 15-ay005tx laptop, if that helps somehow, it has Intel i3 5005U, and AMD Radeon R5 M430 GPU

can you tell me how i can do so ?
i understand very little from the wiki

The easiest method is to simply install the amdgpu-experimental package:

sudo pacman -Syu amdgpu-experimental

(this should set the options required … afterwards reboot and check inxi again)

you sure its ok for me to install the amdgpu experimental… mine is a GCN 1 card ig

The point is to flip some options to enable amdgpu for your card. Sea Island and Southern Island cards are technically capable, but you need to enable ‘experimental support’ for them to use the amdgpu driver. If it works, and it does 99% of the time, you want that rather than the quite old radeon driver.

This will also work better with prime.

Ok, while its installing, i would also like to tell you that when i had tried the mesa-utils, back when it had crashed, it showed proper outputs, like theres that rendering of a sphere ig, it had done it properly… but the game is the only thing it had crashed on

ok, it has installed , should i reboot or something ?

Yes, reboot, then we can look at inxi again to make sure its using the amdgpu driver now:

inxi -Gazy

Why is it taking forever to boot ?

I dont currently have my crystal ball hooked up to your network.
I cannot know. Did you have other updates? Is it performing fsck?

If for whatever reason it doesnt want to get to a graphical session you might try dropping to TTY, using runlevel3, or any of the other options here:

This had also happened the last time, I force shutdown and while in grub I chose advanced boot options and the first one without initram fs ig, that had worked

What happened?
What last time?

I am not sure I understand what this means.

If you do this … then maybe your system is trying to perform fsck (disk repair) and you keep interrupting it. And the cycle of a broken partition that needs fixing continues.
Maybe. Again, I dont know.

The last time my pc crashed with dri prime, I had force shutdown, and it has stuck on boot screen… so I force shutdown it again and the next time I was on GRUB, I chose the advanced boot options , and there the first option, the one without fallback initramfs

I did that now and it booted this time

Which would be … the normal boot option.
Were you using the fallback option previously?

Idk, I didn’t do anything, it had booted into the bootloop automatically

Well … maybe we will come back to that.
If you have a graphical system, and its not ‘fallback’ … then what does inxi look like now?