Need help regaining access to my other nvme ssd

Recently, my bios stopped reading one of my 2 NVMe SSD’s. It had Manjaro on it. I reset my bios, and now it’s reading that drive, but not the other one with windows11 on it. When booted into Manjaro, I can still see all the files and applications on the windows SSD from inside dolphin in Manjaro. How do I fix this issue? When I go to boot menu during startup it gives me both NVMe SSD’s as an option but when I click the one that now has the “UEFI” attached to it (that happened after running command below) it gives me a black screen and says input boot drive like it’s not seeing it there. The SSD I boot Manjaro on says Manjaro on it in boot menu. How do I get the windows SSD to boot again?

I ran this

sudo pacman -S os-prober sudo os-prober sudo grub-mkconfig -o /boot/grub/grub.cfg


and got this output

Generating grub configuration file …
Found theme: /usr/share/grub/themes/Manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.15-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-5.15-x86_64.img
Found initrd fallback image: /boot/initramfs-5.15-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Adding boot menu entry for UEFI Firmware Settings …
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.

this is my Inxi -F output

Host: raivyn Kernel: 5.15.49-1-MANJARO arch: x86_64 bits: 64
Desktop: KDE Plasma v: 5.24.5 Distro: Manjaro Linux
Type: Desktop System: Gigabyte product: X570 AORUS MASTER v: -CF
Mobo: Gigabyte model: X570 AORUS MASTER serial:
UEFI: American Megatrends LLC. v: F35e date: 10/13/2021
Info: 12-core model: AMD Ryzen 9 5900X bits: 64 type: MT MCP cache:
L2: 6 MiB
Speed (MHz): avg: 3039 min/max: 2200/4950 cores: 1: 3596 2: 2876 3: 2462
4: 3314 5: 2874 6: 2873 7: 2879 8: 3597 9: 2879 10: 2880 11: 2879 12: 2880
13: 3600 14: 2880 15: 2880 16: 3570 17: 3164 18: 2867 19: 2878 20: 3600
21: 2879 22: 2880 23: 2880 24: 2878
Device-1: NVIDIA GA106 [GeForce RTX 3060 Lite Hash Rate] driver: nvidia
v: 470.129.06
Device-2: Sunplus Innovation Depstech webcam MIC type: USB
driver: snd-usb-audio,uvcvideo
Display: x11 server: X. Org v: 21.1.3 with: Xwayland v: 22.1.2 driver: X:
loaded: nvidia gpu: nvidia resolution: 3840x2160~60Hz
OpenGL: renderer: NVIDIA GeForce RTX 3060/PCIe/SSE2
v: 4.6.0 NVIDIA 470.129.06
Device-1: NVIDIA driver: snd_hda_intel
Device-2: AMD Starship/Matisse HD Audio driver: snd_hda_intel
Device-3: Sunplus Innovation Depstech webcam MIC type: USB
driver: snd-usb-audio,uvcvideo
Sound Server-1: ALSA v: k5.15.49-1-MANJARO running: yes
Sound Server-2: PulseAudio v: 16.1 running: yes
Sound Server-3: PipeWire v: 0.3.52 running: yes
Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi
IF: wlp5s0 state: down mac: ea:98:ac:33:10:c9
Device-2: Intel I211 Gigabit Network driver: igb
IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: 18:c0:4d:04:dd:f6
Device-3: Realtek RTL8125 2.5GbE driver: r8169
IF: enp7s0 state: down mac: 18:c0:4d:04:dd:f7
Device-1: Intel AX200 Bluetooth type: USB driver: btusb
Report: rfkill ID: hci0 state: up address: see --recommends
Local Storage: total: 1.88 TiB used: 867.68 GiB (45.2%)
ID-1: /dev/nvme0n1 vendor: Sabrent model: Rocket 4.0 1TB size: 931.51 GiB
ID-2: /dev/nvme1n1 vendor: Sabrent model: Rocket 4.0 1TB size: 931.51 GiB
ID-3: /dev/sda type: USB vendor: SanDisk model: USB 3.2Gen1
size: 57.3 GiB
ID-1: / size: 915.53 GiB used: 206.09 GiB (22.5%) fs: ext4
dev: /dev/nvme0n1p2
ID-2: /boot/efi size: 299.4 MiB used: 312 KiB (0.1%) fs: vfat
dev: /dev/nvme0n1p1
Alert: No swap data was found.
System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 52 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Processes: 474 Uptime: 2d 7h 23m Memory: 31.27 GiB used: 4.21 GiB (13.5%)
Shell: Zsh inxi: 3.3.19

provide output from:
sudo parted -l
[ -d /sys/firmware/efi ] && echo UEFI || echo BIOS

1 Like
   ~  sudo parted -l  :heavy_check_mark:  21s 
[ -d /sys/firmware/efi ] && echo UEFI || echo BIOS
[sudo] password for raivyn:
Model: USB SanDisk 3.2Gen1 (scsi)
Disk /dev/sda: 61.5GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 4194kB 61.5GB 61.5GB primary ntfs
2 61.5GB 61.5GB 1049kB primary lba

Model: Sabrent Rocket 4.0 1TB (nvme)
Disk /dev/nvme0n1: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 2097kB 317MB 315MB fat32 boot, esp
2 317MB 1000GB 1000GB ext4 root

Model: Sabrent Rocket 4.0 1TB (nvme)
Disk /dev/nvme1n1: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 17.8MB 16.8MB Microsoft reserved partition msftres
2 17.8MB 1000GB 1000GB ntfs Basic data partition msftdata
3 1000GB 1000GB 685MB ntfs hidden, diag


edit your post… click this icon in the editor: </> and put the output there…
and you cant boot into your windows, do i understand that correctly?
if yes, you have to repair windows bootloader… search for guides on internet:
how to repair windows bootloader from usb

I tried recovery from USB already. I used woeusb to create the bootable. It didn’t even see the drives in the installation part of bootable. Recovery part didn’t work either

use ventoy to flash the windows iso… with ventoy you can select to boot it in uefi mode…

I used ventoy. It is still not finding anything on the windows SSD. I tried uploading pics of what it was showing me, but the forum wouldn’t let me. When I try to do system image recovery, it says that it can’t find a system image on the computer. System restore says, “to use system restore, you must specify which windows installation to restore.” And when I hit install instead of repair, it says no device drivers were found

i have no idea… i was telling you to try to repair windows boot loader from windows usb iso, and search for guides on internet on how to do it? did you tried that?

I thought useing the repair function on the windows iso was what you meant by repairing the bootloader, if thats not what you meant please explain it to me.

in the iso you select repair your computer/troubleshoot/advanced options/startup repair - if the startup repair doesnt work, in the advanced options you select command promt and use that to repair it - and for the third time, search for guides on internet how to do it

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.