Need help installing Fadein

Hi everybody

I work as a writer and I use fadein. Since my macbook is almost dead, I thought I should go back using linux. I bought a new computer and installed majaro kde plasma. I can find the fadein file in the package manager however I can not install the software.

I haven’t used linux in years and need fadein asap for my work. I am really thankful for any help.

Thanks, have a great day

In terminal, if you have pamac installed:

pamac build fadein

1 Like

I tried that:

[ ~]$ pamac build fadein
Cloning fadein build files…
Checking fadein dependencies…
Resolving dependencies…
Checking inter-conflicts…

To build (1):
fadein 4.0.4-1 AUR

Edit build files : [e]
Apply transaction ? [e/y/N] y

Building fadein…
==> Making package: fadein 4.0.4-1 (Mi 23 Jun 2021 13:29:01)
==> Checking runtime dependencies…
==> Checking buildtime dependencies…
==> Retrieving sources…
→ Found fadein-4.0.4.tar.gz
==> Validating source files with md5sums…
fadein-4.0.4.tar.gz … FAILED
==> ERROR: One or more files did not pass the validity check!
Error: Failed to build fadein

Go to the AUR page of the project : AUR (en) - fadein

Download snapshot from right side of the page under “Package Actions”

extract the snapshot

In terminal change to the directory where you extracted the snapshot

If you don’t mind not having it validity checked
In terminal run makepkg -cs or makepkg -csi --skipchecksums

If you run makepkg -cs it will create the install file .zst
If you run makepkg -csi it will ask for your password and install the package

1 Like


Looks like the validity check is failing because the package it is downloading is for version 4.0.7 but the md5sum is for 4.0.4.

Following the instructions by @jrichard326 should install the current version.

1 Like

Thats right. PKGBUILD version can be changed to 4.07. Not sure that matters as it looks like PKGBUILD instruction brings in 4.07 as you said.
MD5 for 4.07 appears to be: c0ceaca348c2313712f835a3944d9aad
which can be modified in the PKGBUILD

1 Like

Maintainer just fixed it and changed validity check from MD5 to SHA512

1 Like

I marked it as out-of-date, didn’t think it would be corrected that quickly.

1 Like

It worked.

Thanks so much for all your help!

You might also be interested in software called Scrivener.

Available from AUR as well

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.