Myricom Driver Not Present on Installation, but is on Live USB?

I’m interested in installing the driver for my 10G NIC which is present in the live USB version of Manjaro, but not on the installed version for reasons beyond my understanding.

Here is the situation:

Installed (Note the Myricom Driver (Device-5)):

Network:   Device-1: Intel I350 Gigabit Network driver: igb 
           IF: eno1 state: down mac: b8:ca:3a:64:a4:b8 
           Device-2: Intel I350 Gigabit Network driver: igb 
           IF: eno2 state: up speed: 1000 Mbps duplex: full mac: b8:ca:3a:64:a4:b9 
           Device-3: Intel I350 Gigabit Network driver: igb 
           IF: eno3 state: down mac: b8:ca:3a:64:a4:ba 
           Device-4: Intel I350 Gigabit Network driver: igb 
           IF: eno4 state: down mac: b8:ca:3a:64:a4:bb 
           Device-5: MYRICOM Myri-10G Dual-Protocol NIC driver: N/A

Live USB:

[manjaro manjaro]# inxi -n
Network:   Device-1: MYRICOM Myri-10G Dual-Protocol NIC driver: myri10ge 
           IF: enp6s0 state: down mac: 00:60:dd:45:7c:7c 
           Device-2: MYRICOM Myri-10G Dual-Protocol NIC driver: myri10ge

I tried searching AUR for the driver, but couldn’t find it.

Does anyone know the magic words to install this driver?

EDIT 1: I was able to enable the kernel driver for this (following this tutorial:, but the problem still remains.

That is a little strange - I think it could be a regression - mostly because the ISO kernel is often outdated when installed - and thus your first update will most likely include a kernel update - which if a regression exist … you get the idea.

Just a thought - as I don’t know the correct name but from your live usb it appears the module loaded is named myri10ge - so on your running system

# modprobe myri10ge

Maybe adding a file


# load myricom ge module

I added the file to the folder that you specified (which didn’t exist previously), but it still doesn’t load :slight_smile:

I also checked the version on the ISO and the server. They’re both 5.10.36-2, so I guess kernel issues are out of the way.

On a second thought

  1. I see a typo - should have been modules-load.d

If above doesn’t work

  1. You could try moving the file to modprobe.d instead of modules-load.d perhaps providing some options for the interface.

More reading


Just tried it :slight_smile:
Thanks for the follow up post!

How would I know if it works or not? System restart? I’m a bit new to using the module systems.

EDIT: Retried modprobe and got this:

As you have referenced the instructions how to get it working on CentOS - also systemd based - you can use that example to verify the interface :slight_smile:

# lsmod | grep myri

If the module is listed - it works.

Try moving the file back to modules-load.d - the syntax is correct for modules-load.d drop-in configs - maybe not for modprobe.d

I literally ran that command
Homer Simpson “doh”
slaps forehead

Module listed, but not sure if it’s working

The module is loaded allright.

You just need to configure the interface.

run below and look for your interface (from your live ISO the name is enp6s0 so you could grep for that)

ip link

Yikes, didn’t appear. Those 4 are from the integrated NIC, not the myricom :slight_smile:
Never mind, I ran that on the server, not the ISO.

Computer administration is so much fun :grin:

I think this is what we wanted right?

So now I have the interface name?

Please do not post screenshots of terminal output. Use copy+paste and proper post formatting (</> button).

That is exactly what you want

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.