My second screen isn't working

I have looked at a few posts, but have not found any of them to be helpful. I have a laptop with two video cards. And I also have one monitor that is connected via HDMI. However, in the display settings it shows. Physically, however, the monitor does nothing. Even if I turn on duplication of screens for example. So the monitor is black.
I have a second laptop where I also have Manjaro, where both screens work normally. And I also have a second drive on my current computer (the one where the screen doesn’t work) where I have Windows 10, where the screen also works normally. At the very beginning (after installation), it didn’t show me the monitor even in the display settings. But then I messed around with the drivers and installed 1.15 Kernel, Majnaro headers and cuda. And then the monitor started showing up in the settings, but it still didn’t work.

- xrandr                                                                                   ✔ 
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
eDP connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
   1920x1080     60.16*+
   1680x1050     60.16  
   1280x1024     60.16  
   1440x900      60.16  
   1280x800      60.16  
   1280x720      60.16  
   1024x768      60.16  
   800x600       60.16  
   640x480       60.16  
HDMI-1-0 connected (normal left inverted right x axis y axis)
   1920x1080     60.00 +  59.94  
   1280x1024     75.02    60.02  
   1280x720      59.94  
   1152x864      75.00  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   720x480       59.94    59.94  
   640x480       75.00    59.94
  Device-1: NVIDIA TU117M vendor: Lenovo driver: nvidia v: 495.46
    alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1f99
    class-ID: 0300
  Device-2: AMD Renoir vendor: Lenovo driver: amdgpu v: kernel
    bus-ID: 05:00.0 chip-ID: 1002:1636 class-ID: 0300
  Device-3: Chicony Integrated Camera type: USB driver: uvcvideo
    bus-ID: 1-3:3 chip-ID: 04f2:b6c2 class-ID: 0e02 serial: <filter>
  Display: x11 server: compositor: gnome-shell driver:
    loaded: amdgpu,ati,nvidia unloaded: modesetting,nouveau,radeon
    alternate: fbdev,nv,vesa resolution: <missing: xdpyinfo>
  OpenGL: renderer: AMD RENOIR (DRM 3.42.0 5.15.16-1-MANJARO LLVM 13.0.0)
    v: 4.6 Mesa 21.3.4 direct render: Yes

You may try another kernel like 5.10, 5.15 ???

Please provide Information:

let me know if this helps

xrandr --output HDMI-1-0 --mode 1920x1080 --rate 60 --right-of eDP

this should set the resolution and refresh rate of the display on the HDMI output and set it so that the screen is to the right for mouse navigation.
if it’s to the left, then you’ll want --left-of

another debugging step would be to check if any kernel modules are blacklisted.
It seems like you have a gaming laptop where the HDMI port is connected to the NVIDIA card but internal display is connected to AMD GPU

Could you please also post the output of

grep 'blacklist' /etc/moprobe.d/*
grep 'blacklist' /usr/lib/modprobe.d/*
1 Like
 ~ xrandr --output HDMI-1-0 --mode 1920x1080 --rate 60 --right-of eDP
xrandr: Configure crtc 4 failed
 ~ grep 'blacklist' /etc/moprobe.d/*
zsh: no matches found: /etc/moprobe.d/*
 ~ grep 'blacklist' /usr/lib/modprobe.d/*
/usr/lib/modprobe.d/nvidia-utils.conf:blacklist nouveau

humor me with a

sudo modprobe nvidia_drm

I think this is related to using the video-amd-nvidia-prime drivers.
you may have to switch entirely to the video-nvidia drivers if you want to get both internal and external display working

I have the exact same problem my laptop is a HP Pavilion that has hybrid GPU’s AMD and Nvidia, i’m using the latest proprietary drivers: video-hybrid-amd-nvidia-prime version: 510.47.0, i’ve tried different TV’s and HDMI cables to no avail, it shows up in settings and my laptop can see the External monitor but it just comes up saying no signal on every TV i tried, I will read the linked topic and try it out and will let you know how i get on

i uninstalled video-hybrid-amd-nvidia-prime then installed video-nvidia and rebooted, manjaro now loads up on my tv but my laptop screen is just black :-(, i went into display settings and the only device showing is my TV now, my laptop screen isn’t showing up in devices, take it there isn’t anyway to have the best of both worlds and have both my laptop screen and tv work together ?

Device-1: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] vendor: Hewlett-Packard
driver: nvidia v: 510.47.03 alternate: nouveau,nvidia_drm bus-ID: 01:00.0
chip-ID: 10de:2191 class-ID: 0300
Device-2: AMD Renoir vendor: Hewlett-Packard driver: amdgpu v: kernel
bus-ID: 05:00.0 chip-ID: 1002:1636 class-ID: 0300
Device-3: IMC Networks HP TrueVision HD Camera type: USB driver: uvcvideo
bus-ID: 5-3:2 chip-ID: 13d3:56c9 class-ID: 0e02 serial:
Display: x11 server: X.orgx compositor: kwin_x11 driver:
loaded: amdgpu,ati,nvidia unloaded: modesetting,nouveau
alternate: fbdev,nv,vesa resolution: <missing: xdpyinfo>
Message: Unable to show advanced data. Required tool glxinfo missing.

also got the same error on xrandr

~ xrandr --output HDMI-1-0 --mode 1920x1080 --rate 60 --right-of eDP
xrandr: Configure crtc 4 failed

i’ve reinstalled the hybrid drivers for now
@filipko_smileface how did you get on ?

looking into this a little bit more there has been other people with the same concerns. there were cases where people have installed optimus-manager & mesa-utils (dependency for optimus-manager) to fix there problems, optimus-manager wouldn’t run when requested (threw up an error)

~ optimus-manager --status
ERROR: a GPU setup was initiated but Xorg post-start hook did not run.
Log at /var/log/optimus-manager/switch/switch-20220206T182223.log
If your login manager is GDM, make sure to follow those instructions:
GitHub - Askannz/optimus-manager: A Linux program to handle GPU switching on Optimus laptops.
If your display manager is neither GDM, SDDM nor LightDM, or if you don’t use one, read the wiki:
FAQ, common issues, troubleshooting · Askannz/optimus-manager Wiki · GitHub
Cannot execute command because of previous errors.

quick research showed i had to run


first then

optimus-manager --status

which resulted in

optimus-manager --status
Optimus Manager (Client) version 1.4
Current GPU mode : integrated
GPU mode requested for next login : no change
GPU at startup : integrated
Temporary config path: no

i then carried out

optimus-manager --switch nvidia

which logs me out but when i log back in it doesn’t change over the driver :frowning: when you run --status it says it will change next log out and log in to nvidia but never does, same thing happens if you try switching it to hybrid

optimus-manager --switch hybrid

still stays on integrated when running the optimus-manager --status :frowning:
what i’ve also noticed is if i plug in my tv it doesn’t even recognize anymore in settings or xrandr
was quite hopeful this was going to work too lol

Guys We are cooking with gas :grin: :grin:
silly me should of read the documentation on optimus-manager :see_no_evil:
so i had to comment 2 lines in and when i logged out and back in everything worked as expected even under hybrid mode is now working for my external monitor which is strange but i’m not complaining because that was the mode that it originally wasn’t working under, anyways down below was the final step i had to do to get this to work

Manjaro ships with a default configuration for SDDM (the default login manager for KDE) which overrides some keys needed by optimus-manager. To use optimus-manager, you need to edit the file /etc/sddm.conf and simply put a # before the line starting with DisplayCommandand the one starting with DisplayStopCommand.

1 Like

@JoConnell Glad you got it sorted, :love_you_gesture:
@filipko_smileface does this work for you?

1 Like

I’ve tried optimus-manager with viewing the whole documentation on github and unfortunately optimus-manager gives me an error. And I’m really tired of solving this problem. However, I am changing the operating system. And I’m not in the mood for Manjaro anymore.

we are here to help mate would be sad to see you leave manjaro :frowning:, if you change your mind and want to try troubleshoot this concern further post up the errors optimus-manager throws you, if not we wish you the best of luck in your journey ahead and hope you get your issue resolved by changing operating system

hey JoConnell,

I followed your indications and it worked for me. However, after restarting my laptop it will go back to the integrated GPU.

How can I do this persistent?

optimus-manager --switch --persistent :stuck_out_tongue:

really, how could I make it choose nvidia after rebooting?




maybe make that command autostart? Depending on situation you might want to make it through systemd or only when the desktop environment starts.

Of course this is only a workaround and it should be handled natively. But hybrid graphics sometimes is still a bit tricky in Linux.

sorry been a while since i have logged into these forums. was a while ago i set this up but I’m sure i set up grub with a command so when it boots its booting hybrid, integrated or dedicated graphics… yeah just had a look at my grub.cfg and there is a line with optimus settings

udev.log_priority=3 optimus-manager.startup=nvidia

the above line sets it to run nvidia constantly for performance. Theres nothing under my normal grub selection for hybrid mode (normal) so must of been a configuration or setting somewhere else that i set up. unfortunately it was that long ago i can’t remember what i did :frowning: you may find guides or tutorials regarding optimus manager and on boot that’s maybe what i did :man_shrugging: sorry for the late reply and hope you get this working.