My hard drive is read only and i can't write on it

Hello
I used Windows before

I installed Linux today and I’m really happy, but I ran into a problem
I installed Linux on my SSD drive

Also I have access to my HDD but it can only be read, nothing can be written on it

How can I solve this ?

I don’t want to format my HDD , I need all of my files in it

Hello,

If you still have Windows installed on that HDD and is formatted as NTFS, then make sure you disable from Windows the Fast Boot and that Hibernation thing it has.

Then on Manjaro install the ntfs-3g package, then you can mount via File Manager that partition and do modifications on your files.

Thanks for your attention

No I don’t have windows yet

And my HDD is read only

Can anyone help me?

I can’t find my problem in this topics

@matixmercury

Ok, so newbie task. Give us at least this information:

  1. Open a terminal
  2. Type there lsblk --fs
  3. Copy and paste the output here in a code block.

Thanks

Ok, thank you my friend

NAME FSTYPE FSVER LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0
     squash 4.0                                                    0   100% /var/lib/snapd/snap/core/12834
loop1
     squash 4.0                                                    0   100% /var/lib/snapd/snap/code/94
loop2
     squash 4.0                                                    0   100% /var/lib/snapd/snap/core20/1405
loop3
     squash 4.0                                                    0   100% /var/lib/snapd/snap/bare/5
loop4
     squash 4.0                                                    0   100% /var/lib/snapd/snap/snap-store/558
loop5
     squash 4.0                                                    0   100% /var/lib/snapd/snap/gtk-common-themes/1519
loop6
     squash 4.0                                                    0   100% /var/lib/snapd/snap/gnome-3-38-2004/99
sda                                                                         
├─sda1
│    ext4   1.0         7079c441-78bc-4495-b321-09114f365e0c                
├─sda2
│    ntfs               EA603A0D6039E0CD                      186.2G    70% /run/media/matix/EA603A0D6039E0CD
├─sda3
│    ntfs         Local Disk
│                       F86493E76493A6C2                                    
└─sda4
     ext4   1.0         82b2a487-fea3-44fd-94f8-5b729b4db29f    784K     1% /run/media/matix/82b2a487-fea3-44fd-94f8-5b729b4db29f
sdb                                                                         
└─sdb2
     ext4   1.0         d5bde8dc-5533-4911-aeb7-317797990e39  196.3G     5% /
sr0                                           

ok, well done @matixmercury :wink:

So sdb2 is your linux installation on the SSD.

There is sda4 and sda2, which are mounted.

Now, could you say which Partition you mean, because one is NTFS and the other is EXT4 ?

Write permissions on NTFS needs to be set when mounting.
Write permissions on EXT4 needs to be set on the filesystem.

there is 2 ntfs
on of them has no name

and anothor one isn’t mounted

now I mounted that

NAME FSTYPE FSVER LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0
     squash 4.0                                                    0   100% /var/lib/snapd/snap/core/12834
loop1
     squash 4.0                                                    0   100% /var/lib/snapd/snap/code/94
loop2
     squash 4.0                                                    0   100% /var/lib/snapd/snap/core20/1405
loop3
     squash 4.0                                                    0   100% /var/lib/snapd/snap/bare/5
loop4
     squash 4.0                                                    0   100% /var/lib/snapd/snap/snap-store/558
loop5
     squash 4.0                                                    0   100% /var/lib/snapd/snap/gtk-common-themes/1519
loop6
     squash 4.0                                                    0   100% /var/lib/snapd/snap/gnome-3-38-2004/99
sda                                                                         
├─sda1
│    ext4   1.0         7079c441-78bc-4495-b321-09114f365e0c                
├─sda2
│    ntfs               EA603A0D6039E0CD                      186.2G    70% /run/media/matix/EA603A0D6039E0CD
├─sda3
│    ntfs         Local Disk
│                       F86493E76493A6C2                      163.3G    47% /run/media/matix/Local Disk
└─sda4
     ext4   1.0         82b2a487-fea3-44fd-94f8-5b729b4db29f    784K     1% /run/media/matix/82b2a487-fea3-44fd-94f8-5b729b4db29f
sdb                                                                         
└─sdb2
     ext4   1.0         d5bde8dc-5533-4911-aeb7-317797990e39  196.1G     5% /
sr0   

This is one of the most common issues on this forum.

If you need to mount the partition in read-write mode and are not able to or willing to boot into Windows and shut it down completely there is a third option. However, it is not included here because it completely deletes hiberfil.sys and will cause you to lose all unsaved information in the hibernated Windows programs. The following is a quotation from man ntfs-3g about the option that would be used to do this.

$ man ntfs-3g
 ...
       remove_hiberfile
              When  the  NTFS  volume  is hibernated, a read-
              write mount is denied and a read-only mount  is
              forced.  One needs either to resume Windows and
              shutdown it properly, or use this option  which
              will   remove  the  Windows  hibernation  file.
              Please note, this means that the saved  Windows
              session  will  be completely lost. Use this op‐
              tion under your own responsibility.
 ...

If you understand the above disclaimer - execute below commands in a terminal window.

Replace sdxy with your device names - from the output above devices using ntfs is /dev/sda2 and /dev/sda3

sudo mkdir /media/windows
sudo mount -t ntfs -o remove_hiberfile /dev/sdxy /media/windows
2 Likes

thank a lot
but this isn’t helpful for me
because ,I fully uninstalled my windows
and there is no windows file or /media file in my drives

Now give us this from the terminal:

Shows how ntfs partitions are mounted.

mount -t fuseblk

Shows how ext4 partitions are mounted.

mount -t ext4
1 Like

mount -t fuseblk

/dev/sda2 on /run/media/matix/EA603A0D6039E0CD type fuseblk (ro,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)
/dev/sda3 on /run/media/matix/Local Disk type fuseblk (ro,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)

mount -t ext4
/dev/sdb2 on / type ext4 (rw,noatime)
/dev/sda4 on /run/media/matix/82b2a487-fea3-44fd-94f8-5b729b4db29f type ext4 (rw,nosuid,nodev,relatime,errors=remount-ro,stripe=4,uhelper=udisks2)

ok both NTFS partitions are mounted in read-only mode. Could be because the filesystem is in a dirty state, a hibernation file is there or fastboot was not disabled on windows. Linux have just minimal tools to solve this, but nothing like CHKDSK from Windows. If no windows available, then try this:

  1. Unmount the partition.
sudo umount /run/media/matix/EA603A0D6039E0CD
  1. Then run:
sudo ntfsfix --clear-dirty /dev/sda2
  1. Mount it again:
sudo mount /dev/sda2 /run/media/matix/EA603A0D6039E0CD
  1. Check again:
mount -t fuseblk

Maybe ro switched to rw now.

2 Likes

Just adapt the command to your situation:

sudo mount -t ntfs -o remove_hiberfile /dev/sda2 /run/media/matix/EA603A0D6039E0CD
sudo mount -t ntfs -o remove_hiberfile /dev/sda3 /run/media/matix/Local\ Disk

woooooow :smile:
thank you my friend
now I have read and write access
you are great !

can you give me a code for anothor hard drive ? I can’t find the correct sda1 path

1 Like

Just a side note:

If you are going to full linux on this computer, then switch to a linux filesystem, since NTFS is not fully compatible with Linux, just what is necessary.

Look above:

Just retype the command and you see the path.

sure ! why not

I run this command
sudo umount /run/media/matix/F86493E76493A6C2
and give this error
umount: /run/media/matix/F86493E76493A6C2: no mount point specified.

:arrow_down:

I found this
/run/media/matix/Local Disk
and run this
sudo umount /run/media/matix/Local Disk
and error
umount: /run/media/matix/Local: no mount point specified.
umount: Disk: no mount point specified.