My 3d games no longer work

I am using a GeForce GTX 1050 in my desktop PC, with the linux61-nvidia driver. It updated yesterday to the 535 version of March. After the update, my 3d games no longer work. They are too slow, and CPU usage is nuts. I looks like a driver issue. Everything else works properly (but my wifi which is too slow too, but that might be another issue).
I’ve tried downgrading, but the downgrade utility does not work.
I’ve tried installing the lattest driver from nvidia, but it is a .run file that refuses to install.
I’ve tried reinstalling with the mhwd tool, nothing changes.
I’ve tried reading some topics in this forum, but I cannot find an answer that solves my problem.

Maybe start with at least something like

inxi -Fazy

For your drivers I would say also provide

mhwd -l -li
  Device-1: NVIDIA GP107 [GeForce GTX 1050] driver: nvidia v: 535.113.01
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.1 driver: X:
    loaded: nvidia gpu: nvidia resolution: 1440x900~60Hz
  API: EGL v: 1.5 drivers: nvidia platforms: gbm
  API: OpenGL v: 4.6.0 vendor: nvidia v: 535.113.01 renderer: NVIDIA
    GeForce GTX 1050/PCIe/SSE2
  API: Vulkan v: 1.3.264 drivers: nvidia surfaces: xcb,xlib
mhwd -li returns:
video-nvidia  2023.03.23  false  PCI

Most of the information is missing.

  Kernel: 6.1.55-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=e8bc9bdb-110c-481e-bd67-929983099554 rw quiet splash
    resume=UUID=77c2ae3b-1772-4b7d-86bd-92f4f00ac592 udev.log_priority=3
  Desktop: KDE Plasma v: 5.27.8 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASRock model: B75M-DGS serial: <superuser required>
    UEFI: American Megatrends v: P1.50 date: 03/14/2018
  Info: model: Intel Core i3-3220 bits: 64 type: MT MCP arch: Ivy Bridge
    gen: core 3 level: v2 built: 2012-15 process: Intel 22nm family: 6
    model-id: 0x3A (58) stepping: 9 microcode: 0x21
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 2025 high: 3300 min/max: 1600/3300 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1600 2: 1600 3: 3300
    4: 1600 bogomips: 26349
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GP107 [GeForce GTX 1050] vendor: Micro-Star MSI
    driver: nvidia v: 535.113.01 alternate: nouveau,nvidia_drm non-free: 535.xx+
    status: current (as of 2023-09) arch: Pascal code: GP10x process: TSMC 16nm
    built: 2016-21 pcie: gen: 2 speed: 5 GT/s lanes: 16 bus-ID: 01:00.0
    chip-ID: 10de:1c81 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.1
    compositor: kwin_x11 driver: X: loaded: nvidia gpu: nvidia display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1440x900 s-dpi: 89 s-size: 411x263mm (16.18x10.35")
    s-diag: 488mm (19.21")
  Monitor-1: HDMI-0 res: 1440x900 hz: 60 dpi: 90
    size: 408x255mm (16.06x10.04") diag: 481mm (18.94") modes: N/A
  API: EGL v: 1.5 hw: drv: nvidia platforms: gbm: drv: nvidia
  API: OpenGL v: 4.6.0 vendor: nvidia v: 535.113.01 glx-v: 1.4
    direct-render: yes renderer: NVIDIA GeForce GTX 1050/PCIe/SSE2
    memory: 1.95 GiB
  API: Vulkan v: 1.3.264 layers: 5 device: 0 type: discrete-gpu
    name: NVIDIA GeForce GTX 1050 driver: nvidia v: 535.113.01
    device-ID: 10de:1c81 surfaces: xcb,xlib
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: ASRock 7
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
    class-ID: 0403
  Device-2: NVIDIA GP107GL High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:0fb9 class-ID: 0403
  API: ALSA v: k6.1.55-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.80 status: off with: wireplumber status: active
    tools: pw-cli,wpctl
  Server-3: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASRock driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
  Device-2: Ralink MT7610U (Archer T2U 2.4G+5G WLAN Adapter driver: mt76x0u
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-1.6:3
    chip-ID: 148f:761a class-ID: 0000 serial: <filter>
  IF: wlp0s26u1u6 state: up mac: <filter>
  Local Storage: total: 558.92 GiB used: 110.21 GiB (19.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37480G
    size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 0000 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Corsair model: Force LS SSD
    size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 1.5 Gb/s
    tech: SSD serial: <filter> fw-rev: 02.8 scheme: GPT
  ID-1: / raw-size: 102.69 GiB size: 100.52 GiB (97.89%)
    used: 32.92 GiB (32.8%) fs: ext4 dev: /dev/sdb2 maj-min: 8:18
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sdb3 maj-min: 8:19
  System Temperatures: cpu: 46.0 C mobo: N/A gpu: nvidia temp: 34 C
  Fan Speeds (rpm): N/A gpu: nvidia fan: 40%
  Processes: 213 Uptime: 31m wakeups: 0 Memory: total: 16 GiB
  available: 15.57 GiB used: 3.55 GiB (22.8%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: 1264 pm: pacman pkgs: 1254 libs: 421 tools: pamac pm: flatpak
  pkgs: 10 Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.30

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2023.03.23               false            PCI

Warning: No installed USB configs!
> 0000:03:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2023.09.12                true            PCI

> 0000:01:00.0 (0300:10de:1c81) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2023.03.23               false            PCI
    video-nvidia-470xx            2023.03.23               false            PCI
    video-nvidia-390xx            2023.03.23               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

Sorry, you replied faster than I was able to post!

I see two legacy drivers, video-nvidia-390xx and video-nvidia-470xx that maybe don’t need to be there.

Ouch, the old BIOS is probably not doing you any favors.
(and yes, I checked, this is the latest version available, its even technically beta)

But still if it worked before …

I suppose we might as well make sure you are up to date:

sudo pacman -Syu

Of course, you could always downgrade to try and check if it works with that … but

How did you try to do this?
Manjaro has its own downgrade:

sudo pacman -Syu manjaro-downgrade
downgrade linux61-nvidia

(note: I would suggest not adding the package(s) to IgnorePkg, if only for now)

Dont do that.

Sorry to you then. :slight_smile:

Probably not … though I dont think they should be affecting anything.
inxi shows 535 in use.

:: Sincronizando las bases de datos de los paquetes...
 core está actualizado
 extra está actualizado
 community está actualizado
 multilib está actualizado
:: Iniciando actualización completa del sistema...
 ...el sistema ya está actualizado.

Downgrading from A.L.A. is disabled on the stable branch. To override this behavior, set DOWNGRADE_FROM_ALA to 1.
See  for more details.

cargando los paquetes...
advertencia: revertiendo el paquete linux61-nvidia a una versión anterior (535.113.01-2 => 535.104.05-8)
resolviendo dependencias...
advertencia: no se pudo resolver «nvidia-utils=535.104.05», una dependencia de «linux61-nvidia»
:: El siguiente paquete no se puede actualizar debido a dependencias que no se pudieron resolver:

:: ¿Quiere omitir el siguiente paquete para esta actualización? [s/N] 

Me pide resolver nvidia-utils primero…

DOWNGRADE_FROM_ALA=1 downgrade nvidia-utils
cargando los paquetes...
advertencia: revertiendo el paquete nvidia-utils a una versión anterior (535.113.01-2 => 535.104.05-1)
resolviendo dependencias...
buscando conflictos entre paquetes...
error: no se pudo preparar la operación (no se pudo satisfacer las dependencias)
:: instalando nvidia-utils (535.104.05-1) se rompe la dependencia con «nvidia-utils=535.113.01», necesaria para el paquete lib32-nvidia-utils
:: instalando nvidia-utils (535.104.05-1) se rompe la dependencia con «nvidia-utils=535.113.01», necesaria para el paquete linux61-nvidia

Dependen unos de otros.
They have linked dependencies.

I can’t stay awake. Got to get up for work in five hours. Will try again tomorrow. Thanks.

You can downgrade multiple at a time

DOWNGRADE_FROM_ALA=1 downgrade nvidia-utils lib32-nvidia-utils linux61-nvidia

It has downgraded.
I will test it tomorrow, I can’t stay awake.
Thank you.

Well, after reboot, my PC cannot load the screen for selecting the user.
I had to open a terminal in F2, update the system and reboot, then it loads again, but of course, 3D acceleration is still not working in my games.
I tried to downgrade the drivers with two different versions, no luck.

That makes it seem as if it is not the driver package update(s) at blame.
EDIT: oh I guess I misread that. If the desktop is not booting we do not know.
Sorry, but I dont really know what else I would check for 3D failing on nvidia.

Well … going back and reviewing … it seems you dont say it fails but

So just really poor performance.

Maybe there is something helpful here:

Let me explain.
I load a game. I see properly the first loading images, the developer, the studio. Then the game starts loading the menu page, and it flickers, more and more, CPU usage is at 100%, the game takes forever to move the mouse, or to acknowledge that I clicked a button.
But that’s just the game. If I Ctrl-Tab, the rest of the system is still working well. I can open the monitor application and kill the steam app, which solves the problem but I cannot play my games.

This didn’t happen before I updated the system, and only games that make use of the GPU are at fault.

I don’t understand why my desktop cannot load after downgrading the driver.

You seem to have both Wayland and X11 installed. Do you experience the same using each of those?

Wayland doesn’t even load. I have to initiate Plasma with X11.

I know that 3D acceleration is lost on older Nvidia cards (in X11), but I’m uncertain where the cut-off point is. Your GTX 1050 don’t seem old enough for that to be an issue. Although, I could be wrong.

These drivers will not peacefully coexist with the newly installed 535xx counterpart. You will need to uninstall those manually:

sudo mhwd -r pci video-nvidia-390xx
sudo mhwd -r pci video-nvidia-470xx

… and, reboot.

The package is not installed.
I don’t know what is going on. A search of nvidia packages show only these:


but trying to remove mhwd-nvidia-370xx says that it messes with mhwd-nvidia-db

The mhwd-nvidia-390xx and mhwd-nvidia-470xx are not the drivers, those are needed by mhwd, they only contain a file with a list of ids.

I don’t know how it’s listed in pamac, but in Octopi, it says:

MHWD module-ids for nvidia 390.157