Mv cannot move directory not empty

So iI got this cute little 2-1 laptop from the kids for Christmas. Its a Lenovo Flex 5-14IIL05 Laptop. So since i cant leave thiings alone i upgraded the nvme m2 to a 500GB. and well sinve it now had no OS anymore i had a reason to finally go back and try linux again. I played with Arch 7 years ago but didnt do much.

so i tried Arch again. lol and mint and ubuntu and mx and finally settleed on manjaro. all i tried had no sound and no touch screen. i figured out the sound but touch screen requires a kernel edit which in already done in the 5.11-rc1. so i compiled the kernel with makepkg -s and after an hour fished no errors. Next i run makepkg -i for install and i am getting a cannot move error directory not empty. Any ideas what i can try? Near the bottom is what im talking about

Uploading: Screenshot from 2021-01-01 16-12-03.png…

That’s not working out so well and screenshots are not helpful. They’re often hard to read (especially on mobile) and cannot be indexed by search.

Please post the output with Preformatted text </>.

Also see:

thank you for pointing that out for me. think i got this right now

    ==> Extracting sources...
  -> Extracting with bsdtar
==> Starting prepare()...
mv: cannot move '/home/mike/build/linux511/src/linux-139711f033f636cc78b6aaf7363252241b9698ef' to '/home/mike/build/linux511/src/linux-5.11/linux-139711f033f636cc78b6aaf7363252241b9698ef': Directory not empty
==> ERROR: A failure occurred in prepare().
~/build/linux511 >>>

Hightlight the text, then click the </> button. :wink:

Are you using our PKGBUILD or something else?

lol that took abit.
Yes i am using the one you linked.
the link for directions i am following can be found by googling


  Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=8bee227c-0205-4d18-993f-f0b0d05f2ca4 rw quiet splash apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: GNOME 3.38.2 tk: GTK 3.24.24 wm: gnome-shell dm: GDM 
  Distro: Manjaro Linux 
  Type: Convertible System: LENOVO product: 81X1 v: IdeaPad Flex 5 14IIL05 
  serial: <filter> Chassis: type: 31 v: IdeaPad Flex 5 14IIL05 
  serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40700 WIN serial: <filter> 
  UEFI: LENOVO v: ECCN30WW date: 09/07/2020 
  ID-1: BAT0 charge: 39.7 Wh condition: 53.7/52.6 Wh (102%) volts: 12.2/11.5 
  model: Sunwoda L19D3PD6 type: Li-poly serial: <filter> status: Discharging 
  cycles: 6 
  Info: Quad Core model: Intel Core i5-1035G1 bits: 64 type: MT MCP 
  arch: Ice Lake family: 6 model-id: 7E (126) stepping: 5 microcode: A0 
  L2 cache: 6 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 19048 
  Speed: 1215 MHz min/max: 400/3600 MHz Core speeds (MHz): 1: 1215 2: 1302 
  3: 1301 4: 1200 5: 1248 6: 747 7: 815 8: 1212 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel Iris Plus Graphics G1 vendor: Lenovo driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:8a56 
  Device-2: Acer Integrated Camera type: USB driver: uvcvideo bus ID: 3-2:2 
  chip ID: 5986:212a 
  Display: wayland server: 1.20.10 compositor: gnome-shell driver: i915 
  note: n/a (using device driver) - try sudo/root display ID: 0 
  resolution: <missing: xdpyinfo> 
  OpenGL: renderer: Mesa Intel UHD Graphics (ICL GT1) v: 4.6 Mesa 20.3.1 
  direct render: Yes 
  Device-1: Intel Smart Sound Audio vendor: Lenovo driver: sof-audio-pci 
  alternate: snd_hda_intel,snd_sof_pci bus ID: 00:1f.3 chip ID: 8086:34c8 
  Sound Server: ALSA v: k5.9.16-1-MANJARO 
  Device-1: Intel Killer Wi-Fi 6 AX1650i 160MHz Wireless Network Adapter 
  driver: iwlwifi v: kernel port: 3000 bus ID: 00:14.3 chip ID: 8086:34f0 
  IF: wlp0s20f3 state: up mac: <filter> 
  Local Storage: total: 465.76 GiB used: 17.2 GiB (3.7%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital 
  model: WDS500G3X0C-00SJG0 size: 465.76 GiB block size: physical: 512 B 
  logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 111110WD 
  temp: 37.9 C 
  ID-1: / raw size: 465.46 GiB size: 457.16 GiB (98.22%) used: 17.2 GiB (3.8%) 
  fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 
  ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 51.0 C mobo: 41.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 255 Uptime: N/A wakeups: 2 Memory: 7.44 GiB 
  used: 1.47 GiB (19.7%) Init: systemd v: 247 Compilers: gcc: 10.2.0 Packages: 
  pacman: 1242 lib: 369 flatpak: 0 Shell: Zsh v: 5.8 
  running in: gnome-terminal inxi: 3.2.01

Well dont ask me how but i got it to install. i was looking in the zips it spit out and one of them started installing the kernel. rebooted and the touchscreen now works

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.