Multi Monitor setup in Plasma broke after stable update 2021-07-28

I initially posted this as a comment under the stable update release post, but I didn’t get any response and I myself couldn’t manage to fix it either. So I’m opening a dedicated post for it.

The update which was released on 2021-07-28 broke my monitors in a bad and weird way. (detailed info of the versions at the bottom of the post).

Here is my monitor arrangement before this update:

The two vertical ones on the side are connected to Nvidea card via HDMI and the middle on is connected to on-board DVI port of motherboard.

When I rebooted the computer, the SDDM loaded and I had all monitors in the landscape, the left monitor was now on the right side of the middle monitor and the right monitor was a mirror of the middle one (primary)! The KDE panel was gone in the primary monitor, all the desktop wallpapers were changed to something (in both Plasma and SDDM). When I make the middle monitor primary via settings window, the KDE panel fills only half of the screen and it does not respond to left-click what so ever (the correct background is always only shown above the KDE panel which in case of this screenshot is the purple one!!):

I have rebooted multiple times and nothing got better. I booted into AwesomeWM and everything worked except the monitor arrangement which was behaving similar to SDDM.

Also the numlock status has been reset to default (off).

It seems that this update has badly damaged my SDDM config and my plasma config!

Any suggestion/fix is highly appreciated.

System info:

Operating System: Manjaro Linux
KDE Plasma Version: 5.22.4
KDE Frameworks Version: 5.84.0
Qt Version: 5.15.2
Kernel Version: 5.14.0-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-4770K CPU @ 3.50GHz
Memory: 15.5 GiB of RAM
Graphics Processor: NV136
❯  inxi --graphics
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics
  driver: i915 v: kernel
  Device-2: NVIDIA GP106 [GeForce GTX 1060 6GB] driver: nouveau v: kernel
  Device-3: Sunplus Innovation HD 720P webcam type: USB
  driver: snd-usb-audio,uvcvideo
  Display: x11 server: X.Org 1.20.11 driver: loaded: modesetting,nouveau
  unloaded: intel resolution: 1: 1080x1920~60Hz 2: 1080x1920~60Hz
  3: 1920x1080~60Hz
  OpenGL: renderer: NV136 v: 4.3 Mesa 21.1.5

Does Wayland work with 3 monitors?

I use two monitors, they work fine but only the wallpaper of the background was sometimes auto reset after login.

I haven’t try Wayland as some parts of my workflow are X-dependent (dmenu, xclip, …). I’m not sure if I want to mess up with my system and add Wayland to the mix as it might make the debugging harder.

What is the output of journalctl -b -p 0..3 ?


-- Journal begins at Sun 2019-10-20 19:49:53 EEST, ends at Sun 2021-08-01 13:45:39 EEST. --
Aug 01 12:13:23 Chrstphr sddm[691]: Failed to read display number from pipe
Aug 01 12:13:23 Chrstphr colord-sane[822]: io/hpmud/pp.c 627: unable to read device-id ret=-1
Aug 01 12:13:23 Chrstphr colord-sane[930]: io/hpmud/pp.c 627: unable to read device-id ret=-1
Aug 01 12:13:23 Chrstphr kernel: NVRM: The NVIDIA probe routine was not called for 1 device(s).
Aug 01 12:13:23 Chrstphr kernel: usb 3-9: Failed to query (GET_INFO) UVC control 6 on unit 1: -32 (exp. 1).
Aug 01 12:13:23 Chrstphr kernel: usb 3-9: Failed to query (GET_INFO) UVC control 8 on unit 1: -32 (exp. 1).
Aug 01 12:13:24 Chrstphr colord-sane[955]: io/hpmud/pp.c 627: unable to read device-id ret=-1
Aug 01 12:13:24 Chrstphr kernel: NVRM: The NVIDIA probe routine was not called for 1 device(s).
Aug 01 12:13:26 Chrstphr kernel: nouveau 0000:01:00.0: gr: intr 00000040
Aug 01 12:14:36 Chrstphr pulseaudio[1355]: module-rescue-stream is obsolete and should no longer be loaded. Please remove it from your configuration.
Aug 01 12:15:01 Chrstphr pulseaudio[1355]: GetManagedObjects() failed: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Could it help?

No because in my case SDDM actually works and in their case SDDM doesn’t even show. In my case these are what have been changed in SDDM:

  1. The monitor orientation are messed up
  2. monitor order and position are messed up
  3. monitor display type (a.k.a “Resplica of:”) was messed up (I didn’t have mirror and now I have!)
  4. the messed up SDDM monitor arrangement is identical to what Plasma showed after update nad reboot
  5. SDDM (and Plasma) background pictures were reset
  6. previously when SDDM was loaded, the keyboard focus was at the password field and now the focus is somewhere else and I have to click on the password field (also pressing Tab does not help)

I just installed plasma-wayland-session and plasma-wayland-protocols (from extra repo), rebooted and logged in to Plasma Wayland. Upon logging in, the desktop loads with Plasma panel but with the wrong desktop background for non-primary monitors. then when the “Wallet Manager” tries to confirm my GPG password to open the wallet, the computer becomes unresponsive (mouse seise to work, keyboard become unresponsive, even the numlock and capslock lights cannot be changed, even TTY does not open) and I have no choice but to hold the power button to turn it off.

All that said, it clearly shows that the situation is not Xorg specific as Wayland also shows wrong background and etc.

I then turned off the computer, disconnected the HDMI cable of the left most monitor and turned on the computer. All issues persists in Xorg and Wayland which shows either:

  1. the issue is not specific to users with more than 2 monitors
  2. the software damage that my computer suffered after this specific update has affected all settings that switching to Wayland and/or removing one monitor from the equation does not change improve the situation.

This issue was “fixed” with [Stable Update] 2021-08-09. There are still some issues with KDE but they are not as awful as what I was facing before.

For whoever having this issue, I should say that the screwed up SDDM and desktop wallpapers didn’t get changed to my old settings, but now I can set the middle monitor as primary and still get the full KDE panel at the bottom (previously it was just spanning across half of the middle monitor as depicted in the screenshot in the first post of this thread)

The issue I now have is that when I move a window from Nvidia monitor (e.g the one in the right) and I move it to the intel graphics monitor (the middle one), then the mouse cursor can get too far from the title bar of the window. Basically the movment of the window gets so laggy that it falls behind and cannot keep up with the mouse. The situation can get worse everytime I move the same window from one monitor to another.

A post was split to a new topic: Multi-monitor setup broken after manjaro-kde-settings update

I finally managed to fix this. The issue was/is/will be because of Nvidia driver as the opensource one is still suboptimal/buggy. To fix it:

  1. Open settings
  2. Go to Hardware Configurations
  3. Make sure every non-opensource driver is uninstalled (especially the bumblebee)
  4. Press "Auto Install Proprietary Driver
  5. Reboot

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.