MSI THIN G63 RTX 3050 Mobile, graphic installation help


Hi eveyone!

I"m using a msi thin gf63 rtx 3050 laptop, i’ve installed nvidia package from pacman but i cannot run nvidia-smi it cannot comminucate with the grahpic card

here’s the output of
inxi --admin --verbosity=7 --filter --no-host --width

I’m using i3wm & x11

For one thing the kernel 6.5 is EOL and you should install a supported kernel like 6.6 LTS, boot into it, and remove 6.5

For another, please show

mhwd -li -l

To show what mhwd profile is in use and which are available, as mhwd is what handles drivers on manjaro.

And of course, please make sure you are fully up to date, ex:

sudo pacman-mirrors -f && sudo pacman -Syu
1 Like

I did upgrade my kernel using mhwd-kernel now i’m running linux66.

Want to show a new inxi with the new kernel as well?
The original, as well as the mhwd output only show an intel.

Though the mhwd profile in use is a hybrid (prime) one.

If prime is working and there is a working nvidia, then you could test it like;

Normal execution (should output intel):

glxinfo | grep 'renderer string'

With prime-run (should output nvidia):

prime-run glxinfo | grep 'renderer string'
1 Like

➜  ~ git:(master) glxinfo | grep 'renderer string'

OpenGL renderer string: Mesa Intel(R) Graphics (ADL GT2)

The outputs dont show any nvidia device.

  Device-1: Intel Alder Lake-P GT1 [UHD Graphics] vendor: Micro-Star MSI
    driver: i915 v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+
    ports: active: eDP-1 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 00:02.0
    chip-ID: 8086:46a3 class-ID: 0300
  Device-2: Bison HD Webcam driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-6:3 chip-ID: 5986:211b
    class-ID: 0e02
  Display: x11 server: v: compositor: Picom v: git-89c2c
    driver: X: loaded: modesetting alternate: fbdev,vesa dri: iris gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-size: <missing: xdpyinfo>
  Monitor-1: eDP-1 model: ChiMei InnoLux 0x1521 built: 2020 res: 1920x1080
    hz: 144 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5")
    ratio: 16:9 modes: 1920x1080
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 1 drv: swrast surfaceless: drv: iris x11: drv: iris
    inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.6-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel Graphics (ADL GT2)
    device-ID: 8086:46a3 memory: 14.97 GiB unified: yes

Are you sure its in there?
And not disconnected?
Or disabled by BIOS?

What does this mean?
Maybe show us installed packages;

pacman -Qs nvidia
1 Like

local/egl-wayland 2:1.1.13-1
    EGLStream-based Wayland external platform
local/envycontrol 3.4.0-2
    Easy GPU switching for Nvidia Optimus laptops
local/lib32-libvdpau 1.5-2
    Nvidia VDPAU library
local/lib32-nvidia-utils 550.78-1
    NVIDIA drivers utilities (32-bit)
local/lib32-vulkan-nouveau 1:24.0.6-1
    Open-source Vulkan driver for Nvidia GPUs - 32-bit
local/libvdpau 1.5-2
    Nvidia VDPAU library
local/libxnvctrl 550.78-1
    NVIDIA NV-CONTROL X extension
local/mhwd-nvidia 550.78-1
    MHWD module-ids for nvidia 550.78
local/mhwd-nvidia-390xx 390.157-10
    MHWD module-ids for nvidia 390.157
local/mhwd-nvidia-470xx 470.239.06-1
    MHWD module-ids for nvidia 470.239.06
local/nvidia-dkms 550.78-1
    NVIDIA drivers - module sources
local/nvidia-prime 1.0-4
    NVIDIA Prime Render Offload configuration and utilities
local/nvidia-settings 550.78-1
    Tool for configuring the NVIDIA graphics driver
local/nvidia-utils 550.78-1
    NVIDIA drivers utilities
local/vulkan-nouveau 1:24.0.6-1
    Open-source Vulkan driver for Nvidia GPUs
local/xf86-video-nouveau 1.0.17-3 (xorg-drivers)
    Open Source 3D acceleration driver for nVidia cards

I don’t think I disabled it, but I can check in BIOS. But I think it’s not recognized that’s the issue.

You shouldnt have this.

So you did install drivers the wrong way.

sudo pacman -Rns nvidia-dkms
sudo mhwd -f -i pci video-hybrid-intel-nvidia-prime 

Then there is

Did you use envycontrol or try some other method to set iGPU only ?

1 Like

probably i did experiment with prime-select or something yes i used it, i just chedked the history
envycontrol -s integrated


> Removing video-hybrid-intel-nvidia-prime...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/local/pci/video-hybrid-intel-nvidia-prime/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing libxnvctrl breaks dependency 'libxnvctrl' required by conky
:: removing libxnvctrl breaks dependency '' required by conky
Error: pacman failed!
Error: script failed!

breaks conky what should i do? remove conky?

I guess so. You can reinstall it again afterwards.
We are just trying to get you on the correct packages (like linux66-nvidia, etc).
You will have the correct dependencies, but its technically uninstalling first.

That might explain it. Assuming there is a working nvidia to find that was there before.

sudo envycontrol -s hybrid

Will put you back in the normal ‘hybrid’ mode.
(By the way - this is how your system would be anyways by default without envycontrol. tools like envycontrol only provide you the ability to switch to iGPU-only or dGPU-only in an easy way)

1 Like

ok now i did

sudo pacman -Rdd conky

and followed your commadns

what’s the next step?

After you switch modes reboot and check your inxi again.
If there is an nvidia visible then check prime-run

When I restart my i3wm doens’t load my wm and it keeps blinking so I use to go to another tty7 and I can see there’s Nvidia 3050

what should I? not sure why the wm doesn’t load it keeps blinking here’s dmesg output

The inxi does list an nvidia now, which is good.

I dont know a whole lot about particulars of nvidia itself, but some blackscreen type issues have been associated with KMS (or the lack thereof).

no i mean i cannot load my wm anymore when i turn on hybrid, i rebuilt the kms and modules and grub again but still no luck, any ideas?

I understand that now with the nvidia no longer disabled you experience desktop errors.

I have mentioned KMS (and DRM-KMS) because they have been related to some nvidia issues. But I do not have an nvidia so I dont know all of their finer points. By the way the KMS instructions were not simply to rebuild intramfs but to ensure certain options are applied.

1 Like

i see nouveau is loading in xorg how can i force to use nvidia?

I highly doubt that is the issue and/or it is how you perceive it.

According to your inxi output for example the nvidia is set to use the proprietary module;

Device-2: NVIDIA GA107M [GeForce RTX 3050 Mobile] vendor: Micro-Star MSI
    driver: nvidia

Besides ensuring those paramaters like shown above my other guess would be another configuration left somewhere from previously. Like with envycontrol … have you placed any xorg configuration files or set any boot options? (and again there are probably boot options you should set, as linked above)

i added all the above link options, rebuild grub and HOOKS still no luck. I didnot change anything since I"M using Manjaro i3wm defaults.