Mouse cursor randomly jumps to screen edges

Hello all,

My mouse cursor randomly jumps to the edges of the screen (~ every minute). I have a Lenovo Yoga 7 (16ARP8) laptop and using the Logitech MX Master 2S with Solaar.

What I know currently about the error:

  • With the touchpad deactivated, it also happens but just less frequently (~ every 5 minutes)
  • The error also occurs without Solaar installed
  • This error occures since I bought this laptop and installed Manjaro (July 2023)

KDE Plasma: 5.27.8
Kernel: 6.1.55-1-MANJARO

Hi @chraebsli,

Try with the touchpad disabled in the BIOS/UEFI.

Hey @Mirdarthos

I just tried to disable the touchpad in the BIOS, but I couldn’t find a BIOS entry. Where would that be located in the BIOS?

It would depend on the manufacturer, there’s no specific one-size-fits-all, sorry.

But you can try it from Linux itself:

Is that the same as disabling the touchpad in the system settings? I have disabled it there:

I can say with all honesty:


(Using a desktop here, not a laptop.)


School started again this week and I had to use windows the last days ⇒ it appears that I also have this issue on Windows but only a few times per day.

Then I’m thinking it’s hardware…

1 Like

Yeah that was also my thought. I’m waiting on a reply from Lenovo.

1 Like

I joined just to say I have two 16ARP8 here that have the same issue since putting Windows 10 on them. Disabling touchpad and touchscreen and still has the same issue.

EDIT - Hopefully you see this since it wont let me reply again possibly notifying you. I have found the resolution.
I only tested these in Windows however.
If you boot the laptop on external display with internal closed, it never has the issue
If you disconnect the touch pad ribbon, it never has the issue
If you replace one of the I2C drivers in device manager forcing a synaptic driver, it never has the issue (but loses touchscreen)

Searching more, I found an issue regarding Wacom drivers, wacom driver replaces one of the I2C and touchpad and screen both work and the issue never occurs.

For you, this also answered for my windows but was a post regarding linux, I found this at

It appears to be related to the same driver but for linux users, but may give you the information you need to fix your side (i am not very linux savy)

Hello @Mirdarthos

Thanks for your reply; I will try your solution in the following days and let you know as soon I know more.

Furthermore, Lenovo is sending me some replacement parts, since it seems to be a hardware problem. I can replace them myself, with a technician advising me via a phone call (as far as I understood).
We came to this since I found a topic about a similar problem:

1 Like


I misunderstood this part because of a translation issue. He called me to schedule an appointment, and then he came to repair it at my place.

At first, Lenovo sent me a new mainboard which the technician them replaced. Since the problem wasn’t resolved, they sent me a spare touchpad and the technician replaced it a week later. The problem is still not resolved; eventually, it’s the cable that connects the touchpad with the mainboard (I don’t know why they didn’t send it with the touchpad :man_shrugging:).

Currently, I’m mailing with the German Premium Care Team hoping they will do something

Have a great day all!