Monitor connected through hdmi port is blank

Hi everyone,

I am new to this forum and I have just switched from windows and installed manjaro with i3. When I try to connect my 2 external monitors 1 of them which is connected through an c-type hub is working fine and in nvidia-settings is marked by it’s name, but the other one which is connected directly to my laptops HDMI port is not working (is detected by xrandr but it’s just a black screen, altough I can physically move my mouse on the screen) and in nvidia-setting is marked as PRIME display (to my knowledge it means it’s connected to iGPU instead of GPU). I tried to switch the cables and it seems that whichever monitor is connected through the c hub is recognised by it’s name but throught the hdmi only as PRIME display. The weird part is when I play around with arandr and move the monitors around sometimes it works, but I have no clue when and why.

I am runnnig it on rog zephyrus g14 laptop.

Thank you so much for any help in advance.

Welcome to the forum.

I’ll preface this by stating I only have superficial experience with i3 (during my distro-hopping phase). I can however, help you find information about your system that will assist others to work through it with you.

I’m guessing that you’re using Wayland and not X11 with i3. Firstly, I suggest you install inxi, if it’s not installed already:

$ pacman -S inxi
... or ...
# pamac install inxi
... if you have the AUR setup on your machine

Once inxi is installed, use it to discover your graphic related devices. In Terminal enter this command, from memory (enter man inxi if I got it wrong):

$ inxi -G

Inxi should report information about your devices, as mentioned. Look through that information and you can easily see whether Wayland or X11 is being used. This information may be useful later.

To save that information to a text file, use the command in this format:

sudo inxi -G > inxi_output.txt

Assuming you did that in your home directory, that’s where you’ll find the text file when generated. You can refer to that file if someone needs more information; and they will.

That’s all I can do for you right now, but I’m sure someone else will carry on from here. Cheers.

Thank you for your time, here is the info:

Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] driver: nvidia
v: 535.104.05
Device-2: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
driver: amdgpu v: kernel
Display: x11 server: X. org v: with: Xwayland v: 23.2.0 driver: X:
loaded: modesetting,nvidia dri: radeonsi gpu: amdgpu,nvidia,nvidia-nvswitch
resolution: 1: 1680x1050~60Hz 2: 1920x1080~60Hz 3: N/A
API: EGL v: 1.5 drivers: nvidia platforms: gbm
API: OpenGL v: 4.6.0 vendor: nvidia v: 535.104.05 renderer: NVIDIA
GeForce RTX 3060 Laptop GPU/PCIe/SSE2

Does this thread help?

Or of any of these?

I followed the instructions but nothing worked, also I don’t have a etc/gdm folder on my system. I tried some more from your link, but so far no luck. :pensive:

What does xrandr --listproviders say?

It says:

Providers: number : 2
Provider 0: id: 0x1b7 cap: 0x1, Source Output crtcs: 4 outputs: 2 associated prov
Provider 1: id: 0x1fc cap: 0xf, Source Output, Sink Output, Source Offload, Sink

Most likely it’s the other way around, hdmi is hardwired to the nvidia. Also see here:
Second monitor on Asus ROG Zephyrus with AMD & Nvidia graphics .
HDMI not working on mux-switch laptop .

I also believe people had better luck using envycontrol instead of optimus-manager to avoid the issue. Keep in mind that this AUR package has already been made available in the manjaro repos, it’s in testing right now:
More tools for Optimus laptops are now available .

Thank you so much! envycontrol -s nvidia fixed it :partying_face:
Still don’t know why it wasn’t working with optimus-manager tho, because I also specified optimus-manager --switch nvidia.

Regardless, thank you!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.