Missing Application Icon (Spotify - Snap) after recent Upgrade - Pahvo

After the recent OS Upgrade (Pahvo) my Spotify (Snap) Application Icons have gone missing (Workspace Switcher,Window Cycling,Title bar, Window Menu).

What’s surprising is that the Window Button’s icon is still in place. (although I think it’s also a bit different now)

Having the same issue with Microsoft Teams - but already way before the upgrade.

Thank you so much for any help on this!

1 Like

:+1: Welcome to Manjaro! :+1:

I have read this already and left you just a :open_mouth: as I don’t use and don’t like snaps (and I’m on KDE)

However, as you haven’t received any responses so far:

Have you tried using a native application instead of a snap already? (E.G From the AUR)


Hey Fabby,
glad to be on board! :+1:
So far I tried flatpak and AUR as alternative. both display the same issue.

Then the only thing to do is to read this:

Especially the What’s this Upstream / Downstream business section and file a bug upstream…

Please note that a quality bug needs the same kind of information we require here:


1 Like

I assume it’s an upstream issue (yeah, I learned a new term! Merci :pray:)

Same/Similar issue seems to exist on Fedora and KDE. Also this happened after they updated the application. Snap, flatpak and AUR got updated nearly simultaneously and are all based on the same .deb image i guess?

I reported it on the spotify community.

when running spotify via terminal that’s the output (using AUR):

/opt/spotify/spotify: /usr/lib/libcurl-gnutls.so.4: no version information available (required by /opt/spotify/spotify)
/opt/spotify/spotify: /usr/lib/libcurl-gnutls.so.4: no version information available (required by /opt/spotify/spotify)
/proc/self/exe: /usr/lib/libcurl-gnutls.so.4: no version information available (required by /proc/self/exe)

Even though I guess it cant be fixed here, still here’s my inxi output:

  Kernel: 5.14.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.14-x86_64 
  root=UUID=da7cfa18-3d1b-4ba2-874d-965399aeaeec ro quiet apparmor=1 
  security=apparmor resume=UUID=dac21756-7942-48b3-8aa0-9246f911e961 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 7 
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
  RAM: total: 15.55 GiB used: 2.82 GiB (18.1%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Quad Core model: Intel Core i7-8809G bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: 9 microcode: EA 
  cache: L2: 8 MiB bogomips: 49618 
  Speed: 800 MHz min/max: 800/8300 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 5: 800 6: 800 7: 800 8: 800 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat 
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts 
  rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 
  sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel HD Graphics 630 driver: i915 v: kernel bus-ID: 00:02.0 
  chip-ID: 8086:591b class-ID: 0380 
  Device-2: AMD Polaris 22 XT [Radeon RX Vega M GH] vendor: Intel 
  driver: amdgpu v: kernel bus-ID: 01:00.0 chip-ID: 1002:694c class-ID: 0300 
  bus-ID: 1-3:2 chip-ID: 045e:0761 class-ID: 0102 
  Display: x11 server: X.Org 1.20.13 compositor: xfwm4 v: 4.16.1 driver: 
  loaded: amdgpu,ati,modesetting alternate: fbdev,vesa display-ID: :0.0 
  screens: 1 
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.0x11.2") 
  s-diag: 1055mm (41.5") 
  Monitor-1: DisplayPort-2 res: 1920x1080 dpi: 93 size: 527x296mm (20.7x11.7") 
  diag: 604mm (23.8") 
  Monitor-2: DisplayPort-5 res: 1920x1080 dpi: 93 size: 527x296mm (20.7x11.7") 
  diag: 604mm (23.8") 
  OpenGL: renderer: AMD VEGAM (DRM 3.42.0 5.14.2-1-MANJARO LLVM 12.0.1) 
  v: 4.6 Mesa 21.2.1 direct render: Yes 
  Processes: 258 Uptime: 11h 48m wakeups: 1 Init: systemd v: 249 
  tool: systemctl Compilers: gcc: 11.1.0 Packages: 1195 pacman: 1180 lib: 356 
  flatpak: 7 snap: 8 Shell: Bash v: 5.1.8 running-in: xfce4-terminal 
  inxi: 3.3.06 

Still any Idea or suggestion how to proceed? Merci

1 Like

De rien… :wink:

Therefore, I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.