Minecraft stutters and then goes black, forcing to restart

I’m pretty new to linux, friend recommended manjaro since they use it and it seemed ok for me to use too, been around a month and I dig it honestly, but I have this problem with just one game, one of the only I play, Minecraft.
This happens pretty much at random but that random seems to be more frequent than the good times when the game doesn’t stutter, then go black.
I’ve tried this thing where i turn a compositor setting that lets apps block it, since I’ve seen it work for someone, didn’t work for me.
What else can I try?

Hello @nepvll,

first it would help to know more about your system. So can you pls post the output from this command:

inxi --admin --verbosity=7 --filter --width

The long text about is here:

Best regards. :slightly_smiling_face:

  Kernel: 6.5.9-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.5-x86_64
    root=UUID=084a07c7-5e7b-4b4e-bf7e-70f6c7836b4f rw quiet splash
    resume=UUID=403e022e-03fb-4a4e-9e15-43cd02134f23 udev.log_priority=3
  Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: ASUSTeK product: X541UV v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: X541UV v: 1.0 serial: <superuser required>
    UEFI: American Megatrends v: X541UV.309 date: 04/17/2019
  ID-1: BAT0 charge: 16.1 Wh (100.0%) condition: 16.1/34.6 Wh (46.6%)
    volts: 10.8 min: 10.8 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
    status: not charging cycles: 1460
  Device-1: hidpp_battery_0 model: Logitech G305 Lightspeed Wireless Gaming
    Mouse serial: <filter> charge: 55% (should be ignored) rechargeable: yes
    status: discharging
  Info: model: Intel Core i5-6198DU bits: 64 type: MT MCP arch: Skylake
    gen: core 6 level: v3 note: check built: 2015 process: Intel 14nm family: 6
    model-id: 0x4E (78) stepping: 3 microcode: 0xF0
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 2700 min/max: 400/2800 scaling: driver: intel_pstate
    governor: powersave cores: 1: 2700 2: 2700 3: 2700 4: 2700 bogomips: 19204
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling status: Vulnerable: No microcode
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: conditional,
    RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel HD Graphics 510 vendor: ASUSTeK driver: i915 v: kernel
    arch: Gen-9 process: Intel 14n built: 2015-16 ports: active: eDP-1
    empty: DP-1,HDMI-A-1,HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:1906
    class-ID: 0300
  Device-2: NVIDIA GM108M [GeForce 920MX] vendor: ASUSTeK driver: nvidia
    v: 535.129.03 alternate: nouveau,nvidia_drm non-free: 545.xx+ status: current
    (as of 2023-11; EOL~2026-12-xx) arch: Maxwell code: GMxxx
    process: TSMC 28nm built: 2014-2019 pcie: gen: 1 speed: 2.5 GT/s lanes: 4
    link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:134f
    class-ID: 0302
  Device-3: Realtek [] driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s
    lanes: 1 mode: 2.0 bus-ID: 1-6:3 chip-ID: 0bda:57de class-ID: 0e02
    serial: <filter>
  Display: x11 server: X.Org v: 21.1.9 compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia unloaded: nouveau alternate: fbdev,nv,vesa
    dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: eDP-1 model: AU Optronics 0x45ec built: 2015 res: 1366x768
    hz: 60 dpi: 101 gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5")
    ratio: 16:9 modes: 1366x768
  API: EGL Message: No EGL data available.
  API: OpenGL v: 4.6 vendor: intel mesa v: 23.1.9-manjaro1.1 glx-v: 1.4
    es-v: 3.2 direct-render: yes renderer: Mesa Intel HD Graphics 510 (SKL GT1)
    device-ID: 8086:1906 memory: 7.45 GiB unified: yes
  API: Vulkan v: 1.3.269 layers: 5 device: 0 type: discrete-gpu
    name: NVIDIA GeForce 920MX driver: nvidia v: 535.129.03 device-ID: 10de:134f
    surfaces: xcb,xlib device: 1 type: integrated-gpu name: Intel HD Graphics
    510 (SKL GT1) driver: mesa intel v: 23.1.9-manjaro1.1 device-ID: 8086:1906
    surfaces: xcb,xlib
  Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_soc_avs
    bus-ID: 00:1f.3 chip-ID: 8086:9d70 class-ID: 0403
  API: ALSA v: k6.5.9-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.83 status: off with: pipewire-media-session
    status: active tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: ASUSTeK
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000
    bus-ID: 02:00.2 chip-ID: 10ec:8136 class-ID: 0200
  IF: enp2s0f2 state: down mac: <filter>
  Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter vendor: Lite-On
    driver: rtl8723be v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: c000
    bus-ID: 03:00.0 chip-ID: 10ec:b723 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  Device-1: Realtek [] driver: btusb v: 0.8 type: USB rev: 2.1 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 1-8:4 chip-ID: 0bda:b721 class-ID: e001
    serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 447.13 GiB used: 75.86 GiB (17.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37480G
    size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: P1.5 scheme: GPT
  ID-1: / raw-size: 438.03 GiB size: 430.09 GiB (98.19%)
    used: 75.86 GiB (17.6%) fs: ext4 dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda3 maj-min: 8:3
  System Temperatures: cpu: 66.0 C pch: 55.5 C mobo: N/A
  Fan Speeds (rpm): cpu: 2800
  Processes: 201 Uptime: 4m wakeups: 0 Memory: total: 8 GiB available: 7.63 GiB
  used: 1.99 GiB (26.1%) Init: systemd v: 254 default: graphical
  tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6 Packages: 1172
  pm: pacman pkgs: 1165 libs: 327 tools: pamac pm: flatpak pkgs: 7 Shell: Zsh
  v: 5.9 default: Bash v: 5.2.15 running-in: konsole inxi: 3.3.31

now what do i do?

Hm, I didnt play minecraft for a long time and dont have it installed to test it on my machine.

So can you also tell

  • if it only happens when you laptop only runs on battery?
  • in what way you start the game (wine, lutris, bottles …)?
  • do you use Java-Edition of minecraft?
  • do you use modification for minecraft?

Previously I can remember that minecraft (Java-Edition) needs a lot of ram/cpu and less gpu. Perhaps using nvidia-gpu to run helps you further.

I always run my laptop plugged in, I barely move it from my desk. I even have a cooling dock for it so it keeps the temps a bit lower, too expensive and time consuming to fiddle around changing thermal paste since it’s pretty old, but this is irrelevant.

I start the game via the minecraft launcher, from AUR, which i installed from the Add/Remove Software app.

Yes, I only play java since bedrock edition doesn’t work, says it’s only available for windows.

Yes, i use modifications for minecraft, latest Fabric loader since FPS is better and more stable compared to Forge. A few performance mods here and there and maybe a visual mod, or idk how to call it, furniture or whatever. But the thing is, i even ran it with optifine (latest ver. for 1.20.2, which is the same version i play on Fabric) and it still did this thing where it goes black after stuttering.

How can I make the game run on my dedicated nvidia gpu? I never figured out how, using a couple different tutorials, one of which breaking my distro and forcing to reinstall everything, lol.

If everything is installed correctly you can use ‘prime-run’ to do that.

prime-run minecraft

… for example, if you can start minecraft by typing ‘minecraft’ in the terminal. But I dont have any experience with hybrid GPUs, so I dont know if this work well and especially with minecraft.

The technique for hybrid-gpu with nvidia-gpu is called ‘prime’. Older software to manage this is called ‘bumblebee’ and recently software used is ‘optimus-manager’. If you want to get deeper to this. :slightly_smiling_face:

I would also recommend to edit the topic by adding ‘minecraft’ to it. So possibly someone with more minecraft experience get attention on your post.


yeah so apparently this pops up when i open terminal and type that command

/usr/bin/prime-run: line 2: minecraft: command not found

what do?

That means ‘minecraft’ is not the right command to start minecraft. You can try ‘minecraft-launcher’ instead of ‘minecraft’ or take a look in the starter with which command you system starts minecraft.

It indeed was minecraft-launcher, thank you. This also fixed my original problem where it stuttered and went to a black screen, thank you.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.