Mhwd nvidia install fails

I get the following when I attempt to install the nvidia drivers with mhwd

sudo mhwd -i pci video-nvidia
> Installing video-nvidia...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/nvidia/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
:: Synchronizing package databases...
 mesa-nonfree downloading...
 core downloading...
 extra downloading...
 community downloading...
 multilib downloading...
error: target not found: linux63-nvidia
Error: pacman failed!
Error: script failed!

What do I need to look for to trouble shoot?

Hi @drmacro,

I know I’ve seen you around, so it kind of surprises me that I have to point this out/ But

That is for kernel 6.3 which has been EOL since July, which leads me to believe you haven’t kept you system up to date or this wouldn’t have happened. And that means you’ve been a bad, naughty boy.

You’d need to upgrade your kernel to a supported version, and try again…


1 Like


mhwd-kernel -li 
Currently running: 6.4.14-1-MANJARO (linux64)
The following kernels are installed in your system:
   * linux61
   * linux63
   * linux64

Well, there’s yer prawblem


So, the mhwd is attempting to do something with all installed kernels?

Do I just remove 6.3?

linux63 and linux64 are EOL, pls remove both.

start your system with kernel 6.1 ?!

terminal command:
sudo mhwd-kernel -r linux63 linux64

after this…use LTS kernel 6.1 or install linux65 with
sudo mhwd-kernel -i linux65

1 Like

You can, yes.

But note, 6.4 isn’t LTS so will also reach EOL relatively soon. To remove 6.3:

sudo mwhd-kernel --remove linux63

Ok, so now 63 and 64 are gone.
65 is installed

64 still shows in grub, 65 does not.

I am currently running 61.

But hey, the mhwd nvidia install didn’t fail.

update-grub didn’t change the kernels listed from advance grub menu.

How do I switch to 65 and make it default for boot. (note: possibl bad search terms but, haven’t found anything that addresses this…)

Please provide the output of the following:

mhwd-kernel --listinstalled


ls -l /boot/
mhwd-kernel --listinstalled                                                            ✔  38s  

Currently running: 6.1.51-1-MANJARO (linux61)
The following kernels are installed in your system:
   * linux61
   * linux65

ls -l /boot/                                                                                   ✔ 
total 137536
-rw-r--r-- 1 root root    81920 Aug 10 08:27 amd-ucode.img
drwxr-xr-x 6 root root     4096 Sep 14 08:13 grub
-rw------- 1 root root 41728955 Sep 14 07:23 initramfs-6.1-x86_64-fallback.img
-rw------- 1 root root 15051832 Sep 14 07:23 initramfs-6.1-x86_64.img
-rw------- 1 root root 44420603 Sep 14 07:55 initramfs-6.5-x86_64-fallback.img
-rw------- 1 root root 15168550 Sep 14 07:55 initramfs-6.5-x86_64.img
-rw-r--r-- 1 root root       21 Sep  2 16:55 linux61-x86_64.kver
-rw-r--r-- 1 root root       20 Sep  2 16:55 linux65-x86_64.kver
drwxr-xr-x 2 root root     4096 Aug  4 14:19 memtest86+
-rw-r--r-- 1 root root 11523904 Sep 10 08:03 vmlinuz-6.1-x86_64
-rw-r--r-- 1 root root 12835488 Sep 14 07:55 vmlinuz-6.5-x86_64

I see both are installed. That’s good. By default Manjaro will boot with the latest version, so 6.5 in your case. You can confirm it with:

uname -r

For example:

$ uname -r

Here you can see I’m using kernel version 6.5.

To switch kernel versions, see here:

Also see that article for proper kernel management.

1 Like

I think what’s happening is the grub is actually coming from the other drive in the PC which has Debian12.

I think I need to do an update-grub when booted to Debian.

But, I’m not sure which Manjaro kernel that will set as default.

There are many threads on the forum about dual boot Linux distros, just search a bit.

I can’t help, since I’ve only got the one OS here…


1 Like

I’m aware of how to dual boot.

It’s the bios on this mobo.

I have never been able to get it to recognize the drive Manjaro is on as bootable. So, it doesn’t show in the bios.

Well, my dear sir, considering my use of different operating systems on the same computer:


1 Like

@Mirdarthos :arrow_lower_right:

@drmacro :arrow_right: Bunny Slap


Manjaro’s GRUB needs to be in control, so you will have to reinstall GRUB, rather than just update its configuration. However, given that you state… :arrow_down:

… it is quite possible that you’ve got one distribution installed in native UEFI mode and the other one in legacy BIOS emulation mode (also known as CSM, “Compatibility Support Module”).

Either way, it wouldn’t hurt to try… From within Manjaro, issue the following commands… :arrow_down:

sudo grub-install --recheck  --bootloader-id=Manjaro
sudo update-grub
1 Like

Very funny…my bad for not knowing an unused kernel would be an issue.

No doubt this is the case. But, I’ve spent inordinate fussing with settings in this bios like CSM, to no avail.

In this day and age, I would completely disable CSM altogether. But considering that your system most likely has a mix of installations, it’s too late for that now. :frowning_man:

Yeah, the Debian drive was there before I added the second drive and installed Manjaro.

I think, though not sure, the Debian has been updated a couple releases and the original (Debian 10?) did support EFI. So, it has never changed since it has just been OS updated along the way to Deb12.

Some day I’ll probably just clear the drives and start over.

In any case, I booted to Debian, did a update-grub, it found Manjaro again and now Manjaro boots to 65.

Thanks to all for the help!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.