Meta key suddenly stopped working

I didnt update the system or anything the meta key which i use in a lot of shortcuts suddenly stopped working for me.

I tried:

  • rebooting

  • adding the meta= to the ~/.config/kwinrc file.

  • changing the shortcuts to Alt+F1

  • Changing the layout of the keyboard from 86keys to 105 (although it did work in the 86 configuration)

None of which worked.
I’d appreciate any help

Hi @yarinbar, and welcome!

This might sound like a silly question, but I’m going to ask it anyway. Have you tried with a different keyboard?

I tried the one on the laptop and the one attached to it so two kb in total.

And none of them worked? Hmmm

Well, I’ve never heard of something like that, so I don’t know what to do, except see if the keypress is “received”. Open a terminal, and run: :point_down:

sudo showkey

This will then show all keypresses for 10 seconds, after which it will quit by itself.

That’ll give you an indication if it’s a hardware or software issue your facing.

Ok , apparently only the usb kb is faulty, but what is weird is that it doesnt register BOTH meta keys (i have 2) which makes me think its not a HW problem

Edit - I mean i deasnt make sense that both keys stopped working, I will try it on a different computer

That does sound like the correct conclusion, yes.

Unfortunately, I have no other advice for you, except to see if it persists across reboots. Sorry.

:sob:

That is a good idea, yes!

check if this helps:

disconnecting my kb and reconnecting fixed it. Ill never understand hardware :sweat_smile:

Luckily that’s not our job…

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.