Megasync fail to run

Hello everyone. The last few days, megasync can’t run. When I try to run it through the console I get the following error:

megasync: error while loading shared libraries: cannot open shared object file: No such file or directory

Reading some pages, its seems that Megasync requires OpenSSL 3, but when I reinstall megasync, openssl 3 does not install as a dependency. Can you help me?

1 Like

Here’s the duplicate:


Thanks. I’ll take a look.

I uninstall megasync, then I reinstalled it again following Desktop App - MEGA, but the error is still the same. I’ll going to look the original post.

As this is a custom build script - you will have to wait for the maintainer to update the script or you can clone and modify yourself.

The package you can fetch from Megasync web is for Archlinux. If you want to sync a package like this you will have to be closer to Arch - e.g. switching to unstable branch - otherwise requirements may not be met.

As workaround I installed downgrade to install megasync 4.7.1 =(

Hi, could you say how you installed megasync 4.7.1?

Have you tried megasync-bin instead
AUR (en) - megasync-bin
I got fed up with issues and have had zero issues since switching to the bin version

I installed that version with “downgrade”.

yay -S downgrade
sudo downgrade megasync

The app is able to launch after the new stable update

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.