Manjaro XFCE sometimes freezes before login when booting

Hello, I am a new Linux user and I have recently installed Manjaro XFCE on my Dell Inspiron 7559 laptop. I am loving it so far but I have been experiencing some random freezing during booting, and I couldn’t find a similar issue on the forum. I would guess about 50% of the time my laptop will freeze just after the filesystem check before login, and I will have to hold down the power button to shut it off and try again. Sometimes I have to do this several times before I can log in. Once I do log in, my experience is perfectly fine, no freezes or crashes. When it does freeze, it is completely frozen and I am unable to get to a tty by using Ctrl+Alt+F2 or access logs in any way.

I was wondering if this might be a graphics driver issue when loading the login screen since my laptop requires the Intel-NVIDIA hybrid drivers, because as I understand it the NVIDIA dGPU has to pass its output through the Intel iGPU to the screen output. However I reinstalled the drivers and I’m still having the same issue.

Any help would be appreciated. Is there a way to get logs from a previous unsuccessful boot after I have logged in?

journalctl --list-boots
journalctl --boot -1 --no-pager

Question: Is it Kernel 5.13?

Maybe this could help:

Replace MODULES=() with:


at /etc/mkinitcpio.conf. (i915 → Intel driver)

Then run sudo mkinitcpio -P to update the initramfs and reboot.

Just for the record. Here is a similar problem: Manjaro XFCE works on my HDD but freezes shortly after login on my SSD With Dell G3 3579 Any Relation?

Thanks for the commands, that is exactly what I was looking for. The last few lines from the last unsuccessful boot are:

Aug 18 16:24:56 laptop systemd[1]: Reached target Multi-User System.
Aug 18 16:24:56 laptop systemd[1]: Reached target Graphical Interface.
Aug 18 16:24:56 laptop systemd[1]: Starting TLP system startup/shutdown...
Aug 18 16:24:56 laptop kernel: snd_hda_intel 0000:00:1f.3: enabling device (0000 -> 0002)

So it looks like some kind of cpu loading issue. The kernel I am using is 5.10.

I followed your instructions for mkinitcpio, and I’ve rebooted about 5 times in a row successfully now. So I think that probably fixed it! Thanks.

BTW I don’t think that issue you linked is related, mine freezes before I have any graphical interface with the computer.


Ok, the term “freeze” is wrong then… lightdm “crashed” is a better term. But however… glad it worked for you :wink:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.