Manjaro XFCE installed on VBox 7.0.6 sometimes hangs

I have installed Manjaro (22.0.3, updated to newest) as a VM on VBox 7.0.6. Host is Win10. Most of the time Manjaro starts up as expected.
Sometimes (now, too) the start up hangs by showing a black screen with 3 flashing dots and “manjaro” at the bottom.
i can ACPI-Shutdown.
Sometimes a new start up works fine. Sometimes not. Currently, hanging is reproducible.

In the past I deleted the VM and worked with an older backup of the VM until it happens again. But I loose some data in that case.

Is there any way to locate the reason for this behavior?

Too many unknown variables:

  • no hardware info at all
  • Win10 host - the VM didn’t change and it worked, then it didn’t - would prompt me to look at the host and what it is doing
  • memory settings of the VM - is there enough RAM allocated - or too much so the host doesn’t have enough
  • logs of the VM - you can boot it into a non graphical mode if the normal one doesn’t work
    then investigate why the guest is having problems and what seems to be the reason

It may be the plymouth splash causing the issues - the combination of firmware splash and plymouth - I think you may find a similar issue using the search function.

Yes - here it is - After update, manjaro vm does not boot to gui reliably - #8 by linux-aarhus

When you have the system started succesfully open a terminal and edit

  1. /etc/default/grub → remove splash → save the file
  2. /etc/mkinitcpio → hooks section - remove plymouth → save the file

Rebuild grub

sudo update-grub -o /boot/grub/grub.cfg

Rebuild init

sudo mkinitcpio -P


Without any change and after 6 restarts in about 2 days Manjaro started as expected. Without any change, even not to the Win10 host (I worked on a different hardware these days.).

However, I applied the suggested changes to grub and hope, I will never see this problem again.
Thanks linux-aarhus .