After update, manjaro vm does not boot to gui reliably

After an update my virtual machine does not boot into xfce any more. This is a fresh vm from today.
Steps to reproduce:

  • Use virtualbox (up to date 7.0.8 r156879)
  • manjaro-xfce-22.1.3-230529-linux61.iso
  • boot and run installer
    • efi-install
    • 1GB fat as /boot/efi, 200GB btrfs as /
  • boot into vm
    Until now everything works !

  • reboot vm
  • press ESC to get into grub
  • boot into timeshift-snapshot from before the update
  • everything works


pressing F12 while booting led to one successfull boot :flushed:
next boot, no such luck :man_shrugging:

pressing F12 while the kernel starts leads to success

If I don’t disturb the kernel when booting, I don’t end up in the GUI, just have the boot animation forever. No further reaction, neither to function keys, nor mouse or keyboard.

If F12 is pressed several times during boot, the kernel boot log becomes visible. The screen flips several times, but ends up in xfce. After that everything is normal

Why are you using EFI in a VM? I’ve never had that work right.

Disclaimer: I gave up on VirtualBox and use GNOME Boxes currently.

I tried to simulate a “standard Manjaro installation” as close as possible to someone doing this in real life on hardware (where UEFI is standard today) :wink:

So I would get grub in the EFI partition instead of the bootloader or somewhere else.

For what it is worth, I have the same requirement as Andreas and am using libvirt/qemu to build a virtual with UEFI. I’ve found this works reliably and is a single option in the settings when creating a new VM using Virtual Machine Manager. (I try/test config changes before changing the config on my host, and main, system)

1 Like

I have been using UEFI with my VMs in VMWare and Virtualbox the last… 2 years? And everything has been fine. In VMWare is the default for Win guests.

I had an issue with a Manjaro XFCE virtualbox VM ( Manjaro XFCE Unstable host) yesterday. Due to the repositories changeover, I think. The system wants to upgrade packages that I know are in the official repositories to the AUR version(s). An example is menulibre, where it wants to install the same package with the epoch naming format. I didn’t want a bunch of AUR packages as substitutes, so I switched to Unstable. After I updated to Unstable, I couldn’t get scaling to work as it did before and I was seeing Virtualbox errors during boot and “stopping vboxadd.service” issue on shutdown. This VM is also a efi install that worked fine previously. I didn’t try too hard to fix it as it was just a test VM for my new computer (efi) install which I had never tried before. I have restored the VM from a backup and will stay on Stable until this repositories thing gets sorted out. Currently it needs 405 updates.

To work around the problem, I now saved the VM in the running state. Even if I have to reinstall something, I will avoid every boot as far as possible.

That’s enough for my investigations

I know there is some huddlihut with plymouth and virtualbox vm - I don’t know what it is but I know what workaround to apply.

  1. Restart your vm - and hit Esc to enter too Grub menu.
  2. Edit your command and remove quiet, splash and udev.log_priority=3 - press F10 to boot the vm.
  3. Edit your /etc/default/grub and edit the command to remove the above arguments.
  4. Save and rebuild your grub config grub-mkconfig -o /boot/grub/grub.cfg
1 Like

Did these 2 steps. Reboot was successful at first try. :smiling_face_with_three_hearts:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.